summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-07-07 01:59:50 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-07-07 01:59:50 +0000
commitd7b0a8967d9c99e705f0af2772671c0465c28762 (patch)
treebbb87f5bc1d0c96c7f516564e9f8c01ca73bcfe1 /net-misc
parentVersion bumped. (diff)
downloadgentoo-2-d7b0a8967d9c99e705f0af2772671c0465c28762.tar.gz
gentoo-2-d7b0a8967d9c99e705f0af2772671c0465c28762.tar.bz2
gentoo-2-d7b0a8967d9c99e705f0af2772671c0465c28762.zip
fix clean up a bit
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/l7-filter/ChangeLog5
-rw-r--r--net-misc/l7-filter/l7-filter-2.12.ebuild19
2 files changed, 19 insertions, 5 deletions
diff --git a/net-misc/l7-filter/ChangeLog b/net-misc/l7-filter/ChangeLog
index fc640dbf4bd5..62b672f9a6cc 100644
--- a/net-misc/l7-filter/ChangeLog
+++ b/net-misc/l7-filter/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/l7-filter
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/l7-filter/ChangeLog,v 1.48 2007/07/07 00:31:11 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/l7-filter/ChangeLog,v 1.49 2007/07/07 01:59:50 dragonheart Exp $
+
+ 07 Jul 2007; Daniel Black <dragonheart@gentoo.org> l7-filter-2.12.ebuild:
+ fix clean up a bit
*l7-filter-2.12 (07 Jul 2007)
diff --git a/net-misc/l7-filter/l7-filter-2.12.ebuild b/net-misc/l7-filter/l7-filter-2.12.ebuild
index 53436623667f..3fe6f6404fdf 100644
--- a/net-misc/l7-filter/l7-filter-2.12.ebuild
+++ b/net-misc/l7-filter/l7-filter-2.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/l7-filter/l7-filter-2.12.ebuild,v 1.1 2007/07/07 00:31:11 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/l7-filter/l7-filter-2.12.ebuild,v 1.2 2007/07/07 01:59:50 dragonheart Exp $
inherit linux-info eutils
@@ -153,15 +153,26 @@ pkg_postinst() {
pkg_prerm() {
# How to determine what version it was installed against? - measily
- eval $(/bin/fgrep KV=2 ${ROOT}/var/db/pkg/net-misc/${PF}/environment |\
- /bin/head -1)
+ if [ -f ${ROOT}/var/db/pkg/net-misc/${PF}/environment ]; then
+ eval $(/bin/fgrep KV=2 ${ROOT}/var/db/pkg/net-misc/${PF}/environment |\
+ /bin/head -1)
+ elif [ -f ${ROOT}/var/db/pkg/net-misc/${PF}/environment.bz2 ]; then
+ eval $(/bin/bzfgrep KV=2 ${ROOT}/var/db/pkg/net-misc/${PF}/environment.bz2 |\
+ /bin/head -1)
+ elif [ -f ${ROOT}/var/db/pkg/net-misc/${PF}/environment.gz ]; then
+ eval $(/usr/bin/zfgrep KV=2 ${ROOT}/var/db/pkg/net-misc/${PF}/environment.gz |\
+ /bin/head -1)
+ else
+ die 'could not find previous version'
+ fi
KV_DIR=/usr/src/linux-"${KV}"
if [ -d ${KV_DIR} ]; then
ewarn "${KV_DIR} nolonger exists"
return 0;
fi
echo "KV_DIR=$KV_DIR"
- if [ -f ${KV_DIR}/include/linux/netfilter_ipv4/ipt_layer7.h ]
+ if [ -f ${KV_DIR}/include/linux/netfilter_ipv4/ipt_layer7.h ] || \
+ [ -f ${KV_DIR}/include/linux/netfilter/xt_layer7.h ]
then
einfo 'attempting to unpatch l7-patch from kernel ${KV_FULL}'
which_patch