summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-08-22 04:36:54 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-08-22 04:36:54 +0000
commitccd1c77842d2234c5af1e24239a138c437094592 (patch)
treee2b9fa5521b93813a2ce607ac1ac8f1eccf618ce /net-misc
parentbup (diff)
downloadgentoo-2-ccd1c77842d2234c5af1e24239a138c437094592.tar.gz
gentoo-2-ccd1c77842d2234c5af1e24239a138c437094592.tar.bz2
gentoo-2-ccd1c77842d2234c5af1e24239a138c437094592.zip
bup and possible fixes for bug 518814 and bug 520332
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/radvd/ChangeLog7
-rw-r--r--net-misc/radvd/radvd-2.5.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/net-misc/radvd/ChangeLog b/net-misc/radvd/ChangeLog
index 3f7ad07f139d..065eaaa4db21 100644
--- a/net-misc/radvd/ChangeLog
+++ b/net-misc/radvd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/radvd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/ChangeLog,v 1.123 2014/07/30 22:12:53 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/ChangeLog,v 1.124 2014/08/22 04:36:54 prometheanfire Exp $
+
+*radvd-2.5 (22 Aug 2014)
+
+ 22 Aug 2014; Matthew Thode <prometheanfire@gentoo.org> +radvd-2.5.ebuild:
+ bup and possible fixes for bug 518814 and bug 520332
*radvd-2.3 (30 Jul 2014)
diff --git a/net-misc/radvd/radvd-2.5.ebuild b/net-misc/radvd/radvd-2.5.ebuild
new file mode 100644
index 000000000000..dc149f478504
--- /dev/null
+++ b/net-misc/radvd/radvd-2.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-2.5.ebuild,v 1.1 2014/08/22 04:36:54 prometheanfire Exp $
+
+EAPI=4
+
+inherit systemd user eutils
+
+DESCRIPTION="Linux IPv6 Router Advertisement Daemon"
+HOMEPAGE="http://v6web.litech.org/radvd/"
+SRC_URI="http://v6web.litech.org/radvd/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_FreeBSD selinux"
+
+RDEPEND="dev-libs/libdaemon
+ selinux? ( sec-policy/selinux-radvd )"
+DEPEND="${RDEPEND}
+ dev-libs/check
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig"
+
+DOCS=( CHANGES README TODO radvd.conf.example )
+
+pkg_setup() {
+ enewgroup radvd
+ enewuser radvd -1 -1 /dev/null radvd
+
+ # force ownership of radvd user and group (bug #19647)
+ [[ -d ${ROOT}/var/run/radvd ]] && chown radvd:radvd "${ROOT}"/var/run/radvd
+}
+
+src_configure() {
+ econf --with-pidfile=/var/run/radvd/radvd.pid \
+ --disable-silent-rules
+}
+
+src_install() {
+ default
+
+ dohtml INTRO.html
+
+ newinitd "${FILESDIR}"/${PN}-1.9.1.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ if use kernel_FreeBSD ; then
+ sed -i -e \
+ 's/^SYSCTL_FORWARD=.*$/SYSCTL_FORWARD=net.inet6.ip6.forwarding/g' \
+ "${D}"/etc/init.d/${PN} || die
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ elog "Please create a configuratoion ${ROOT}etc/radvd.conf."
+ elog "See ${ROOT}usr/share/doc/${PF} for an example."
+ einfo
+ elog "grsecurity users should allow a specific group to read /proc"
+ elog "and add the radvd user to that group, otherwise radvd may"
+ elog "segfault on startup."
+}