summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-04-09 01:16:52 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-04-09 01:16:52 +0000
commitb860a16aa64659e4bda7f7a992886ab9d3d96834 (patch)
tree7bef142dfb9625d89d6f9b0f74ad2cef12b55297 /net-misc
parentRemoved deprecated versions (diff)
downloadgentoo-2-b860a16aa64659e4bda7f7a992886ab9d3d96834.tar.gz
gentoo-2-b860a16aa64659e4bda7f7a992886ab9d3d96834.tar.bz2
gentoo-2-b860a16aa64659e4bda7f7a992886ab9d3d96834.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/arm/ChangeLog7
-rw-r--r--net-misc/arm/arm-1.4.2.2.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/net-misc/arm/ChangeLog b/net-misc/arm/ChangeLog
index 2002ce078aea..19c9d9ba1e3a 100644
--- a/net-misc/arm/ChangeLog
+++ b/net-misc/arm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/arm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/ChangeLog,v 1.7 2011/04/09 01:12:59 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/ChangeLog,v 1.8 2011/04/09 01:16:52 blueness Exp $
+
+*arm-1.4.2.2 (09 Apr 2011)
+
+ 09 Apr 2011; Anthony G. Basile <blueness@gentoo.org> +arm-1.4.2.2.ebuild:
+ Version bump
09 Apr 2011; Anthony G. Basile <blueness@gentoo.org> -arm-1.4.0.2.ebuild,
-arm-1.4.1.0.ebuild, metadata.xml:
diff --git a/net-misc/arm/arm-1.4.2.2.ebuild b/net-misc/arm/arm-1.4.2.2.ebuild
new file mode 100644
index 000000000000..058a439040a2
--- /dev/null
+++ b/net-misc/arm/arm-1.4.2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/arm-1.4.2.2.ebuild,v 1.1 2011/04/09 01:16:52 blueness Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="ncurses"
+
+inherit python distutils
+
+DESCRIPTION="A ncurses-based status monitor for Tor relays"
+HOMEPAGE="http://www.atagar.com/arm/"
+SRC_URI="http://www.atagar.com/arm/resources/static/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-misc/tor-0.2.1.27"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install --docPath "${EPREFIX}"/usr/share/doc/${PF}
+}
+
+pkg_postinst() {
+ elog "Some graphing data issues have been noted in testing"
+ elog "when run as root. It is not recommended to run arm as"
+ elog "root until those issues have been isolated and fixed."
+ elog
+ elog "Trouble with graphs under app-misc/screen? Try:"
+ elog 'TERM="rxvt-unicode" arm'
+}