summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-07-17 11:42:37 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-07-17 11:42:37 +0000
commitaaa986edceed699bc107286b53b033ec6e293eeb (patch)
treeab61afb53b21024a8c8e7088ee3c1961a02de8c2 /net-misc
parentalpha stable wrt bug #140657. Tested by Mike Hlavac <mike@flyingpenguins.org> (diff)
downloadgentoo-2-aaa986edceed699bc107286b53b033ec6e293eeb.tar.gz
gentoo-2-aaa986edceed699bc107286b53b033ec6e293eeb.tar.bz2
gentoo-2-aaa986edceed699bc107286b53b033ec6e293eeb.zip
Added patch to fix test46 in 7.15.1 (#111555), version bumped to 7.15.4, stripped LDFLAGS from curl-config and libcurl.pc.
(Portage version: 2.1-r1)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/ChangeLog10
-rw-r--r--net-misc/curl/curl-7.15.1-r1.ebuild7
-rw-r--r--net-misc/curl/curl-7.15.4.ebuild95
-rw-r--r--net-misc/curl/files/curl-7.15-strip-ldflags.patch20
-rw-r--r--net-misc/curl/files/curl-7.15.1-test46.patch25
-rw-r--r--net-misc/curl/files/digest-curl-7.15.43
6 files changed, 156 insertions, 4 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 7ee127684f5e..466b7abd35d1 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/curl
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.74 2006/06/01 22:03:44 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.75 2006/07/17 11:42:37 liquidx Exp $
+
+*curl-7.15.4 (17 Jul 2006)
+
+ 17 Jul 2006; Alastair Tse <liquidx@gentoo.org>
+ +files/curl-7.15.1-test46.patch, +files/curl-7.15-strip-ldflags.patch,
+ curl-7.15.1-r1.ebuild, +curl-7.15.4.ebuild:
+ Added patch to fix test46 in 7.15.1 (#111555), version bumped to 7.15.4,
+ stripped LDFLAGS from curl-config and libcurl.pc.
01 Jun 2006; Daniel Black <dragonheart@gentoo.org>
-files/curl-7.15.0-versionnumber.patch, -curl-7.15.1.ebuild:
diff --git a/net-misc/curl/curl-7.15.1-r1.ebuild b/net-misc/curl/curl-7.15.1-r1.ebuild
index 97df2be473b5..e99156158cd9 100644
--- a/net-misc/curl/curl-7.15.1-r1.ebuild
+++ b/net-misc/curl/curl-7.15.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.15.1-r1.ebuild,v 1.5 2006/04/27 22:29:03 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.15.1-r1.ebuild,v 1.6 2006/07/17 11:42:37 liquidx Exp $
# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
@@ -32,8 +32,9 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/curl-7.15-libtftp.patch
+ cd ${S}
+ epatch ${FILESDIR}/curl-7.15-libtftp.patch
+ epatch ${FILESDIR}/curl-7.15-test46.patch
}
src_compile() {
diff --git a/net-misc/curl/curl-7.15.4.ebuild b/net-misc/curl/curl-7.15.4.ebuild
new file mode 100644
index 000000000000..3c8e26563db0
--- /dev/null
+++ b/net-misc/curl/curl-7.15.4.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.15.4.ebuild,v 1.1 2006/07/17 11:42:37 liquidx Exp $
+
+# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
+
+inherit libtool eutils
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT X11"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl ipv6 ldap ares gnutls idn kerberos krb4 test"
+
+RDEPEND="gnutls? ( net-libs/gnutls )
+ ssl? ( !gnutls? ( dev-libs/openssl ) )
+ ldap? ( net-nds/openldap )
+ idn? ( net-dns/libidn )
+ ares? ( net-dns/c-ares )
+ kerberos? ( virtual/krb5 )
+ krb4? ( app-crypt/kth-krb )"
+
+DEPEND="${RDEPEND}
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+# used - but can do without in self test: net-misc/stunnel
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/${PN}-7.15-strip-ldflags.patch
+ elibtoolize
+}
+
+src_compile() {
+
+ myconf="$(use_enable ldap)
+ $(use_with idn libidn)
+ $(use_enable kerberos gssapi)
+ $(use_enable ipv6)
+ --enable-http
+ --enable-ftp
+ --enable-gopher
+ --enable-file
+ --enable-dict
+ --enable-manual
+ --enable-telnet
+ --enable-nonblocking
+ --enable-largefile"
+
+ if use ipv6 && use ares; then
+ ewarn "c-ares support disabled because it is incompatible with ipv6."
+ myconf="${myconf} --disable-ares"
+ else
+ myconf="${myconf} $(use_enable ares)"
+ fi
+
+ if use ipv6 && use krb4; then
+ ewarn "kerberos-4 support disabled because it is incompatible with ipv6."
+ myconf="${myconf} --disable-krb4"
+ else
+ myconf="${myconf} $(use_enable krb4)"
+ fi
+
+ if use gnutls; then
+ myconf="${myconf} --without-ssl --with-gnutls=/usr"
+ elif use ssl; then
+ myconf="${myconf} --without-gnutls --with-ssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-ssl"
+ fi
+
+ if use kerberos; then
+ myconf="${myconfg} --with-gssapi=/usr"
+ fi
+
+ econf ${myconf} || die 'configure failed'
+ emake || die "install failed for current version"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "installed failed for current version"
+
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+
+ dodoc CHANGES README
+ dodoc docs/FEATURES docs/INTERNALS docs/LIBCURL
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
diff --git a/net-misc/curl/files/curl-7.15-strip-ldflags.patch b/net-misc/curl/files/curl-7.15-strip-ldflags.patch
new file mode 100644
index 000000000000..5c5999aee657
--- /dev/null
+++ b/net-misc/curl/files/curl-7.15-strip-ldflags.patch
@@ -0,0 +1,20 @@
+--- curl-7.15.4/curl-config.in 2006-05-02 23:48:22.000000000 +0100
++++ curl-7.15.4/curl-config.in 2006-07-17 12:32:59.000000000 +0100
+@@ -181,7 +181,7 @@
+ ;;
+
+ --libs)
+- echo -L@libdir@ -lcurl @LDFLAGS@ @LIBS@
++ echo -L@libdir@ -lcurl @LIBS@
+ ;;
+
+ *)
+--- curl-7.15.4/libcurl.pc.in 2004-12-11 18:46:40.000000000 +0000
++++ curl-7.15.4/libcurl.pc.in 2006-07-17 12:33:10.000000000 +0100
+@@ -6,5 +6,5 @@
+ Name: libcurl
+ Description: Library to transfer files with ftp, http, etc.
+ Version: @VERSION@
+-Libs: -L${libdir} -lcurl @LDFLAGS@ @LIBS@
++Libs: -L${libdir} -lcurl @LIBS@
+ Cflags: -I${includedir}
diff --git a/net-misc/curl/files/curl-7.15.1-test46.patch b/net-misc/curl/files/curl-7.15.1-test46.patch
new file mode 100644
index 000000000000..ee443d956341
--- /dev/null
+++ b/net-misc/curl/files/curl-7.15.1-test46.patch
@@ -0,0 +1,25 @@
+===================================================================
+RCS file: /cvsroot/curl/curl/tests/data/test46,v
+retrieving revision 1.13
+retrieving revision 1.14
+diff -u -r1.13 -r1.14
+--- curl/tests/data/test46 2005/05/24 10:03:13 1.13
++++ curl/tests/data/test46 2006/02/06 20:02:14 1.14
+@@ -43,7 +43,7 @@
+
+ www.fake.come FALSE / FALSE 1022144953 cookiecliente si
+ www.loser.com FALSE / FALSE 1139150993 UID 99
+-127.0.0.1 FALSE / FALSE 1139150993 mooo indeed
++127.0.0.1 FALSE / FALSE 1439150993 mooo indeed
+ 127.0.0.1 FALSE / FALSE 0 empty
+ </file>
+ </client>
+@@ -67,7 +67,7 @@
+
+ www.fake.come FALSE / FALSE 1022144953 cookiecliente si
+ www.loser.com FALSE / FALSE 1139150993 UID 99
+-127.0.0.1 FALSE / FALSE 1139150993 mooo indeed
++127.0.0.1 FALSE / FALSE 1439150993 mooo indeed
+ 127.0.0.1 FALSE / FALSE 0 empty
+ 127.0.0.1 FALSE / FALSE 1262322000 ckyPersistent permanent
+ 127.0.0.1 FALSE / FALSE 0 ckySession temporary
diff --git a/net-misc/curl/files/digest-curl-7.15.4 b/net-misc/curl/files/digest-curl-7.15.4
new file mode 100644
index 000000000000..1613a6544c7d
--- /dev/null
+++ b/net-misc/curl/files/digest-curl-7.15.4
@@ -0,0 +1,3 @@
+MD5 d9345a55c8bc67eafcd37fa1b728e00e curl-7.15.4.tar.bz2 1519792
+RMD160 bbef248926d3935272746f605d91e6f03badff6b curl-7.15.4.tar.bz2 1519792
+SHA256 11521127e175eb633c046a2c6ed11f97e81816d3aec9e8cac560763457a8e623 curl-7.15.4.tar.bz2 1519792