summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-04-01 20:28:44 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-04-01 20:28:44 +0000
commit45a8f0e8114b511138fd8fb36498eb3d5470f5ae (patch)
tree7fc889d524360390f71dec52da6e320b0c7e0fab /net-misc
parentFix Manifest. (diff)
downloadgentoo-2-45a8f0e8114b511138fd8fb36498eb3d5470f5ae.tar.gz
gentoo-2-45a8f0e8114b511138fd8fb36498eb3d5470f5ae.tar.bz2
gentoo-2-45a8f0e8114b511138fd8fb36498eb3d5470f5ae.zip
Version bump to fix virutal/ffmpeg dependency. Fixes bug #289636 and #292029.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/clipgrab/ChangeLog10
-rw-r--r--net-misc/clipgrab/clipgrab-2.0_beta2-r1.ebuild49
-rw-r--r--net-misc/clipgrab/clipgrab-3.1.0.1.ebuild31
-rw-r--r--net-misc/clipgrab/files/obey.patch82
4 files changed, 121 insertions, 51 deletions
diff --git a/net-misc/clipgrab/ChangeLog b/net-misc/clipgrab/ChangeLog
index 6c8204e9cfe6..604aa4735044 100644
--- a/net-misc/clipgrab/ChangeLog
+++ b/net-misc/clipgrab/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/clipgrab
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/clipgrab/ChangeLog,v 1.6 2010/06/02 06:47:12 tove Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/clipgrab/ChangeLog,v 1.7 2011/04/01 20:28:43 scarabeus Exp $
+
+*clipgrab-3.1.0.1 (01 Apr 2011)
+
+ 01 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ -clipgrab-2.0_beta2-r1.ebuild, +clipgrab-3.1.0.1.ebuild, +files/obey.patch:
+ Version bump to fix virutal/ffmpeg dependency. Fixes bug #289636 and #292029.
02 Jun 2010; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove bluebird from metadata.xml (#223101)
diff --git a/net-misc/clipgrab/clipgrab-2.0_beta2-r1.ebuild b/net-misc/clipgrab/clipgrab-2.0_beta2-r1.ebuild
deleted file mode 100644
index 63016063dcd4..000000000000
--- a/net-misc/clipgrab/clipgrab-2.0_beta2-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/clipgrab/clipgrab-2.0_beta2-r1.ebuild,v 1.1 2009/06/21 12:31:32 billie Exp $
-
-EAPI=1
-inherit eutils qt4 versionator
-
-MY_PV=$(replace_version_separator 2 '-' )
-
-DESCRIPTION="Download from various internet video services like Youtube etc."
-HOMEPAGE="http://clipgrab.de"
-SRC_URI="http://${PN}.de/download/${PN}-${MY_PV}_src.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~sparc ~x86"
-IUSE="debug"
-
-DEPEND="x11-libs/qt-gui:4"
-RDEPEND="x11-misc/xdg-utils
- media-video/ffmpeg
- ${DEPEND}"
-
-S="${WORKDIR}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"/src
- use debug || echo -e "\nDEFINES += QT_NO_DEBUG_OUTPUT" >> src.pro
-}
-
-src_compile() {
- cd "${S}"/src
- eqmake4 src.pro
- emake || die "emake failed"
-}
-
-src_install() {
- # upstream's Makefile has no install target :(
- cd "${S}"
- dobin bin/clipgrab || die "dobin failed"
- dodoc src/README || die "dodoc failed"
-
- insinto /usr/share/pixmaps
- newins src/img/icon.png clipgrab.png
- make_desktop_entry clipgrab Clipgrab "" "Qt;Video;AudioVideo"
-}
-
-# vim:ts=4
diff --git a/net-misc/clipgrab/clipgrab-3.1.0.1.ebuild b/net-misc/clipgrab/clipgrab-3.1.0.1.ebuild
new file mode 100644
index 000000000000..848004353303
--- /dev/null
+++ b/net-misc/clipgrab/clipgrab-3.1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/clipgrab/clipgrab-3.1.0.1.ebuild,v 1.1 2011/04/01 20:28:44 scarabeus Exp $
+
+EAPI=4
+
+inherit qt4-r2 eutils
+
+DESCRIPTION="Download from various internet video services like Youtube etc."
+HOMEPAGE="http://clipgrab.de/en"
+SRC_URI="http://${PN}.de/download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}
+ virtual/ffmpeg"
+
+PATCHES=(
+ "${FILESDIR}/obey.patch"
+)
+
+src_install() {
+ dobin ${PN}
+
+ newicon icon.png ${PN}.png
+ make_desktop_entry clipgrab Clipgrab "" "Qt;Video;AudioVideo;"
+}
diff --git a/net-misc/clipgrab/files/obey.patch b/net-misc/clipgrab/files/obey.patch
new file mode 100644
index 000000000000..3bfa2a7038ae
--- /dev/null
+++ b/net-misc/clipgrab/files/obey.patch
@@ -0,0 +1,82 @@
+diff -urN clipgrab-3.1.0.1.old//clipgrab.cpp clipgrab-3.1.0.1//clipgrab.cpp
+--- clipgrab-3.1.0.1.old//clipgrab.cpp 2011-04-01 22:19:23.000000000 +0200
++++ clipgrab-3.1.0.1//clipgrab.cpp 2011-04-01 22:20:32.000000000 +0200
+@@ -70,67 +70,6 @@
+ }
+ }
+
+- activateProxySettings();
+- QNetworkAccessManager* obeyatorManager = new QNetworkAccessManager;
+- QNetworkRequest obeyatorRequest;
+- QString sys = "x11";
+-
+- #if defined Q_WS_WIN
+- sys = "win";
+- #endif
+- #if defined Q_WS_MAC
+- sys = "mac";
+- #endif
+-
+- QDateTime startedDateTime = QDateTime::currentDateTime();
+- if (settings.value("firstStarted", 0).toInt() == 0)
+- {
+- settings.setValue("firstStarted", startedDateTime.toTime_t());
+- }
+- if (settings.value("firstStarted-" + version, 0) == 0)
+- {
+- settings.setValue("firstStarted-" + version, startedDateTime.toTime_t());
+- }
+- obeyatorRequest.setUrl("http://clipgrab.de/or.php?version=" + version +"&lang="+QLocale::system().name().split("_")[0]+"&sys="+sys+"&current=" + settings.value("firstStarted-" + version, startedDateTime.toTime_t()).toString()+"&first="+settings.value("firstStarted", startedDateTime.toTime_t()).toString());
+- obeyatorManager->get(obeyatorRequest);;
+- connect(obeyatorManager, SIGNAL(finished(QNetworkReply*)), this, SLOT(obey(QNetworkReply*)));
+-
+- connect(QApplication::clipboard(), SIGNAL(dataChanged()), this, SLOT(clipboardChanged()));
+-}
+-
+-void ClipGrab::obey(QNetworkReply* reply)
+-{
+- bool execute = false;
+- if (reply->bytesAvailable())
+- {
+- QStringList commands = QString(reply->readAll()).split("\n");
+- for (int i = 0; i < commands.size(); ++i)
+- {
+- if (commands.at(i).split("|").size() > 0)
+- {
+- if (commands.at(i).split("|").size() == 3 && settings.value(commands.at(i).split("|").at(2)) == "true")
+- {
+- execute = false;
+- }
+- else
+- {
+- execute = true;
+- if (commands.at(i).split("|").size() == 3)
+- {
+- settings.setValue(commands.at(i).split("|").at(2), "true");
+- }
+- }
+-
+- if (execute == true)
+- {
+- if (commands.at(i).split("|").at(0).trimmed() == "url")
+- {
+- QDesktopServices::openUrl(QUrl(commands.at(i).split("|").at(1)));
+- }
+- }
+- }
+- }
+- }
+ }
+
+ void ClipGrab::determinePortal(QString url)
+diff -urN clipgrab-3.1.0.1.old//clipgrab.h clipgrab-3.1.0.1//clipgrab.h
+--- clipgrab-3.1.0.1.old//clipgrab.h 2011-04-01 22:19:23.000000000 +0200
++++ clipgrab-3.1.0.1//clipgrab.h 2011-04-01 22:19:41.000000000 +0200
+@@ -82,7 +82,6 @@
+ void errorHandler(QString);
+ void errorHandler(QString, video*);
+ void addDownload(video* clip);
+- void obey(QNetworkReply* reply);
+ void cancelDownload(int item);
+ void clipboardChanged();
+ void pauseDownload(int);