summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-04 12:14:50 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-04 12:14:50 +0000
commit0c7a6021b803bfa370701f649c0f37a3823a9219 (patch)
tree48fe0a59d438ea947b6e2555a114bd46852ff858 /net-misc
parentSparc stable, bug #267435. (diff)
downloadgentoo-2-0c7a6021b803bfa370701f649c0f37a3823a9219.tar.gz
gentoo-2-0c7a6021b803bfa370701f649c0f37a3823a9219.tar.bz2
gentoo-2-0c7a6021b803bfa370701f649c0f37a3823a9219.zip
Version bump.
(Portage version: 13775-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/neon/ChangeLog8
-rw-r--r--net-misc/neon/neon-0.28.5.ebuild (renamed from net-misc/neon/neon-0.28.2.ebuild)58
2 files changed, 34 insertions, 32 deletions
diff --git a/net-misc/neon/ChangeLog b/net-misc/neon/ChangeLog
index 70978a02e430..54417e8dd231 100644
--- a/net-misc/neon/ChangeLog
+++ b/net-misc/neon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/neon
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.125 2009/06/12 23:10:32 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.126 2009/07/04 12:14:50 arfrever Exp $
+
+*neon-0.28.5 (04 Jul 2009)
+
+ 04 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -neon-0.28.2.ebuild, +neon-0.28.5.ebuild:
+ Version bump.
12 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
neon-0.28.4.ebuild, +files/neon-0.28.4-SOCK_CLOEXEC.patch:
diff --git a/net-misc/neon/neon-0.28.2.ebuild b/net-misc/neon/neon-0.28.5.ebuild
index d445b50f6fab..199f57c14923 100644
--- a/net-misc/neon/neon-0.28.2.ebuild
+++ b/net-misc/neon/neon-0.28.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.28.2.ebuild,v 1.3 2008/06/14 16:33:52 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.28.5.ebuild,v 1.1 2009/07/04 12:14:50 arfrever Exp $
-inherit autotools eutils libtool versionator
+EAPI="2"
-RESTRICT="test"
+inherit autotools libtool versionator
DESCRIPTION="HTTP and WebDAV client library"
HOMEPAGE="http://www.webdav.org/neon/"
@@ -12,12 +12,14 @@ SRC_URI="http://www.webdav.org/neon/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE="doc expat gnutls kerberos nls pkcs11 socks5 ssl zlib"
IUSE_LINGUAS="cs de fr ja nn pl ru tr zh_CN"
for lingua in ${IUSE_LINGUAS}; do
- IUSE="${IUSE} linguas_${lingua}"
+ IUSE+=" linguas_${lingua}"
done
+unset lingua
+RESTRICT="test"
RDEPEND="expat? ( dev-libs/expat )
!expat? ( dev-libs/libxml2 )
@@ -25,48 +27,47 @@ RDEPEND="expat? ( dev-libs/expat )
>=net-libs/gnutls-2.0
pkcs11? ( dev-libs/pakchois )
)
- !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6f ) )
+ !gnutls? ( ssl? (
+ >=dev-libs/openssl-0.9.6f
+ pkcs11? ( dev-libs/pakchois )
+ ) )
kerberos? ( virtual/krb5 )
nls? ( virtual/libintl )
socks5? ( net-proxy/dante )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
local lingua linguas
for lingua in ${IUSE_LINGUAS}; do
- use linguas_${lingua} && linguas="${linguas} ${lingua}"
+ use linguas_${lingua} && linguas+=" ${lingua}"
done
sed -i -e "s/ALL_LINGUAS=.*/ALL_LINGUAS=\"${linguas}\"/g" configure.in
sed -i -e "s/socks5/socks/g" macros/neon.m4
AT_M4DIR="macros" eautoreconf
+
+ elibtoolize
}
-src_compile() {
+src_configure() {
local myconf
if has_version sys-libs/glibc; then
- if built_with_use --missing true sys-libs/glibc nptlonly \
- || built_with_use --missing true sys-libs/glibc nptl; then
- einfo "Enabling SSL library thread-safety using POSIX threads..."
- myconf="${myconf} --enable-threadsafe-ssl=posix"
- fi
+ einfo "Enabling SSL library thread-safety using POSIX threads..."
+ myconf+=" --enable-threadsafe-ssl=posix"
fi
if use expat; then
- myconf="${myconf} --with-expat"
+ myconf+=" --with-expat"
else
- myconf="${myconf} --with-libxml2"
+ myconf+=" --with-libxml2"
fi
if use gnutls; then
- myconf="${myconf} --with-ssl=gnutls"
+ myconf+=" --with-ssl=gnutls"
elif use ssl; then
- myconf="${myconf} --with-ssl=openssl"
+ myconf+=" --with-ssl=openssl"
fi
econf \
@@ -78,11 +79,6 @@ src_compile() {
$(use_with socks5 socks) \
$(use_with zlib) \
${myconf}
- emake || die "emake failed"
-}
-
-src_test() {
- emake check || die "Trying make check without success."
}
src_install() {
@@ -98,12 +94,12 @@ src_install() {
pkg_postinst() {
ewarn "Neon has a policy of breaking API across minor versions, this means"
- ewarn "that any package that links against neon may be broken after"
+ ewarn "that any package that links against Neon may be broken after"
ewarn "updating. They will remain broken until they are ported to the"
- ewarn "new API. You can downgrade neon to the previous version by doing:"
+ ewarn "new API. You can downgrade Neon to the previous version by doing:"
ewarn
ewarn " emerge --oneshot '<net-misc/neon-$(get_version_component_range 1-2 ${PV})'"
ewarn
- ewarn "You may also have to downgrade any package that has already been"
- ewarn "ported to the new API."
+ ewarn "You may also have to downgrade any package that has not been"
+ ewarn "ported to the new API yet."
}