summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-01-03 15:34:28 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-01-03 15:34:28 +0000
commitd9b9336ab4c4e13145177e99a62e01e408f89a0d (patch)
treeb68e81508cf58bc3932861f81e4619a2e6954ae2 /net-misc/x2goclient
parentStop building libbacktrace with -Werror. (diff)
downloadgentoo-2-d9b9336ab4c4e13145177e99a62e01e408f89a0d.tar.gz
gentoo-2-d9b9336ab4c4e13145177e99a62e01e408f89a0d.tar.bz2
gentoo-2-d9b9336ab4c4e13145177e99a62e01e408f89a0d.zip
Bugfix version bump for 5.x
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-misc/x2goclient')
-rw-r--r--net-misc/x2goclient/ChangeLog10
-rw-r--r--net-misc/x2goclient/x2goclient-4.0.1.2.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/net-misc/x2goclient/ChangeLog b/net-misc/x2goclient/ChangeLog
index 5d6ecbf2e04b..1ae9d5b1c249 100644
--- a/net-misc/x2goclient/ChangeLog
+++ b/net-misc/x2goclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/x2goclient
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.23 2013/10/21 09:15:07 voyageur Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.24 2014/01/03 15:34:28 voyageur Exp $
+
+*x2goclient-4.0.1.2 (03 Jan 2014)
+
+ 03 Jan 2014; Bernard Cafarelli <voyageur@gentoo.org>
+ +x2goclient-4.0.1.2.ebuild:
+ Version bump
21 Oct 2013; Bernard Cafarelli <voyageur@gentoo.org>
x2goclient-4.0.1.0.ebuild, x2goclient-4.0.1.1.ebuild:
diff --git a/net-misc/x2goclient/x2goclient-4.0.1.2.ebuild b/net-misc/x2goclient/x2goclient-4.0.1.2.ebuild
new file mode 100644
index 000000000000..02561ab0ebc6
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-4.0.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/x2goclient-4.0.1.2.ebuild,v 1.1 2014/01/03 15:34:28 voyageur Exp $
+
+EAPI=4
+inherit eutils qt4-r2
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap"
+
+DEPEND=">=net-libs/libssh-0.6.0_rc1
+ net-print/cups
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ net-misc/nx"
+
+src_prepare() {
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i x2goclientconfig.h || die
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/pixmaps/x2goclient
+ doins -r icons/*
+
+ make_desktop_entry ${PN} "X2go client" ${PN} "Network"
+}