summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-06-24 09:02:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-06-24 09:02:56 +0000
commit45229ef0c1b0ee58af479a845c90460a0516e9de (patch)
treea01317e3e4b0156ca215343b1fd252dba1ffccda /net-misc/unison
parentadded missing dependencies to X11 libraries (diff)
downloadgentoo-2-45229ef0c1b0ee58af479a845c90460a0516e9de.tar.gz
gentoo-2-45229ef0c1b0ee58af479a845c90460a0516e9de.tar.bz2
gentoo-2-45229ef0c1b0ee58af479a845c90460a0516e9de.zip
Add support for no-ocamlopt installs, bug #229129
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.7 x86_64)
Diffstat (limited to 'net-misc/unison')
-rw-r--r--net-misc/unison/ChangeLog6
-rw-r--r--net-misc/unison/unison-2.13.16-r1.ebuild16
-rw-r--r--net-misc/unison/unison-2.27.57-r1.ebuild16
3 files changed, 33 insertions, 5 deletions
diff --git a/net-misc/unison/ChangeLog b/net-misc/unison/ChangeLog
index 00b1ebe7a0e9..d7dd62900ed8 100644
--- a/net-misc/unison/ChangeLog
+++ b/net-misc/unison/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/unison
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.52 2008/06/16 20:51:23 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.53 2008/06/24 09:02:56 aballier Exp $
+
+ 24 Jun 2008; Alexis Ballier <aballier@gentoo.org>
+ unison-2.13.16-r1.ebuild, unison-2.27.57-r1.ebuild:
+ Add support for no-ocamlopt installs, bug #229129
16 Jun 2008; Alexis Ballier <aballier@gentoo.org> unison-2.13.16.ebuild:
quote variables and dont dodoc copying
diff --git a/net-misc/unison/unison-2.13.16-r1.ebuild b/net-misc/unison/unison-2.13.16-r1.ebuild
index d3c0973d15a9..ed95a8946a9f 100644
--- a/net-misc/unison/unison-2.13.16-r1.ebuild
+++ b/net-misc/unison/unison-2.13.16-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.13.16-r1.ebuild,v 1.1 2008/06/16 20:20:07 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.13.16-r1.ebuild,v 1.2 2008/06/24 09:02:56 aballier Exp $
EAPI=1
inherit eutils versionator
-IUSE="gtk doc static debug threads"
+IUSE="gtk doc static debug threads +ocamlopt"
DESCRIPTION="Two-way cross-platform file synchronizer"
HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
@@ -28,6 +28,15 @@ SRC_URI="http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}.t
doc? ( http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
src_unpack() {
unpack ${P}.tar.gz
@@ -58,6 +67,8 @@ src_compile() {
myconf="$myconf UISTYLE=text"
fi
+ use ocamlopt || myconf="$myconf NATIVE=false"
+
# Discard cflags as it will try to pass them to ocamlc...
emake -j1 $myconf CFLAGS="" || die "error making unsion"
}
@@ -73,6 +84,7 @@ src_install () {
dohtml "${DISTDIR}/${P}-manual.html" || die
dodoc "${DISTDIR}/${P}-manual.pdf" || die
fi
+ use ocamlopt || export STRIP_MASK="*/bin/*"
}
pkg_postinst() {
diff --git a/net-misc/unison/unison-2.27.57-r1.ebuild b/net-misc/unison/unison-2.27.57-r1.ebuild
index 3524e196f5b1..53d283ef6d3a 100644
--- a/net-misc/unison/unison-2.27.57-r1.ebuild
+++ b/net-misc/unison/unison-2.27.57-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.27.57-r1.ebuild,v 1.5 2008/06/13 19:34:39 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.27.57-r1.ebuild,v 1.6 2008/06/24 09:02:56 aballier Exp $
EAPI=1
inherit eutils versionator
-IUSE="gtk doc static debug threads"
+IUSE="gtk doc static debug threads +ocamlopt"
DESCRIPTION="Two-way cross-platform file synchronizer"
HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
@@ -28,6 +28,15 @@ SRC_URI="http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}.t
doc? ( http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -55,6 +64,8 @@ src_compile() {
myconf="$myconf UISTYLE=text"
fi
+ use ocamlopt || myconf="$myconf NATIVE=false"
+
# Discard cflags as it will try to pass them to ocamlc...
emake -j1 $myconf CFLAGS="" || die "error making unsion"
}
@@ -74,6 +85,7 @@ src_install () {
dohtml "${DISTDIR}/${P}-manual.html" || die
dodoc "${DISTDIR}/${P}-manual.pdf" || die
fi
+ use ocamlopt || export STRIP_MASK="*/bin/*"
}
pkg_postinst() {