summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-07-18 02:53:57 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-07-18 02:53:57 +0000
commit3c868288f8e592c90acc77e2d7f4946de5611fc3 (patch)
treeb09069e5d592954b64e1d56cf68106c4e8206c27 /net-misc/unison
parentNew ebuild of autofs with OpenLDAP 2.x support. Also proper setting of (diff)
downloadgentoo-2-3c868288f8e592c90acc77e2d7f4946de5611fc3.tar.gz
gentoo-2-3c868288f8e592c90acc77e2d7f4946de5611fc3.tar.bz2
gentoo-2-3c868288f8e592c90acc77e2d7f4946de5611fc3.zip
new package unison: bidirectional cross-platform file synchronization
Diffstat (limited to 'net-misc/unison')
-rw-r--r--net-misc/unison/ChangeLog12
-rw-r--r--net-misc/unison/files/digest-unison-2.9.11
-rw-r--r--net-misc/unison/unison-2.9.1.ebuild38
3 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/unison/ChangeLog b/net-misc/unison/ChangeLog
new file mode 100644
index 000000000000..0a5fdc91591f
--- /dev/null
+++ b/net-misc/unison/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-misc/unison
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.1 2002/07/18 02:53:57 george Exp $
+
+*unison-2.9.1.ebuild (17 July 2002)
+
+ 17 July 2002; George Shapovalov <george@gentoo.org> unison-2.9.1.ebuild, files/digest-unison-2.9.1, ChangeLog :
+
+ Inital release,
+ Two-way cross-platform file synchronizer
+
+ ebuild submitted by Bardur Arantsson <bardur-gta@odense.kollegienet.dk>
diff --git a/net-misc/unison/files/digest-unison-2.9.1 b/net-misc/unison/files/digest-unison-2.9.1
new file mode 100644
index 000000000000..570a7db56292
--- /dev/null
+++ b/net-misc/unison/files/digest-unison-2.9.1
@@ -0,0 +1 @@
+MD5 d8084fa87c13671de21ec1b701a4606c src.tar.gz 319081
diff --git a/net-misc/unison/unison-2.9.1.ebuild b/net-misc/unison/unison-2.9.1.ebuild
new file mode 100644
index 000000000000..3bde7e9c5e19
--- /dev/null
+++ b/net-misc/unison/unison-2.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.9.1.ebuild,v 1.1 2002/07/18 02:53:57 george Exp $
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=dev-lang/ocaml-3.04
+ gtk? ( >=dev-ml/lablgtk-1.2.3 )"
+RDEPEND="gtk? ( >=x11-libs/gtk+-1.2.10 )"
+
+SRC_URI="http://www.cis.upenn.edu/~bcpierce/unison/download/stable/${P}/src.tar.gz"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ local myconf
+
+ if [ `use gtk` ]; then
+ myconf="$myconf UISTYLE=gtk"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ make $myconf CFLAGS="" || die
+}
+
+src_install () {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ dobin unison
+ dodoc BUGS.txt CONTRIB COPYING INSTALL NEWS \
+ README ROADMAP.txt TODO.txt
+}