summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2009-01-08 20:15:19 +0000
committerPatrick McLean <chutzpah@gentoo.org>2009-01-08 20:15:19 +0000
commitf9eefda4e1d603eb993aaa988d25beff3073585d (patch)
treeabe7531180f6da63ecf5a0702a638b540dc396d0 /net-misc/tn5250
parentRemoving old (diff)
downloadgentoo-2-f9eefda4e1d603eb993aaa988d25beff3073585d.tar.gz
gentoo-2-f9eefda4e1d603eb993aaa988d25beff3073585d.tar.bz2
gentoo-2-f9eefda4e1d603eb993aaa988d25beff3073585d.zip
Version bump.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'net-misc/tn5250')
-rw-r--r--net-misc/tn5250/ChangeLog9
-rw-r--r--net-misc/tn5250/tn5250-0.17.4.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/net-misc/tn5250/ChangeLog b/net-misc/tn5250/ChangeLog
index 334c6fba3ce2..52e724583e1d 100644
--- a/net-misc/tn5250/ChangeLog
+++ b/net-misc/tn5250/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tn5250
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tn5250/ChangeLog,v 1.19 2008/03/15 22:32:05 dertobi123 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tn5250/ChangeLog,v 1.20 2009/01/08 20:15:19 chutzpah Exp $
+
+*tn5250-0.17.4 (08 Jan 2009)
+
+ 08 Jan 2009; Patrick McLean <chutzpah@gentoo.org> +tn5250-0.17.4.ebuild:
+ Version bump.
15 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
tn5250-0.17.3-r1.ebuild:
diff --git a/net-misc/tn5250/tn5250-0.17.4.ebuild b/net-misc/tn5250/tn5250-0.17.4.ebuild
new file mode 100644
index 000000000000..165fe02dfab8
--- /dev/null
+++ b/net-misc/tn5250/tn5250-0.17.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tn5250/tn5250-0.17.4.ebuild,v 1.1 2009/01/08 20:15:19 chutzpah Exp $
+
+inherit eutils python
+
+DESCRIPTION="Telnet client for the IBM AS/400 that emulates 5250 terminals and printers."
+HOMEPAGE="http://tn5250.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="X ssl"
+
+RDEPEND="sys-libs/ncurses
+ ssl? ( dev-libs/openssl )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-libs/libXt )"
+
+src_unpack() {
+ unpack ${A}
+
+ # Next, the Makefile for the terminfo settings tries to remove
+ # some files it doesn't have access to. We can just remove those
+ # lines.
+ cd "${S}/linux"
+ sed -i \
+ -e "/rm -f \/usr\/.*\/terminfo.*5250/d" Makefile.in \
+ || die "sed Makefile.in failed"
+ cd "${S}"
+}
+
+src_compile() {
+ econf \
+ $(use_with X x) \
+ $(use_with ssl) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ # The TERMINFO variable needs to be defined for the install
+ # to work, because the install calls "tic." man tic for
+ # details.
+ dodir /usr/share/terminfo
+ make DESTDIR="${D}" \
+ TERMINFO="${D}/usr/share/terminfo" install \
+ || die "make install failed"
+
+ dodoc AUTHORS BUGS NEWS README README.ssl TODO ChangeLog
+}