summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-02-09 13:17:29 +0000
committerSamuli Suominen <drac@gentoo.org>2008-02-09 13:17:29 +0000
commitf81cabefcc6f6741694dda1010a1b628b2d108f0 (patch)
tree4c29aaabf1900c5742119d856652bcc405727565 /net-misc/tn5250
parentStable for HPPA (bug #208128). (diff)
downloadgentoo-2-f81cabefcc6f6741694dda1010a1b628b2d108f0.tar.gz
gentoo-2-f81cabefcc6f6741694dda1010a1b628b2d108f0.tar.bz2
gentoo-2-f81cabefcc6f6741694dda1010a1b628b2d108f0.zip
Remove USE slang so it doesn't hold up bug 209416.
(Portage version: 2.1.4.1)
Diffstat (limited to 'net-misc/tn5250')
-rw-r--r--net-misc/tn5250/ChangeLog9
-rw-r--r--net-misc/tn5250/tn5250-0.17.3-r1.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/net-misc/tn5250/ChangeLog b/net-misc/tn5250/ChangeLog
index 2db171f98810..0be9c3d4d321 100644
--- a/net-misc/tn5250/ChangeLog
+++ b/net-misc/tn5250/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tn5250
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tn5250/ChangeLog,v 1.16 2007/08/29 17:26:35 phreak Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tn5250/ChangeLog,v 1.17 2008/02/09 13:17:29 drac Exp $
+
+*tn5250-0.17.3-r1 (09 Feb 2008)
+
+ 09 Feb 2008; Samuli Suominen <drac@gentoo.org> +tn5250-0.17.3-r1.ebuild:
+ Remove USE slang so it doesn't hold up bug 209416.
29 Aug 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing gustavoz from metadata due to his retirement (see #36010 for
diff --git a/net-misc/tn5250/tn5250-0.17.3-r1.ebuild b/net-misc/tn5250/tn5250-0.17.3-r1.ebuild
new file mode 100644
index 000000000000..cdee5d54cd04
--- /dev/null
+++ b/net-misc/tn5250/tn5250-0.17.3-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tn5250/tn5250-0.17.3-r1.ebuild,v 1.1 2008/02/09 13:17:29 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="Telnet client for the IBM AS/400 that emulates 5250 terminals and printers."
+HOMEPAGE="http://tn5250.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="X ssl"
+
+RDEPEND="sys-libs/ncurses
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ X? ( x11-libs/libXt )"
+
+src_unpack() {
+ unpack ${A}
+
+ # First, for some reason, TRUE and FALSE aren't defined
+ # for the compile. This causes some problems. ???
+ echo >> "${S}/src/tn5250-config.h.in"
+ echo "/* Define TRUE and FALSE */" >> "${S}/src/tn5250-config.h.in"
+ echo "#define FALSE 0" >> "${S}/src/tn5250-config.h.in"
+ echo "#define TRUE !FALSE" >> "${S}/src/tn5250-config.h.in"
+
+ # Next, the Makefile for the terminfo settings tries to remove
+ # some files it doesn't have access to. We can just remove those
+ # lines.
+ cd "${S}/linux"
+ sed -i \
+ -e "/rm -f \/usr\/.*\/terminfo.*5250/d" Makefile.in \
+ || die "sed Makefile.in failed"
+ cd "${S}/src"
+}
+
+src_compile() {
+ econf \
+ $(use_with X x) \
+ $(use_with ssl) \
+ --without-slang || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ # The TERMINFO variable needs to be defined for the install
+ # to work, because the install calls "tic." man tic for
+ # details.
+ dodir /usr/share/terminfo
+ make DESTDIR="${D}" \
+ TERMINFO="${D}/usr/share/terminfo" install \
+ || die "make install failed"
+ dodoc AUTHORS BUGS NEWS README README.ssl TODO
+ dohtml -r doc/*
+}