summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-12-22 18:55:28 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-12-22 18:55:28 +0000
commit411d8bdbaf4ff9480ebc1ddf571e81ddb9375317 (patch)
tree871ebf1e84cd67f0900e804d25713bfdba09cbae /net-misc/tinc/tinc-1.0.25.ebuild
parentVersion bump for Gnome 3.14. (diff)
downloadgentoo-2-411d8bdbaf4ff9480ebc1ddf571e81ddb9375317.tar.gz
gentoo-2-411d8bdbaf4ff9480ebc1ddf571e81ddb9375317.tar.bz2
gentoo-2-411d8bdbaf4ff9480ebc1ddf571e81ddb9375317.zip
Version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/tinc/tinc-1.0.25.ebuild')
-rw-r--r--net-misc/tinc/tinc-1.0.25.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/tinc/tinc-1.0.25.ebuild b/net-misc/tinc/tinc-1.0.25.ebuild
new file mode 100644
index 000000000000..b7e34708d9bc
--- /dev/null
+++ b/net-misc/tinc/tinc-1.0.25.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/tinc-1.0.25.ebuild,v 1.1 2014/12/22 18:55:28 blueness Exp $
+
+EAPI="5"
+inherit systemd
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+lzo uml vde +zlib"
+
+DEPEND="dev-libs/openssl
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )"
+
+src_configure() {
+ econf \
+ --enable-jumbograms \
+ --disable-tunemu \
+ $(use_enable lzo) \
+ $(use_enable uml) \
+ $(use_enable vde) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf tincd
+ newinitd "${FILESDIR}"/tincd-r1 tincd
+ systemd_newunit "${FILESDIR}"/tincd_at.service "tincd@.service"
+}
+
+pkg_postinst() {
+ elog "This package requires the tun/tap kernel device."
+ elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}