summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-26 01:44:08 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-26 01:44:08 +0000
commitf67af77d46db4b001ed9822891f0e05b7b9a273e (patch)
treefdc42aac3c7b6892b73df4515ae62c3be02c6c9f /net-misc/tinc/files
parentVersion bump. (diff)
downloadgentoo-2-f67af77d46db4b001ed9822891f0e05b7b9a273e.tar.gz
gentoo-2-f67af77d46db4b001ed9822891f0e05b7b9a273e.tar.bz2
gentoo-2-f67af77d46db4b001ed9822891f0e05b7b9a273e.zip
Version bump with patch to fix AC_ARG_ENABLE
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tinc/files')
-rw-r--r--net-misc/tinc/files/fix-ac-arg-enable.patch69
1 files changed, 69 insertions, 0 deletions
diff --git a/net-misc/tinc/files/fix-ac-arg-enable.patch b/net-misc/tinc/files/fix-ac-arg-enable.patch
new file mode 100644
index 000000000000..fef695211551
--- /dev/null
+++ b/net-misc/tinc/files/fix-ac-arg-enable.patch
@@ -0,0 +1,69 @@
+diff -Naur tinc-1.0.18.orig//configure.in tinc-1.0.18/configure.in
+--- tinc-1.0.18.orig//configure.in 2012-03-25 09:46:02.000000000 -0400
++++ tinc-1.0.18/configure.in 2012-03-25 21:24:55.000000000 -0400
+@@ -74,29 +74,43 @@
+
+ AC_ARG_ENABLE(uml,
+ AS_HELP_STRING([--enable-uml], [enable support for User Mode Linux]),
+- [ AC_DEFINE(ENABLE_UML, 1, [Support for UML])
+- uml=true
+- ]
++ [ AS_IF([test "x$enable_uml" = "xyes"],
++ [ AC_DEFINE(ENABLE_UML, 1, [Support for UML])
++ uml=true
++ ],
++ [uml=false])
++ ],
++ [uml=true]
+ )
+
+ AC_ARG_ENABLE(vde,
+ AS_HELP_STRING([--enable-vde], [enable support for Virtual Distributed Ethernet]),
+- [ AC_CHECK_HEADERS(libvdeplug_dyn.h, [], [AC_MSG_ERROR([VDE plug header files not found.]); break])
+- AC_DEFINE(ENABLE_VDE, 1, [Support for VDE])
+- vde=true
+- ]
++ [ AS_IF([test "x$enable_vde" = "xyes"],
++ [ AC_CHECK_HEADERS(libvdeplug_dyn.h, [], [AC_MSG_ERROR([VDE plug header files not found.]); break])
++ AC_DEFINE(ENABLE_VDE, 1, [Support for VDE])
++ vde=true
++ ],
++ [vde=false])
++ ],
++ [vde=true]
+ )
+
+ AC_ARG_ENABLE(tunemu,
+ AS_HELP_STRING([--enable-tunemu], [enable support for the tunemu driver]),
+- [ AC_DEFINE(ENABLE_TUNEMU, 1, [Support for tunemu])
+- tunemu=true
+- ]
++ [ AS_IF([test "x$enable_tunemu" = "xyes"],
++ [ AC_DEFINE(ENABLE_TUNEMU, 1, [Support for tunemu])
++ tunemu=true
++ ],
++ [tunemu=false])
++ ],
++ [tunemu=true]
+ )
+
+ AC_ARG_WITH(windows2000,
+ AS_HELP_STRING([--with-windows2000], [compile with support for Windows 2000. This disables support for tunneling over existing IPv6 networks.]),
+- [AC_DEFINE(WITH_WINDOWS2000, 1, [Compile with support for Windows 2000])]
++ [ AS_IF([test "x$with_windows2000" = "xyes"],
++ [AC_DEFINE(WITH_WINDOWS2000, 1, [Compile with support for Windows 2000])])
++ ]
+ )
+
+ AM_CONDITIONAL(UML, test "$uml" = true)
+@@ -177,7 +191,9 @@
+ dnl Check if support for jumbograms is requested
+ AC_ARG_ENABLE(jumbograms,
+ AS_HELP_STRING([--enable-jumbograms], [enable support for jumbograms (packets up to 9000 bytes)]),
+- [ AC_DEFINE(ENABLE_JUMBOGRAMS, 1, [Support for jumbograms (packets up to 9000 bytes)]) ]
++ [ AS_IF([test "x$enable_jumbograms" = "xyes"],
++ [ AC_DEFINE(ENABLE_JUMBOGRAMS, 1, [Support for jumbograms (packets up to 9000 bytes)]) ])
++ ]
+ )
+
+ AC_SUBST(INCLUDES)