summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-07-05 06:15:08 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-07-05 06:15:08 +0000
commit9f946dfdeddbd90d4c27a6d45eb245c3c82468ed (patch)
tree602358e94fe0eba894cb3407106d1af97dec6823 /net-misc/spice-gtk
parentCall cmake-utils_src_prepare instead of base_src_prepare, wrt bug #475510. Th... (diff)
downloadgentoo-2-9f946dfdeddbd90d4c27a6d45eb245c3c82468ed.tar.gz
gentoo-2-9f946dfdeddbd90d4c27a6d45eb245c3c82468ed.tar.bz2
gentoo-2-9f946dfdeddbd90d4c27a6d45eb245c3c82468ed.zip
Version bump (bug #471964), also solves bug #419933 since we don't have to run eautoreconf anymore.
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0x1E0CA85F!)
Diffstat (limited to 'net-misc/spice-gtk')
-rw-r--r--net-misc/spice-gtk/ChangeLog8
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.20.ebuild168
2 files changed, 175 insertions, 1 deletions
diff --git a/net-misc/spice-gtk/ChangeLog b/net-misc/spice-gtk/ChangeLog
index 46e96fe1b923..acd916ab4731 100644
--- a/net-misc/spice-gtk/ChangeLog
+++ b/net-misc/spice-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/spice-gtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.59 2013/06/30 17:56:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.60 2013/07/05 06:15:08 dev-zero Exp $
+
+*spice-gtk-0.20 (05 Jul 2013)
+
+ 05 Jul 2013; Tiziano Müller <dev-zero@gentoo.org> +spice-gtk-0.20.ebuild:
+ Version bump (bug #471964), also solves bug #419933 since we don't have to run
+ eautoreconf anymore.
*spice-gtk-0.18-r1 (30 Jun 2013)
diff --git a/net-misc/spice-gtk/spice-gtk-0.20.ebuild b/net-misc/spice-gtk/spice-gtk-0.20.ebuild
new file mode 100644
index 000000000000..9caabb3c3350
--- /dev/null
+++ b/net-misc/spice-gtk/spice-gtk-0.20.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.20.ebuild,v 1.1 2013/07/05 06:15:08 dev-zero Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+WANT_AUTOMAKE="1.12"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit autotools eutils python-single-r1 vala
+
+PYTHON_DEPEND="2"
+
+DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI."
+HOMEPAGE="http://spice-space.org http://gitorious.org/spice-gtk"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+SRC_URI="http://spice-space.org/download/gtk/${P}.tar.bz2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus doc gstreamer gtk3 +introspection policykit pulseaudio
+python sasl smartcard static-libs usbredir vala"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ ?? ( pulseaudio gstreamer )"
+
+# TODO:
+# * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
+# * use external pnp.ids as soon as that means not pulling in gnome-desktop
+RDEPEND="${PYTHON_DEPS}
+ pulseaudio? ( media-sound/pulseaudio[glib] )
+ gstreamer? (
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10 )
+ >=x11-libs/pixman-0.17.7
+ >=media-libs/celt-0.5.1.1:0.5.1
+ dev-libs/openssl
+ gtk3? ( x11-libs/gtk+:3[introspection?] )
+ x11-libs/gtk+:2[introspection?]
+ >=dev-libs/glib-2.26:2
+ >=x11-libs/cairo-1.2
+ virtual/jpeg
+ sys-libs/zlib
+ dbus? ( dev-libs/dbus-glib )
+ introspection? ( dev-libs/gobject-introspection )
+ python? ( dev-python/pygtk:2 )
+ sasl? ( dev-libs/cyrus-sasl )
+ smartcard? ( app-emulation/libcacard )
+ usbredir? (
+ sys-apps/hwids
+ >=sys-apps/usbredir-0.4.2
+ virtual/libusb:1
+ virtual/udev[gudev]
+ policykit? (
+ sys-apps/acl
+ >=sys-auth/polkit-0.101 )
+ )"
+DEPEND="${RDEPEND}
+ dev-lang/python
+ virtual/pyparsing
+ dev-perl/Text-CSV
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+# Hard-deps while building from git:
+# dev-lang/vala:0.14
+# dev-lang/perl
+
+GTK2_BUILDDIR="${WORKDIR}/${P}_gtk2"
+GTK3_BUILDDIR="${WORKDIR}/${P}_gtk3"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ mkdir ${GTK2_BUILDDIR} ${GTK3_BUILDDIR} || die
+}
+
+src_configure() {
+ local myconf
+ local audio="no"
+
+ use gstreamer && audio="gstreamer"
+ use pulseaudio && audio="pulse"
+
+ if use vala ; then
+ # force vala regen for MinGW, etc
+ rm -fv gtk/controller/controller.{c,vala.stamp} gtk/controller/menu.c
+ fi
+
+ myconf="
+ $(use_enable static-libs static) \
+ $(use_enable introspection) \
+ --with-audio=${audio} \
+ $(use_with python) \
+ $(use_with sasl) \
+ $(use_enable smartcard) \
+ $(use_enable usbredir) \
+ $(use_with usbredir usb-ids-path /usr/share/misc/usb.ids) \
+ $(use_with usbredir usb-acl-helper-dir /usr/libexec) \
+ $(use_enable policykit polkit) \
+ $(use_enable vala) \
+ $(use_enable dbus) \
+ --disable-werror \
+ --enable-pie"
+
+ cd ${GTK2_BUILDDIR}
+ echo "Running configure in ${GTK2_BUILDDIR}"
+ ECONF_SOURCE="${S}" econf --disable-maintainer-mode \
+ --with-gtk=2.0 \
+ ${myconf}
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ echo "Running configure in ${GTK3_BUILDDIR}"
+ ECONF_SOURCE="${S}" econf --disable-maintainer-mode \
+ --with-gtk=3.0 \
+ ${myconf}
+ fi
+}
+
+src_compile() {
+ cd ${GTK2_BUILDDIR}
+ einfo "Running make in ${GTK2_BUILDDIR}"
+ default
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ einfo "Running make in ${GTK3_BUILDDIR}"
+ default
+ fi
+}
+
+src_test() {
+ cd ${GTK2_BUILDDIR}
+ einfo "Running make check in ${GTK2_BUILDDIR}"
+ default
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ einfo "Running make check in ${GTK3_BUILDDIR}"
+ default
+ fi
+}
+
+src_install() {
+ cd ${GTK2_BUILDDIR}
+ einfo "Running make check in ${GTK2_BUILDDIR}"
+ default
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ einfo "Running make install in ${GTK3_BUILDDIR}"
+ default
+ fi
+
+ # Remove .la files if they're not needed
+ use static-libs || prune_libtool_files
+
+ use python && rm -rf "${ED}"/usr/lib*/python*/site-packages/*.la
+ use doc || rm -rf "${ED}/usr/share/gtk-doc"
+
+ make_desktop_entry spicy Spicy "utilities-terminal" "Network;RemoteAccess;"
+}