summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-04-06 06:42:26 +0000
committerJon Nelson <jnelson@gentoo.org>2002-04-06 06:42:26 +0000
commit15a97fedeb8b4a67c57ba228d78dbe17c9053de5 (patch)
tree9b81327ce3a820b0276c6b64ae50149dd8ed0952 /net-misc/sock/sock-1.1.ebuild
parentgcc3 fixes to tcp-wrappers (diff)
downloadgentoo-2-15a97fedeb8b4a67c57ba228d78dbe17c9053de5.tar.gz
gentoo-2-15a97fedeb8b4a67c57ba228d78dbe17c9053de5.tar.bz2
gentoo-2-15a97fedeb8b4a67c57ba228d78dbe17c9053de5.zip
Add sock-1.1 ebuild
Diffstat (limited to 'net-misc/sock/sock-1.1.ebuild')
-rw-r--r--net-misc/sock/sock-1.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/sock/sock-1.1.ebuild b/net-misc/sock/sock-1.1.ebuild
new file mode 100644
index 000000000000..f1dff7f79dad
--- /dev/null
+++ b/net-misc/sock/sock-1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Jon Nelson <jnelson@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+
+S=${WORKDIR}/${P}
+
+# Short one-line description of this package.
+DESCRIPTION="A shell interface to network sockets"
+
+# Point to any required sources; these will be automatically
+# downloaded by Portage.
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/local/mj/net/${P}.tar.gz"
+
+# Homepage, not used by Portage directly but handy for developer reference
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/linux.shtml"
+
+DEPEND=""
+
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+ #make || die
+}
+
+src_install () {
+ exeinto /usr/bin
+ doexe sock
+ doman sock.1
+# make DESTDIR=${D} install || die
+ dodoc README ChangeLog
+}