summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2009-08-20 12:23:49 +0000
committerRobert Buchholz <rbu@gentoo.org>2009-08-20 12:23:49 +0000
commitf88e1ec36c76d6ab265cc908357242e33c5b1877 (patch)
tree1f708488faac55037617977f1e6d91b047533273 /net-misc/radvd
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-f88e1ec36c76d6ab265cc908357242e33c5b1877.tar.gz
gentoo-2-f88e1ec36c76d6ab265cc908357242e33c5b1877.tar.bz2
gentoo-2-f88e1ec36c76d6ab265cc908357242e33c5b1877.zip
Version bump, bug 281637. Add another parallel-make patch to stop ylwrap from running in parallel with gcc. gnu-source detection is upstream.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/radvd')
-rw-r--r--net-misc/radvd/ChangeLog9
-rw-r--r--net-misc/radvd/files/radvd-1.4-parallel-make.patch9
-rw-r--r--net-misc/radvd/radvd-1.4.ebuild72
3 files changed, 89 insertions, 1 deletions
diff --git a/net-misc/radvd/ChangeLog b/net-misc/radvd/ChangeLog
index e65317ae2d5f..de0d0863796b 100644
--- a/net-misc/radvd/ChangeLog
+++ b/net-misc/radvd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/radvd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/ChangeLog,v 1.54 2009/08/20 11:42:38 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/ChangeLog,v 1.55 2009/08/20 12:23:49 rbu Exp $
+
+*radvd-1.4 (20 Aug 2009)
+
+ 20 Aug 2009; Robert Buchholz <rbu@gentoo.org> +radvd-1.4.ebuild,
+ +files/radvd-1.4-parallel-make.patch:
+ Version bump, bug 281637. Add another parallel-make patch to stop ylwrap
+ from running in parallel with gcc. gnu-source detection is upstream.
20 Aug 2009; Robert Buchholz <rbu@gentoo.org> -radvd-1.0-r1.ebuild,
radvd-1.1.ebuild:
diff --git a/net-misc/radvd/files/radvd-1.4-parallel-make.patch b/net-misc/radvd/files/radvd-1.4-parallel-make.patch
new file mode 100644
index 000000000000..64ae804f93bb
--- /dev/null
+++ b/net-misc/radvd/files/radvd-1.4-parallel-make.patch
@@ -0,0 +1,9 @@
+diff -Nuar radvd-1.1.orig/Makefile.am radvd-1.1/Makefile.am
+--- radvd-1.1.orig/Makefile.am 2008-01-24 02:03:17.000000000 -0800
++++ radvd-1.1/Makefile.am 2008-11-18 15:55:59.698396162 -0800
+@@ -61,3 +61,5 @@
+ mkdir $(distdir)/redhat
+ cp -p $(srcdir)/redhat/radvd.init $(srcdir)/redhat/radvd.spec \
+ $(srcdir)/redhat/radvd.sysconfig $(distdir)/redhat
++
++scanner.o: gram.h
diff --git a/net-misc/radvd/radvd-1.4.ebuild b/net-misc/radvd/radvd-1.4.ebuild
new file mode 100644
index 000000000000..a03194268094
--- /dev/null
+++ b/net-misc/radvd/radvd-1.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-1.4.ebuild,v 1.1 2009/08/20 12:23:49 rbu Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Linux IPv6 Router Advertisement Daemon"
+HOMEPAGE="http://v6web.litech.org/radvd/"
+SRC_URI="http://v6web.litech.org/radvd/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_FreeBSD"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex"
+RDEPEND=""
+
+pkg_setup() {
+ enewgroup radvd
+ enewuser radvd -1 -1 /dev/null radvd
+
+ # force ownership of radvd user and group (bug #19647)
+ [[ -d ${ROOT}/var/run/radvd ]] && chown radvd:radvd "${ROOT}"/var/run/radvd
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4-parallel-make.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-pidfile=/var/run/radvd/radvd.pid \
+ || die "econf failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc CHANGES README TODO radvd.conf.example
+ dohtml INTRO.html
+
+ newinitd "${FILESDIR}/${PN}".init "${PN}"
+ newconfd "${FILESDIR}/${PN}".conf "${PN}"
+
+ # location of radvd.pid needs to be writeable by the radvd user
+ keepdir /var/run/radvd
+ chown -R radvd:radvd "${D}"/var/run/radvd
+ fperms 755 /var/run/radvd
+
+ if use kernel_FreeBSD ; then
+ sed -i -e \
+ 's/^SYSCTL_FORWARD=.*$/SYSCTL_FORWARD=net.inet6.ip6.forwarding/g' \
+ "${D}"/etc/init.d/"${PN}" || die
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use ${PN} you must create the configuration file"
+ einfo "${ROOT}/etc/radvd.conf"
+ einfo
+ einfo "An example configuration file has been installed under"
+ einfo "${ROOT}/usr/share/doc/${PF}"
+ einfo
+ einfo "grsecurity users should allow a specific group to read /proc"
+ einfo "and add the radvd user to that group, otherwise radvd may"
+ einfo "segfault on startup."
+}