summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2012-06-02 22:05:05 +0000
committerChristian Birchinger <joker@gentoo.org>2012-06-02 22:05:05 +0000
commit9b243be22230127723fcb4af08e18bda2f9a3f4b (patch)
treeb32f15bfba325528a93d0edb0abc1e00ba74e06a /net-misc/r8168
parentstable for amd64, wrt to bug #418953 (diff)
downloadgentoo-2-9b243be22230127723fcb4af08e18bda2f9a3f4b.tar.gz
gentoo-2-9b243be22230127723fcb4af08e18bda2f9a3f4b.tar.bz2
gentoo-2-9b243be22230127723fcb4af08e18bda2f9a3f4b.zip
Version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/r8168')
-rw-r--r--net-misc/r8168/ChangeLog7
-rw-r--r--net-misc/r8168/r8168-8.031.00.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/net-misc/r8168/ChangeLog b/net-misc/r8168/ChangeLog
index 27b1130c0c37..c70a07ccad3d 100644
--- a/net-misc/r8168/ChangeLog
+++ b/net-misc/r8168/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/r8168
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/ChangeLog,v 1.11 2012/05/18 19:38:12 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/ChangeLog,v 1.12 2012/06/02 22:05:05 joker Exp $
+
+*r8168-8.031.00 (02 Jun 2012)
+
+ 02 Jun 2012; Christian Birchinger <joker@gentoo.org> +r8168-8.031.00.ebuild:
+ Version bump
*r8168-8.030.00 (18 May 2012)
diff --git a/net-misc/r8168/r8168-8.031.00.ebuild b/net-misc/r8168/r8168-8.031.00.ebuild
new file mode 100644
index 000000000000..3471f3bad8af
--- /dev/null
+++ b/net-misc/r8168/r8168-8.031.00.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/r8168-8.031.00.ebuild,v 1.1 2012/06/02 22:05:05 joker Exp $
+
+EAPI=4
+
+inherit linux-mod eutils
+
+DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
+HOMEPAGE="http://www.realtek.com.tw"
+SRC_URI="http://r8168.googlecode.com/files/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+MODULE_NAMES="r8168(net:${S}/src)"
+BUILD_TARGETS="modules"
+CONFIG_CHECK="!R8169"
+
+ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README
+}