summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-02-17 05:07:34 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-02-17 05:07:34 +0000
commit194b32fdcfa1830ef4ad8efa5fad4e868db1eb41 (patch)
tree9b5912eaf740d99a2192efda7d866fd5ee32644e /net-misc/openvswitch
parentRemove unneded useflag description from metadata.xml (diff)
downloadgentoo-2-194b32fdcfa1830ef4ad8efa5fad4e868db1eb41.tar.gz
gentoo-2-194b32fdcfa1830ef4ad8efa5fad4e868db1eb41.tar.bz2
gentoo-2-194b32fdcfa1830ef4ad8efa5fad4e868db1eb41.zip
fix for bug 500890 (introduced by removing pyside halfway)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'net-misc/openvswitch')
-rw-r--r--net-misc/openvswitch/ChangeLog9
-rw-r--r--net-misc/openvswitch/openvswitch-2.0.0-r1.ebuild154
-rw-r--r--net-misc/openvswitch/openvswitch-2.0.0-r3.ebuild (renamed from net-misc/openvswitch/openvswitch-2.0.0-r2.ebuild)5
-rw-r--r--net-misc/openvswitch/openvswitch-2.0.0.ebuild149
4 files changed, 11 insertions, 306 deletions
diff --git a/net-misc/openvswitch/ChangeLog b/net-misc/openvswitch/ChangeLog
index cd93373edfe5..71177834f359 100644
--- a/net-misc/openvswitch/ChangeLog
+++ b/net-misc/openvswitch/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/openvswitch
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/ChangeLog,v 1.21 2014/02/09 08:56:18 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/ChangeLog,v 1.22 2014/02/17 05:07:34 prometheanfire Exp $
+
+*openvswitch-2.0.0-r3 (17 Feb 2014)
+
+ 17 Feb 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +openvswitch-2.0.0-r3.ebuild, -openvswitch-2.0.0-r1.ebuild,
+ -openvswitch-2.0.0-r2.ebuild, -openvswitch-2.0.0.ebuild:
+ fix for bug 500890 (introduced by removing pyside halfway)
*openvswitch-2.0.0-r2 (09 Feb 2014)
diff --git a/net-misc/openvswitch/openvswitch-2.0.0-r1.ebuild b/net-misc/openvswitch/openvswitch-2.0.0-r1.ebuild
deleted file mode 100644
index d4391ba7e8a2..000000000000
--- a/net-misc/openvswitch/openvswitch-2.0.0-r1.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-2.0.0-r1.ebuild,v 1.1 2013/12/14 13:06:53 pacho Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils linux-info linux-mod python-single-r1 systemd
-
-DESCRIPTION="Production quality, multilayer virtual switch"
-HOMEPAGE="http://openvswitch.org"
-SRC_URI="http://openvswitch.org/releases/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug modules monitor +pyside +ssl"
-
-RDEPEND=">=sys-apps/openrc-0.10.5
- ssl? ( dev-libs/openssl )
- monitor? (
- ${PYTHON_DEPS}
- dev-python/twisted-core
- dev-python/twisted-conch
- dev-python/twisted-web
- pyside? ( dev-python/pyside[${PYTHON_USEDEP}] )
- !pyside? ( dev-python/PyQt4[${PYTHON_USEDEP}] )
- net-zope/zope-interface[${PYTHON_USEDEP}] )
- debug? ( dev-lang/perl )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
-MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
-BUILD_TARGETS="all"
-
-pkg_setup() {
- if use modules ; then
- CONFIG_CHECK+=" ~!OPENVSWITCH"
- kernel_is ge 2 6 32 || die "Linux >=2.6.32 and <3.10 required"
- kernel_is lt 3 11 || die "Linux >=2.6.18 and <3.11 required"
- linux-mod_pkg_setup
- else
- CONFIG_CHECK+=" ~OPENVSWITCH"
- linux-info_pkg_setup
- fi
- use monitor && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # Never build kernelmodules, doing this manually
- sed -i \
- -e '/^SUBDIRS/d' \
- datapath/Makefile.in || die "sed failed"
- epatch "${FILESDIR}/prevent-traceback.patch"
-}
-src_configure() {
- set_arch_to_kernel
- use monitor || export ovs_cv_python="no"
- use pyside || export ovs_cv_pyuic4="no"
-
- local linux_config
- use modules && linux_config="--with-linux=${KERNEL_DIR}"
-
- econf ${linux_config} \
- --with-rundir=/var/run/openvswitch \
- --with-logdir=/var/log/openvswitch \
- --with-pkidir=/etc/ssl/openvswitch \
- --with-dbdir=/var/lib/openvswitch \
- $(use_enable ssl) \
- $(use_enable !debug ndebug)
-}
-
-src_compile() {
- default
-
- use monitor && python_fix_shebang \
- utilities/ovs-{pcap,tcpundump,test,vlan-test} \
- utilities/bugtool/ovs-bugtool \
- ovsdb/ovsdbmonitor/ovsdbmonitor
-
- use modules && linux-mod_src_compile
-}
-
-src_install() {
- default
-
- if use monitor ; then
- python_domodule "${ED}"/usr/share/openvswitch/python/*
- rm -r "${ED}/usr/share/openvswitch/python"
- python_optimize "${ED}/usr/share/ovsdbmonitor"
- fi
- # not working without the brcompat_mod kernel module which did not get
- # included in the kernel and we can't build it anymore
- rm "${D}/usr/sbin/ovs-brcompatd" "${D}/usr/share/man/man8/ovs-brcompatd.8"
-
- keepdir /var/{lib,log}/openvswitch
- keepdir /etc/ssl/openvswitch
- fperms 0750 /etc/ssl/openvswitch
-
- rm -rf "${ED}/var/run"
- use monitor || rmdir "${ED}/usr/share/ovsdbmonitor"
- use debug || rm "${ED}/usr/bin/ovs-parse-leaks"
-
- newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
- newconfd "${FILESDIR}/ovs-vswitchd_conf" ovs-vswitchd
- newconfd "${FILESDIR}/ovs-controller_conf" ovs-controller
- newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
- newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
- newinitd "${FILESDIR}/ovs-controller-r1" ovs-controller
-
- systemd_dounit "${FILESDIR}/ovsdb-server.service"
- systemd_dounit "${FILESDIR}/ovs-vswitchd.service"
- systemd_dounit "${FILESDIR}/ovs-controller.service"
- systemd_newtmpfilesd "${FILESDIR}/openvswitch.tmpfiles" openvswitch.conf
-
- insinto /etc/logrotate.d
- newins rhel/etc_logrotate.d_openvswitch openvswitch
-
- use modules && linux-mod_src_install
-}
-
-pkg_postinst() {
- use modules && linux-mod_pkg_postinst
-
- for pv in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 1.9.0 ${pv} ; then
- ewarn "The configuration database for Open vSwitch got moved in version 1.9.0 from"
- ewarn " /etc/openvswitch"
- ewarn "to"
- ewarn " /var/lib/openvswitch"
- ewarn "Please copy/move the database manually before running the schema upgrade."
- ewarn "The PKI files are now supposed to go to /etc/ssl/openvswitch"
- fi
- done
-
- elog "Use the following command to create an initial database for ovsdb-server:"
- elog " emerge --config =${CATEGORY}/${PF}"
- elog "(will create a database in /var/lib/openvswitch/conf.db)"
- elog "or to convert the database to the current schema after upgrading."
-}
-
-pkg_config() {
- local db="${EPREFIX}/var/lib/openvswitch/conf.db"
- if [ -e "${db}" ] ; then
- einfo "Database '${db}' already exists, doing schema migration..."
- einfo "(if the migration fails, make sure that ovsdb-server is not running)"
- "${EPREFIX}/usr/bin/ovsdb-tool" convert "${db}" "${EPREFIX}/usr/share/openvswitch/vswitch.ovsschema" || die "converting database failed"
- else
- einfo "Creating new database '${db}'..."
- "${EPREFIX}/usr/bin/ovsdb-tool" create "${db}" "${EPREFIX}/usr/share/openvswitch/vswitch.ovsschema" || die "creating database failed"
- fi
-}
diff --git a/net-misc/openvswitch/openvswitch-2.0.0-r2.ebuild b/net-misc/openvswitch/openvswitch-2.0.0-r3.ebuild
index 93d1c782a314..5a4a4de1548f 100644
--- a/net-misc/openvswitch/openvswitch-2.0.0-r2.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.0.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-2.0.0-r2.ebuild,v 1.1 2014/02/09 08:56:18 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-2.0.0-r3.ebuild,v 1.1 2014/02/17 05:07:34 prometheanfire Exp $
EAPI=5
@@ -63,7 +63,8 @@ src_prepare() {
src_configure() {
set_arch_to_kernel
use monitor || export ovs_cv_python="no"
- use pyside || export ovs_cv_pyuic4="no"
+ #pyside is staticly disabled
+ export ovs_cv_pyuic4="no"
local linux_config
use modules && linux_config="--with-linux=${KV_OUT_DIR}"
diff --git a/net-misc/openvswitch/openvswitch-2.0.0.ebuild b/net-misc/openvswitch/openvswitch-2.0.0.ebuild
deleted file mode 100644
index 496da244a3ca..000000000000
--- a/net-misc/openvswitch/openvswitch-2.0.0.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-2.0.0.ebuild,v 1.5 2013/12/11 03:05:13 prometheanfire Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils linux-info linux-mod python-single-r1
-
-DESCRIPTION="Production quality, multilayer virtual switch."
-HOMEPAGE="http://openvswitch.org"
-SRC_URI="http://openvswitch.org/releases/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug modules monitor +pyside +ssl"
-
-RDEPEND=">=sys-apps/openrc-0.10.5
- ssl? ( dev-libs/openssl )
- monitor? (
- ${PYTHON_DEPS}
- dev-python/twisted-core
- dev-python/twisted-conch
- dev-python/twisted-web
- pyside? ( dev-python/pyside[${PYTHON_USEDEP}] )
- !pyside? ( dev-python/PyQt4[${PYTHON_USEDEP}] )
- net-zope/zope-interface[${PYTHON_USEDEP}] )
- debug? ( dev-lang/perl )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
-MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
-BUILD_TARGETS="all"
-
-pkg_setup() {
- if use modules ; then
- CONFIG_CHECK+=" ~!OPENVSWITCH"
- kernel_is ge 2 6 32 || die "Linux >=2.6.32 and <3.10 required"
- kernel_is lt 3 11 || die "Linux >=2.6.18 and <3.11 required"
- linux-mod_pkg_setup
- else
- CONFIG_CHECK+=" ~OPENVSWITCH"
- linux-info_pkg_setup
- fi
- use monitor && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # Never build kernelmodules, doing this manually
- sed -i \
- -e '/^SUBDIRS/d' \
- datapath/Makefile.in || die "sed failed"
- epatch "${FILESDIR}/prevent-traceback.patch"
-}
-src_configure() {
- set_arch_to_kernel
- use monitor || export ovs_cv_python="no"
- use pyside || export ovs_cv_pyuic4="no"
-
- local linux_config
- use modules && linux_config="--with-linux=${KERNEL_DIR}"
-
- econf ${linux_config} \
- --with-rundir=/var/run/openvswitch \
- --with-logdir=/var/log/openvswitch \
- --with-pkidir=/etc/ssl/openvswitch \
- --with-dbdir=/var/lib/openvswitch \
- $(use_enable ssl) \
- $(use_enable !debug ndebug)
-}
-
-src_compile() {
- default
-
- use monitor && python_fix_shebang \
- utilities/ovs-{pcap,tcpundump,test,vlan-test} \
- utilities/bugtool/ovs-bugtool \
- ovsdb/ovsdbmonitor/ovsdbmonitor
-
- use modules && linux-mod_src_compile
-}
-
-src_install() {
- default
-
- if use monitor ; then
- python_domodule "${ED}"/usr/share/openvswitch/python/*
- rm -r "${ED}/usr/share/openvswitch/python"
- python_optimize "${ED}/usr/share/ovsdbmonitor"
- fi
- # not working without the brcompat_mod kernel module which did not get
- # included in the kernel and we can't build it anymore
- rm "${D}/usr/sbin/ovs-brcompatd" "${D}/usr/share/man/man8/ovs-brcompatd.8"
-
- keepdir /var/{lib,log}/openvswitch
- keepdir /etc/ssl/openvswitch
- fperms 0750 /etc/ssl/openvswitch
-
- rm -rf "${ED}/var/run"
- use monitor || rmdir "${ED}/usr/share/ovsdbmonitor"
- use debug || rm "${ED}/usr/bin/ovs-parse-leaks"
-
- newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
- newconfd "${FILESDIR}/ovs-vswitchd_conf" ovs-vswitchd
- newconfd "${FILESDIR}/ovs-controller_conf" ovs-controller
- newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
- newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
- newinitd "${FILESDIR}/ovs-controller-r1" ovs-controller
-
- insinto /etc/logrotate.d
- newins rhel/etc_logrotate.d_openvswitch openvswitch
-
- use modules && linux-mod_src_install
-}
-
-pkg_postinst() {
- use modules && linux-mod_pkg_postinst
-
- for pv in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 1.9.0 ${pv} ; then
- ewarn "The configuration database for Open vSwitch got moved in version 1.9.0 from"
- ewarn " /etc/openvswitch"
- ewarn "to"
- ewarn " /var/lib/openvswitch"
- ewarn "Please copy/move the database manually before running the schema upgrade."
- ewarn "The PKI files are now supposed to go to /etc/ssl/openvswitch"
- fi
- done
-
- elog "Use the following command to create an initial database for ovsdb-server:"
- elog " emerge --config =${CATEGORY}/${PF}"
- elog "(will create a database in /var/lib/openvswitch/conf.db)"
- elog "or to convert the database to the current schema after upgrading."
-}
-
-pkg_config() {
- local db="${EPREFIX}/var/lib/openvswitch/conf.db"
- if [ -e "${db}" ] ; then
- einfo "Database '${db}' already exists, doing schema migration..."
- einfo "(if the migration fails, make sure that ovsdb-server is not running)"
- "${EPREFIX}/usr/bin/ovsdb-tool" convert "${db}" "${EPREFIX}/usr/share/openvswitch/vswitch.ovsschema" || die "converting database failed"
- else
- einfo "Creating new database '${db}'..."
- "${EPREFIX}/usr/bin/ovsdb-tool" create "${db}" "${EPREFIX}/usr/share/openvswitch/vswitch.ovsschema" || die "creating database failed"
- fi
-}