summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-02-10 02:32:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-02-10 02:32:42 +0000
commit70ad6cc450ff992d28adacdb4192fd1e92d62d8a (patch)
tree5b5033f86b377ef9e86dea24756705dd73cebb30 /net-misc/openssh
parentBug #354113: AES-CTR workaround was dropped from 5.7 and 5.8 when it is still... (diff)
downloadgentoo-2-70ad6cc450ff992d28adacdb4192fd1e92d62d8a.tar.gz
gentoo-2-70ad6cc450ff992d28adacdb4192fd1e92d62d8a.tar.bz2
gentoo-2-70ad6cc450ff992d28adacdb4192fd1e92d62d8a.zip
Also add AES-CTR fix to 5.8_p1 presently under stabilization. alpha/hppa/ppc64 are the only stable arches with the broken HPN version at present.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/openssh')
-rw-r--r--net-misc/openssh/ChangeLog7
-rw-r--r--net-misc/openssh/openssh-5.8_p1.ebuild9
2 files changed, 14 insertions, 2 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index 8eccc4620a57..b2d0da300386 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.407 2011/02/10 02:30:27 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.408 2011/02/10 02:32:42 robbat2 Exp $
+
+ 10 Feb 2011; Robin H. Johnson <robbat2@gentoo.org> openssh-5.8_p1.ebuild:
+ Also add AES-CTR fix to 5.8_p1 presently under stabilization.
+ alpha/hppa/ppc64 are the only stable arches with the broken HPN version at
+ present.
*openssh-5.8_p1-r1 (10 Feb 2011)
diff --git a/net-misc/openssh/openssh-5.8_p1.ebuild b/net-misc/openssh/openssh-5.8_p1.ebuild
index d9b7cf29eae2..7b83cc149d2f 100644
--- a/net-misc/openssh/openssh-5.8_p1.ebuild
+++ b/net-misc/openssh/openssh-5.8_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.8_p1.ebuild,v 1.4 2011/02/08 21:39:12 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.8_p1.ebuild,v 1.5 2011/02/10 02:32:42 robbat2 Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -97,6 +97,13 @@ src_prepare() {
# version.h patch conflict avoidence
mv version.h version.h.hpn
cp -f version.h.pristine version.h
+ # The AES-CTR multithreaded variant is temporarily broken, and
+ # causes random hangs when combined with the -f switch of ssh.
+ # To avoid this, we change the internal table to use the non-multithread
+ # version for the meantime. Do NOT remove this in new versions.
+ sed -i \
+ -e '/aes...-ctr.*SSH_CIPHER_SSH2/s,evp_aes_ctr_mt,evp_aes_128_ctr,' \
+ cipher.c || die
fi
sed -i "s:-lcrypto:$(pkg-config --libs openssl):" configure{,.ac} || die