summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-11-01 22:40:32 +0000
committerVlastimil Babka <caster@gentoo.org>2008-11-01 22:40:32 +0000
commit3a1cf68e386af9d8193e3e1eed2cb04d9d7f59ae (patch)
treeace8f4f3b636945bfba663387d65ec88e3e055e2 /net-misc/omniORB
parentWhitespace. (diff)
downloadgentoo-2-3a1cf68e386af9d8193e3e1eed2cb04d9d7f59ae.tar.gz
gentoo-2-3a1cf68e386af9d8193e3e1eed2cb04d9d7f59ae.tar.bz2
gentoo-2-3a1cf68e386af9d8193e3e1eed2cb04d9d7f59ae.zip
Version bump. Should fix CFLAGS handling - bug #241076.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo-r1-perfctr x86_64)
Diffstat (limited to 'net-misc/omniORB')
-rw-r--r--net-misc/omniORB/ChangeLog8
-rw-r--r--net-misc/omniORB/files/mkomnistubs.py24
-rw-r--r--net-misc/omniORB/omniORB-4.1.0.ebuild81
-rw-r--r--net-misc/omniORB/omniORB-4.1.1.ebuild80
-rw-r--r--net-misc/omniORB/omniORB-4.1.3.ebuild84
5 files changed, 91 insertions, 186 deletions
diff --git a/net-misc/omniORB/ChangeLog b/net-misc/omniORB/ChangeLog
index a4e111c7a742..6694dfa87b5a 100644
--- a/net-misc/omniORB/ChangeLog
+++ b/net-misc/omniORB/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/omniORB
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/ChangeLog,v 1.49 2008/04/02 21:20:13 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/ChangeLog,v 1.50 2008/11/01 22:40:32 caster Exp $
+
+*omniORB-4.1.3 (01 Nov 2008)
+
+ 01 Nov 2008; Vlastimil Babka <caster@gentoo.org> -files/mkomnistubs.py,
+ -omniORB-4.1.0.ebuild, -omniORB-4.1.1.ebuild, +omniORB-4.1.3.ebuild:
+ Version bump. Should fix CFLAGS handling - bug #241076.
*omniORB-4.1.2 (02 Apr 2008)
diff --git a/net-misc/omniORB/files/mkomnistubs.py b/net-misc/omniORB/files/mkomnistubs.py
deleted file mode 100644
index 47c3e8386486..000000000000
--- a/net-misc/omniORB/files/mkomnistubs.py
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/usr/bin/env python
-
-
-import os
-
-
-idlfiles = ["TimeBase", "CosTime", "CosEventComm", "CosEventChannelAdmin",
-"CosTypedEventComm", "CosTypedEventChannelAdmin", "CosTimerEvent",
-"CosNotification", "CosNotifyComm", "CosNotifyFilter",
-"CosNotifyChannelAdmin", "CosTypedNotifyComm", "CosTypedNotifyChannelAdmin",
-"AttNotifyChannelAdmin"]
-
-
-# d is the top-level idl directory from an omniORB release
-d = "/usr/idl"
-
-
-for x in idlfiles:
- y = x + ".idl"
- print x
- cmd = "omniidl -bpython -C /usr/lib/python2.1/site-packages/ -I%s -I%s/COS -DNOLONGLONG %s/COS/%s" % (d, d, d, y)
- print cmd
- os.system(cmd)
-
diff --git a/net-misc/omniORB/omniORB-4.1.0.ebuild b/net-misc/omniORB/omniORB-4.1.0.ebuild
deleted file mode 100644
index f8bdb3fed346..000000000000
--- a/net-misc/omniORB/omniORB-4.1.0.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/omniORB-4.1.0.ebuild,v 1.2 2007/04/28 17:00:45 swegener Exp $
-
-inherit python
-
-DESCRIPTION="A robust, high-performance CORBA 2 ORB"
-SRC_URI="mirror://sourceforge/omniorb/${PF}.tar.gz"
-HOMEPAGE="http://omniorb.sourceforge.net/"
-
-IUSE="ssl"
-
-LICENSE="LGPL-2 GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-DEPEND="dev-lang/python
- ssl? ( >=dev-libs/openssl-0.9.6b )"
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s/^CXXDEBUGFLAGS.*/CXXDEBUGFLAGS = ${CXXFLAGS}/" \
- -e "s/^CDEBUGFLAGS.*/CDEBUGFLAGS = ${CFLAGS}/" \
- ${S}/mk/beforeauto.mk.in \
- ${S}/mk/platforms/i586_linux_2.0_*.mk
-}
-
-src_compile() {
- cd ${S}
-
- mkdir ${S}/build
- cd ${S}/build
-
- MY_CONF="--prefix=/usr --with-omniORB-config=/etc/omniorb/omniORB.cfg --with-omniNames-logdir=/var/log/omniORB"
-
- use ssl && MY_CONF="${MY_CONF} --with-openssl=/usr"
-
- python_version
- PYTHON=/usr/bin/python${PYVER} ../configure ${MY_CONF} \
- || die "./configure failed"
-
- emake || die "make failed"
-}
-
-src_install () {
-
- cd ${S}/build
- emake DESTDIR=${D} install
-
- cd ${S}
- dodoc COPYING* CREDITS README* ReleaseNotes*
-
- cd ${S}/doc
- docinto print
- dodoc *.ps
- dodoc *.tex
- dodoc *.pdf
-
- dodir /etc/env.d/
- echo "PATH=/usr/share/omniORB/bin/scripts" > ${D}/etc/env.d/90omniORB
- echo "OMNIORB_CONFIG=/etc/omniorb/omniORB.cfg" >> ${D}/etc/env.d/90omniORB
- newinitd ${FILESDIR}/omniORB-4.0.0 omniORB
-
- cp ${S}/sample.cfg ${S}/omniORB.cfg
- dodir /etc/omniorb
- insinto /etc/omniorb
- doins ${S}/omniORB.cfg
-
- keepdir /var/log/omniORB
-}
-
-pkg_postinst() {
- echo "Performing post-installation routines for ${P}."
-
- if [ ! -f "${ROOT}etc/omniorb/omniORB.cfg" ] ; then
- echo "ORBInitialHost `uname -n`" > ${ROOT}etc/omniorb/omniORB.cfg
- echo "ORBInitialPort 2809" >> ${ROOT}etc/omniorb/omniORB.cfg
- fi
-
- #/usr/bin/python ${ROOT}usr/share/doc/${PF}/mkomnistubs.py
-}
diff --git a/net-misc/omniORB/omniORB-4.1.1.ebuild b/net-misc/omniORB/omniORB-4.1.1.ebuild
deleted file mode 100644
index 8a6ebc0c5be4..000000000000
--- a/net-misc/omniORB/omniORB-4.1.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/omniORB-4.1.1.ebuild,v 1.1 2007/11/03 17:04:58 caleb Exp $
-
-inherit python
-
-DESCRIPTION="A robust, high-performance CORBA 2 ORB"
-SRC_URI="mirror://sourceforge/omniorb/${PF}.tar.gz"
-HOMEPAGE="http://omniorb.sourceforge.net/"
-
-IUSE="ssl"
-
-LICENSE="LGPL-2 GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-DEPEND="dev-lang/python
- ssl? ( >=dev-libs/openssl-0.9.6b )"
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s/^CXXDEBUGFLAGS.*/CXXDEBUGFLAGS = ${CXXFLAGS}/" \
- -e "s/^CDEBUGFLAGS.*/CDEBUGFLAGS = ${CFLAGS}/" \
- ${S}/mk/beforeauto.mk.in \
- ${S}/mk/platforms/i586_linux_2.0_*.mk
-}
-
-src_compile() {
- cd "${S}"
-
- mkdir "${S}/build"
- cd "${S}/build"
-
- MY_CONF="--prefix=/usr --with-omniORB-config=/etc/omniorb/omniORB.cfg --with-omniNames-logdir=/var/log/omniORB"
-
- use ssl && MY_CONF="${MY_CONF} --with-openssl=/usr"
-
- python_version
- PYTHON=/usr/bin/python${PYVER} ../configure ${MY_CONF} \
- || die "./configure failed"
-
- emake || die "make failed"
-}
-
-src_install () {
-
- cd "${S}/build"
- emake DESTDIR="${D}" install
-
- cd "${S}"
- dodoc COPYING* CREDITS README* ReleaseNotes*
-
- cd "${S}/doc"
- docinto print
- dodoc *.ps
- dodoc *.tex
- dodoc *.pdf
-
- dodir /etc/env.d/
- echo "PATH=/usr/share/omniORB/bin/scripts" > "${D}"/etc/env.d/90omniORB
- echo "OMNIORB_CONFIG=/etc/omniorb/omniORB.cfg" >> "${D}"/etc/env.d/90omniORB
- newinitd ${FILESDIR}/omniORB-4.0.0 omniORB
-
- cp "${S}/sample.cfg" "${S}/omniORB.cfg"
- dodir /etc/omniorb
- insinto /etc/omniorb
- doins "${S}/omniORB.cfg"
-
- keepdir /var/log/omniORB
-}
-
-pkg_postinst() {
- echo "Performing post-installation routines for ${P}."
-
- if [ ! -f "${ROOT}etc/omniorb/omniORB.cfg" ] ; then
- echo "ORBInitialHost `uname -n`" > "${ROOT}etc/omniorb/omniORB.cfg"
- echo "ORBInitialPort 2809" >> "${ROOT}etc/omniorb/omniORB.cfg"
- fi
-
-}
diff --git a/net-misc/omniORB/omniORB-4.1.3.ebuild b/net-misc/omniORB/omniORB-4.1.3.ebuild
new file mode 100644
index 000000000000..69e071d01f5a
--- /dev/null
+++ b/net-misc/omniORB/omniORB-4.1.3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/omniORB-4.1.3.ebuild,v 1.1 2008/11/01 22:40:32 caster Exp $
+
+inherit python eutils
+
+DESCRIPTION="A robust, high-performance CORBA 2 ORB"
+SRC_URI="mirror://sourceforge/omniorb/${PF}.tar.gz"
+HOMEPAGE="http://omniorb.sourceforge.net/"
+
+IUSE="ssl"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-lang/python
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e 's/^CXXDEBUGFLAGS.*/CXXDEBUGFLAGS = $(OPTCXXFLAGS)/' \
+ -e 's/^CDEBUGFLAGS.*/CDEBUGFLAGS = $(OPTCFLAGS)/' \
+ mk/beforeauto.mk.in \
+ mk/platforms/i586_linux_2.0*.mk || die "sed failed"
+}
+
+src_compile() {
+ mkdir build || die
+ cd build
+
+ MY_CONF="--prefix=/usr --with-omniORB-config=/etc/omniorb/omniORB.cfg \
+ --with-omniNames-logdir=/var/log/omniORB --libdir=/usr/$(get_libdir)"
+
+ use ssl && MY_CONF="${MY_CONF} --with-openssl=/usr"
+
+ python_version
+ PYTHON=/usr/bin/python${PYVER} ECONF_SOURCE=".." econf ${MY_CONF} \
+ || die "./configure failed"
+
+ emake OPTCFLAGS="${OPTCFLAGS}" OPTCXXFLAGS="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install () {
+ cd "${S}/build"
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ cd "${S}"
+ dodoc COPYING* CREDITS README* ReleaseNotes* || die
+
+ docinto print
+ dodoc doc/*.ps doc/*.pdf || die
+
+ dodir /etc/env.d/
+ cat <<- EOF > "${T}/90omniORB"
+ PATH="/usr/share/omniORB/bin/scripts"
+ OMNIORB_CONFIG="/etc/omniorb/omniORB.cfg"
+ EOF
+ doenvd "${T}/90omniORB" || die
+ doinitd "${FILESDIR}"/omniNames || die
+
+ cp "sample.cfg" "${T}/omniORB.cfg" || die
+ cat <<- EOF >> "${T}/omniORB.cfg"
+ # resolve the omniNames running on localhost
+ InitRef = NameService=corbaname::localhost
+ EOF
+ dodir /etc/omniorb
+ insinto /etc/omniorb
+ doins "${T}/omniORB.cfg" || die
+
+ keepdir /var/log/omniORB
+}
+
+pkg_postinst() {
+ elog "Since 4.1.2, the omniORB init script has been renamed to omniNames for clarity."
+ python_mod_optimize "/usr/$(get_libdir)/python${PYVER}/site-packages/omniidl"
+ python_mod_optimize "/usr/$(get_libdir)/python${PYVER}/site-packages/omniidl_be"
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}