summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-10-19 19:26:07 +0000
committerMike Gilbert <floppym@gentoo.org>2013-10-19 19:26:07 +0000
commitb0ab7c77d5d2a5c61f32734fae6297906be4edee (patch)
treeec06779afa989322123db94641ca087352532e4c /net-misc/netctl
parentRemove unnecessary build delay (diff)
downloadgentoo-2-b0ab7c77d5d2a5c61f32734fae6297906be4edee.tar.gz
gentoo-2-b0ab7c77d5d2a5c61f32734fae6297906be4edee.tar.bz2
gentoo-2-b0ab7c77d5d2a5c61f32734fae6297906be4edee.zip
Update LICENSE to GPL-3. Remove old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-misc/netctl')
-rw-r--r--net-misc/netctl/ChangeLog6
-rw-r--r--net-misc/netctl/netctl-1.1-r1.ebuild80
-rw-r--r--net-misc/netctl/netctl-1.2.ebuild79
-rw-r--r--net-misc/netctl/netctl-1.3.ebuild5
-rw-r--r--net-misc/netctl/netctl-9999.ebuild5
5 files changed, 11 insertions, 164 deletions
diff --git a/net-misc/netctl/ChangeLog b/net-misc/netctl/ChangeLog
index e1d1bf86ae5d..101d0e381a93 100644
--- a/net-misc/netctl/ChangeLog
+++ b/net-misc/netctl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/netctl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.13 2013/09/28 16:00:31 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.14 2013/10/19 19:26:07 floppym Exp $
+
+ 19 Oct 2013; Mike Gilbert <floppym@gentoo.org> -netctl-1.1-r1.ebuild,
+ -netctl-1.2.ebuild, netctl-1.3.ebuild, netctl-9999.ebuild:
+ Update LICENSE to GPL-3. Remove old.
*netctl-1.3 (28 Sep 2013)
diff --git a/net-misc/netctl/netctl-1.1-r1.ebuild b/net-misc/netctl/netctl-1.1-r1.ebuild
deleted file mode 100644
index a7e9a9f0318a..000000000000
--- a/net-misc/netctl/netctl-1.1-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-1.1-r1.ebuild,v 1.6 2013/08/02 16:26:09 floppym Exp $
-
-EAPI=5
-
-inherit bash-completion-r1
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
- inherit git-2
- DEPEND="app-text/asciidoc"
-else
- SRC_URI="ftp://ftp.archlinux.org/other/packages/${PN}/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Profile based network connection tool from Arch Linux"
-HOMEPAGE="https://wiki.archlinux.org/index.php/Netctl
- https://www.archlinux.org/packages/core/any/netctl/
- https://projects.archlinux.org/netctl.git/"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-DEPEND+="
- virtual/pkgconfig
- sys-apps/systemd
-"
-RDEPEND="
- >=app-shells/bash-4.0
- >=net-dns/openresolv-3.5.4-r1
- sys-apps/iproute2
- sys-apps/systemd
- !<net-misc/dhcpcd-5.6.7
-"
-
-src_prepare() {
- sed -i -e "s:/usr/bin/ifplugd:/usr/sbin/ifplugd:" \
- "services/netctl-ifplugd@.service" || die
-}
-
-src_compile() {
- return 0
-}
-
-src_install() {
- emake DESTDIR="${D%/}" SHELL=bash install
- dodoc AUTHORS NEWS README
- newbashcomp contrib/bash-completion netctl
- insinto /usr/share/zsh/site-functions
- newins contrib/zsh-completion _netctl
-}
-
-optfeature() {
- local desc=$1
- shift
- while (( $# )); do
- if has_version "$1"; then
- elog " [I] $1 for ${desc}"
- else
- elog " [ ] $1 for ${desc}"
- fi
- shift
- done
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "To get additional features, a number of option runtime dependencies may be"
- elog "installed."
- optfeature "DHCP support" net-misc/dhcpcd ">=net-misc/dhcp-5.6.7[client]"
- optfeature "WPA support" net-wireless/wpa_supplicant
- optfeature "interactive assistant" dev-util/dialog
- optfeature "automatic connection" sys-apps/ifplugd
- optfeature "bonding support" net-misc/ifenslave
- optfeature "bridge support" net-misc/bridge-utils
- optfeature "dialup support" net-dialup/ppp
- fi
-}
diff --git a/net-misc/netctl/netctl-1.2.ebuild b/net-misc/netctl/netctl-1.2.ebuild
deleted file mode 100644
index 1cab12543055..000000000000
--- a/net-misc/netctl/netctl-1.2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-1.2.ebuild,v 1.1 2013/08/02 16:26:09 floppym Exp $
-
-EAPI=5
-
-inherit bash-completion-r1
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
- inherit git-2
- DEPEND="app-text/asciidoc"
-else
- SRC_URI="ftp://ftp.archlinux.org/other/packages/${PN}/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Profile based network connection tool from Arch Linux"
-HOMEPAGE="https://wiki.archlinux.org/index.php/Netctl
- https://www.archlinux.org/packages/core/any/netctl/
- https://projects.archlinux.org/netctl.git/"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-DEPEND+="
- virtual/pkgconfig
- sys-apps/systemd
-"
-RDEPEND="
- >=app-shells/bash-4.0
- >=net-dns/openresolv-3.5.4-r1
- sys-apps/iproute2
- sys-apps/systemd
- !<net-misc/dhcpcd-5.6.7
-"
-
-src_prepare() {
- sed -i -e "s:/usr/bin/ifplugd:/usr/sbin/ifplugd:" \
- "services/netctl-ifplugd@.service" || die
-}
-
-src_compile() {
- return 0
-}
-
-src_install() {
- emake DESTDIR="${D%/}" SHELL=bash install
- dodoc AUTHORS NEWS README
- newbashcomp contrib/bash-completion netctl
- insinto /usr/share/zsh/site-functions
- newins contrib/zsh-completion _netctl
-}
-
-optfeature() {
- local desc=$1
- shift
- while (( $# )); do
- if has_version "$1"; then
- elog " [I] $1 for ${desc}"
- else
- elog " [ ] $1 for ${desc}"
- fi
- shift
- done
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "To get additional features, a number of optional runtime dependencies may be"
- elog "installed."
- optfeature "DHCP support" net-misc/dhcpcd ">=net-misc/dhcp-5.6.7[client]"
- optfeature "WPA support" net-wireless/wpa_supplicant
- optfeature "interactive assistant" dev-util/dialog
- optfeature "automatic connection" sys-apps/ifplugd
- optfeature "bonding support" net-misc/ifenslave
- optfeature "dialup support" net-dialup/ppp
- fi
-}
diff --git a/net-misc/netctl/netctl-1.3.ebuild b/net-misc/netctl/netctl-1.3.ebuild
index 5c505da1af51..3f68eaba41d9 100644
--- a/net-misc/netctl/netctl-1.3.ebuild
+++ b/net-misc/netctl/netctl-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-1.3.ebuild,v 1.1 2013/09/28 16:00:31 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-1.3.ebuild,v 1.2 2013/10/19 19:26:07 floppym Exp $
EAPI=5
@@ -19,7 +19,8 @@ DESCRIPTION="Profile based network connection tool from Arch Linux"
HOMEPAGE="https://wiki.archlinux.org/index.php/Netctl
https://www.archlinux.org/packages/core/any/netctl/
https://projects.archlinux.org/netctl.git/"
-LICENSE="BSD"
+
+LICENSE="GPL-3"
SLOT="0"
IUSE=""
diff --git a/net-misc/netctl/netctl-9999.ebuild b/net-misc/netctl/netctl-9999.ebuild
index 35aefb29ecbc..7ce5267aef5a 100644
--- a/net-misc/netctl/netctl-9999.ebuild
+++ b/net-misc/netctl/netctl-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-9999.ebuild,v 1.10 2013/08/02 16:26:09 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-9999.ebuild,v 1.11 2013/10/19 19:26:07 floppym Exp $
EAPI=5
@@ -19,7 +19,8 @@ DESCRIPTION="Profile based network connection tool from Arch Linux"
HOMEPAGE="https://wiki.archlinux.org/index.php/Netctl
https://www.archlinux.org/packages/core/any/netctl/
https://projects.archlinux.org/netctl.git/"
-LICENSE="BSD"
+
+LICENSE="GPL-3"
SLOT="0"
IUSE=""