summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-06-08 17:08:17 +0000
committerMike Gilbert <floppym@gentoo.org>2013-06-08 17:08:17 +0000
commit0a755b0cae9e7119ba51c95db39ac25fcab2f7d2 (patch)
tree09683b41dff2702a45cd4718021a475a4121eb23 /net-misc/netctl
parentfix for EPREFIX starting with . (diff)
downloadgentoo-2-0a755b0cae9e7119ba51c95db39ac25fcab2f7d2.tar.gz
gentoo-2-0a755b0cae9e7119ba51c95db39ac25fcab2f7d2.tar.bz2
gentoo-2-0a755b0cae9e7119ba51c95db39ac25fcab2f7d2.zip
Fix path to ifplugd, bug 472682 by Alexander Tsoy.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-misc/netctl')
-rw-r--r--net-misc/netctl/ChangeLog8
-rw-r--r--net-misc/netctl/netctl-1.1-r1.ebuild46
-rw-r--r--net-misc/netctl/netctl-9999.ebuild10
3 files changed, 61 insertions, 3 deletions
diff --git a/net-misc/netctl/ChangeLog b/net-misc/netctl/ChangeLog
index 4e0e9e1b5c43..b0e1e4a5f54a 100644
--- a/net-misc/netctl/ChangeLog
+++ b/net-misc/netctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/netctl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.5 2013/05/25 19:07:31 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.6 2013/06/08 17:08:17 floppym Exp $
+
+*netctl-1.1-r1 (08 Jun 2013)
+
+ 08 Jun 2013; Mike Gilbert <floppym@gentoo.org> +netctl-1.1-r1.ebuild,
+ netctl-9999.ebuild:
+ Fix path to ifplugd, bug 472682 by Alexander Tsoy.
*netctl-1.1 (25 May 2013)
diff --git a/net-misc/netctl/netctl-1.1-r1.ebuild b/net-misc/netctl/netctl-1.1-r1.ebuild
new file mode 100644
index 000000000000..aca207c476f1
--- /dev/null
+++ b/net-misc/netctl/netctl-1.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-1.1-r1.ebuild,v 1.1 2013/06/08 17:08:17 floppym Exp $
+
+EAPI=5
+
+inherit bash-completion-r1
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
+ inherit git-2
+ DEPEND="app-text/asciidoc"
+else
+ SRC_URI="ftp://ftp.archlinux.org/other/packages/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Profile based network connection tool from Arch Linux"
+HOMEPAGE="https://www.archlinux.org/netctl/"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=app-shells/bash-4.0
+ >=net-dns/openresolv-3.5.4-r1
+ sys-apps/iproute2
+ sys-apps/systemd
+"
+
+src_prepare() {
+ sed -i -e "s:/usr/bin/ifplugd:/usr/sbin/ifplugd:" \
+ "services/netctl-ifplugd@.service" || die
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" SHELL=bash install
+ dodoc AUTHORS NEWS README
+ newbashcomp contrib/bash-completion netctl
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _netctl
+}
diff --git a/net-misc/netctl/netctl-9999.ebuild b/net-misc/netctl/netctl-9999.ebuild
index bc830d5ab311..34c0f55b36f0 100644
--- a/net-misc/netctl/netctl-9999.ebuild
+++ b/net-misc/netctl/netctl-9999.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-9999.ebuild,v 1.4 2013/05/25 19:07:31 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-9999.ebuild,v 1.5 2013/06/08 17:08:17 floppym Exp $
EAPI=5
-inherit bash-completion-r1 eutils
+inherit bash-completion-r1
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
inherit git-2
+ DEPEND="app-text/asciidoc"
else
SRC_URI="ftp://ftp.archlinux.org/other/packages/${PN}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
@@ -27,6 +28,11 @@ RDEPEND="
sys-apps/systemd
"
+src_prepare() {
+ sed -i -e "s:/usr/bin/ifplugd:/usr/sbin/ifplugd:" \
+ "services/netctl-ifplugd@.service" || die
+}
+
src_compile() {
return 0
}