summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-05 11:30:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-05 11:30:20 +0000
commitcf5df2822c56a602a6f966911520e9a8470d3a17 (patch)
treee631c7a0fa30e2b0a801027e7adb2ba13c664ee0 /net-misc/mico
parentFix a typing error (diff)
downloadgentoo-2-cf5df2822c56a602a6f966911520e9a8470d3a17.tar.gz
gentoo-2-cf5df2822c56a602a6f966911520e9a8470d3a17.tar.bz2
gentoo-2-cf5df2822c56a602a6f966911520e9a8470d3a17.zip
Remove old, this should have never been revbumped for a simple compile-time fix.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/mico')
-rw-r--r--net-misc/mico/Manifest1
-rw-r--r--net-misc/mico/mico-2.3.13.ebuild104
2 files changed, 0 insertions, 105 deletions
diff --git a/net-misc/mico/Manifest b/net-misc/mico/Manifest
index d670fac754e2..66999c090d54 100644
--- a/net-misc/mico/Manifest
+++ b/net-misc/mico/Manifest
@@ -8,6 +8,5 @@ AUX mico-2.3.13-pthread.patch 1317 RMD160 1ef269452add11a18e5c313c126029afb1a110
AUX mico-2.3.13-winnt.patch.bz2 7453 RMD160 6e89f88ab2fe7e13718e756e993d4aa1dfa73a50 SHA1 340d5a5ee2618e9bda9781e5112c2bf5463f0efe SHA256 5769f5deacbf8d7f29510cc719f895aaba7c21ef43c4ef6942ba7d8387b95ae5
DIST mico-2.3.13.tar.gz 3269814 RMD160 70c8b9e68deac853ed2a28f48cd719bdef4e60fb SHA1 ee0138deb4d9ad0a50fe18e0b2add99fb5831c93 SHA256 a355fd0205440f0c8793b68d105b179942d883babc6b1fe69113707b88fe1d69
EBUILD mico-2.3.13-r1.ebuild 3795 RMD160 9b7c5847023203cee74d6e8d08761c57685c410f SHA1 c351830badfaaf20526e9459c548fcfbd20c9dcd SHA256 5ba1bf320e5dc44c615d7938ee6790e41c39bc0a93308cfd70dd2d187b987c62
-EBUILD mico-2.3.13.ebuild 3245 RMD160 dc65e4844d9e63567c41cfc6e20723ca3955128d SHA1 2413ebcfb0f3b4cc44fc88a4e4261be2c07cbd87 SHA256 52455bf40f7c5487bd6c9779c9c98815ce5b8a7e7e8e6b5c1c1f9fdcdcaf33e5
MISC ChangeLog 1795 RMD160 e85ff2e9d04f99143f08c39226c532c4460db7e8 SHA1 bd672bef14f48dd4049b3b7762d58f6c27b922ea SHA256 0aaac845a8f78825b2ee37febbf3e1b7922a07160b1ba650aacb123bb02a010b
MISC metadata.xml 640 RMD160 7c861b35cb15bad094830b9e83d0077fb7177a4b SHA1 5426b40b5f7a464c4a4577bef86ab0fcd1be117f SHA256 1f8be72dd1c133d7a282c5e5564466680dff87ed0c5daf688b6dca00327d9f85
diff --git a/net-misc/mico/mico-2.3.13.ebuild b/net-misc/mico/mico-2.3.13.ebuild
deleted file mode 100644
index 22f8f244967e..000000000000
--- a/net-misc/mico/mico-2.3.13.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.13.ebuild,v 1.5 2009/07/07 08:00:06 haubi Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="A freely available and fully compliant implementation of the CORBA standard"
-HOMEPAGE="http://www.mico.org/"
-SRC_URI="http://www.mico.org/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="gtk postgres qt3 ssl tcl threads X"
-
-# doesn't compile:
-# bluetooth? ( net-wireless/bluez-libs )
-
-RDEPEND="
- gtk? ( >=x11-libs/gtk+-2 )
- postgres? ( dev-db/postgresql )
- qt3? ( =x11-libs/qt-3* )
- ssl? ( dev-libs/openssl )
- tcl? ( dev-lang/tcl )
- X? ( x11-libs/libXt )
-"
-DEPEND="${RDEPEND}
- >=sys-devel/flex-2.5.2
- >=sys-devel/bison-1.22
-"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd "${S}" || die "failed to cd to '${S}'"
-
- epatch "${FILESDIR}"/${P}-nolibcheck.patch
- epatch "${FILESDIR}"/${P}-gcc43.patch
- epatch "${FILESDIR}"/${P}-pthread.patch
- epatch "${FILESDIR}"/${P}-aix.patch
- epatch "${FILESDIR}"/${P}-hpux.patch
-
- # cannot use big TOC (AIX only), gdb doesn't like it.
- # This assumes that the compiler (or -wrapper) uses
- # gcc flag '-mminimal-toc' for compilation.
- sed -i -e 's/,-bbigtoc//' "${S}"/configure
-}
-
-src_compile() {
- tc-export CC CXX
-
- if use gtk; then
- # set up gtk-1 wrapper for gtk-2
- mkdir "${T}"/path || die "failed to create temporary path"
- cp "${FILESDIR}"/gtk-config "${T}"/path || die "failed to dupe gtk-config"
- chmod +x "${T}"/path/gtk-config || die "failed to arm gtk-config"
- export PATH="${T}"/path:${PATH}
- fi
-
- # Don't know which version of JavaCUP would suffice, but there is no
- # configure argument to disable checking for JavaCUP.
- # So we override the configure check to not find 'javac'.
- export ac_cv_path_JAVAC=no
-
- # '--without-ssl' just does not add another search path - the only way
- # to disable openssl utilization seems to override the configure check.
- use ssl || export ac_cv_lib_ssl_open=no
-
- # '--without-*' or '--with-*=no' does not disable some features, the value
- # needs to be empty instead. This applies to: bluetooth, gtk, pgsql, qt, tcl.
- # But --without-x works.
-
- # moc is searched within PATH, not within QTDIR.
- use qt3 && export MOC="${QTDIR}"/bin/moc
-
- # http://www.mico.org/pipermail/mico-devel/2009-April/010285.html
- [[ ${CHOST} == *-hpux* ]] && append-cppflags -D_XOPEN_SOURCE_EXTENDED
-
- # bluetooth and wireless both don't compile cleanly
- econf \
- --disable-mini-stl \
- $(use_enable threads) \
- --with-gtk=$(use gtk && echo /usr) \
- --with-pgsql=$(use postgres && echo /usr) \
- --with-qt=$(use qt3 && echo "${QTDIR}") \
- --with-tcl=$(use tcl && echo /usr) \
- $(use_with X x /usr) \
- --with-bluetooth='' \
- --disable-wireless
-
- emake || die "make failed"
-}
-
-src_install() {
- emake INSTDIR="${D}"/usr SHARED_INSTDIR="${D}"/usr install LDCONFIG=: || die "install failed"
-
- dodir /usr/share || die
- mv "${D}"/usr/man "${D}"/usr/share || die
- dodir /usr/share/doc/${PF} || die
- mv "${D}"/usr/doc "${D}"/usr/share/doc/${PF} || die
-
- dodoc BUGS CHANGES* CONVERT FAQ README* ROADMAP TODO VERSION WTODO || die
-}