summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2012-08-17 11:54:58 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2012-08-17 11:54:58 +0000
commit6a7c61611d154bb6e71f29e9a09cc395c0932b9e (patch)
treece13fa66396f4412cbad167566d0b8ae4c61fd53 /net-misc/logmein-hamachi
parentRemove the frami suffix from dict files to solve bug#430468. (diff)
downloadgentoo-2-6a7c61611d154bb6e71f29e9a09cc395c0932b9e.tar.gz
gentoo-2-6a7c61611d154bb6e71f29e9a09cc395c0932b9e.tar.bz2
gentoo-2-6a7c61611d154bb6e71f29e9a09cc395c0932b9e.zip
Fixes bug 430234. Per Simone Scanzoni.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/logmein-hamachi')
-rw-r--r--net-misc/logmein-hamachi/ChangeLog8
-rw-r--r--net-misc/logmein-hamachi/logmein-hamachi-2.1.0.68-r1.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/net-misc/logmein-hamachi/ChangeLog b/net-misc/logmein-hamachi/ChangeLog
index 31ec022f2ece..17d4a9f6a2b8 100644
--- a/net-misc/logmein-hamachi/ChangeLog
+++ b/net-misc/logmein-hamachi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/logmein-hamachi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/ChangeLog,v 1.5 2012/06/29 08:06:49 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/ChangeLog,v 1.6 2012/08/17 11:54:58 titanofold Exp $
+
+*logmein-hamachi-2.1.0.68-r1 (17 Aug 2012)
+
+ 17 Aug 2012; Aaron W. Swenson <titanofold@gentoo.org>
+ +logmein-hamachi-2.1.0.68-r1.ebuild:
+ Fixes bug 430234. Per Simone Scanzoni.
*logmein-hamachi-2.1.0.68 (29 Jun 2012)
diff --git a/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.68-r1.ebuild b/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.68-r1.ebuild
new file mode 100644
index 000000000000..364e95d590fb
--- /dev/null
+++ b/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.68-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.68-r1.ebuild,v 1.1 2012/08/17 11:54:58 titanofold Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="LogMeIn Hamachi VPN tunneling engine"
+HOMEPAGE="https://secure.logmein.com/products/hamachi2"
+SRC_URI="x86? ( https://secure.logmein.com/labs/${P}-x86.tgz )
+ amd64? ( https://secure.logmein.com/labs/${P}-x64.tgz )"
+
+LICENSE="LogMeIn"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!net-misc/hamachi"
+
+RESTRICT="mirror"
+
+QA_PREBUILT="/opt/${PN}/bin/hamachid"
+QA_PRESTRIPPED="/opt/${PN}/bin/hamachid"
+
+pkg_setup() {
+ einfo "Checking your kernel configuration for TUN/TAP support."
+ CONFIG_CHECK="~TUN"
+ check_extra_config
+}
+
+src_unpack() {
+ unpack ${A}
+ mv ${P}-$(use x86 && echo x86 || echo x64) "${S}" || die
+}
+
+src_install() {
+ into /opt/${PN}
+ dobin hamachid dnsup dnsdown || die
+ dosym /opt/${PN}/bin/hamachid /usr/bin/hamachi || die "Couldn't create hamachi symlink"
+
+ dodir /var/run/${PN} || die
+
+ # Config and log directory
+ dodir /var/lib/${PN} || die
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+
+ dodoc CHANGES README || die
+}
+
+pkg_postinst() {
+ elog "LogMeIn Hamachi2 is installed."
+ elog "Consult the README file on how to configure your client."
+ elog "You can run the client 'hamachi' as root,"
+ elog "or as a user if you add a line:"
+ elog "Ipc.User <login name>"
+ elog "to the file '/var/lib/${PN}/h2-engine-override.cfg'"
+ elog "and restart the daemon with"
+ elog "/etc/init.d/${PN} restart"
+ elog "To enable auto-login when the service starts set a nickname in"
+ elog "/etc/conf.d/${PN}"
+}