summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-02-02 13:36:13 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-02-02 13:36:13 +0000
commit9cf78042d60aacd0f19139578cedc81e9b27fe22 (patch)
treeef580f0dd15d938685b717199eb50b7701bc0509 /net-misc/linphone
parentStable on sparc wrt #164922 (diff)
downloadgentoo-2-9cf78042d60aacd0f19139578cedc81e9b27fe22.tar.gz
gentoo-2-9cf78042d60aacd0f19139578cedc81e9b27fe22.tar.bz2
gentoo-2-9cf78042d60aacd0f19139578cedc81e9b27fe22.zip
Revbump: Add patch to avoid linphonec "call" to crash.
Patch already sent upstream. (Portage version: 2.1.2-r5)
Diffstat (limited to 'net-misc/linphone')
-rw-r--r--net-misc/linphone/ChangeLog9
-rw-r--r--net-misc/linphone/files/digest-linphone-1.6.0-r13
-rw-r--r--net-misc/linphone/files/linphone-1.6.0-call.patch10
-rw-r--r--net-misc/linphone/linphone-1.6.0-r1.ebuild79
4 files changed, 100 insertions, 1 deletions
diff --git a/net-misc/linphone/ChangeLog b/net-misc/linphone/ChangeLog
index 5f2ed806e4f6..96b97231a8fa 100644
--- a/net-misc/linphone/ChangeLog
+++ b/net-misc/linphone/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/linphone
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/linphone/ChangeLog,v 1.21 2007/01/30 15:12:44 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/linphone/ChangeLog,v 1.22 2007/02/02 13:36:13 drizzt Exp $
+
+*linphone-1.6.0-r1 (02 Feb 2007)
+
+ 02 Feb 2007; Timothy Redaelli <drizzt@gentoo.org>
+ +files/linphone-1.6.0-call.patch, +linphone-1.6.0-r1.ebuild:
+ Revbump: Add patch to avoid linphonec "call" to crash.
+ Patch already sent upstream.
*linphone-1.6.0 (30 Jan 2007)
diff --git a/net-misc/linphone/files/digest-linphone-1.6.0-r1 b/net-misc/linphone/files/digest-linphone-1.6.0-r1
new file mode 100644
index 000000000000..dac887590160
--- /dev/null
+++ b/net-misc/linphone/files/digest-linphone-1.6.0-r1
@@ -0,0 +1,3 @@
+MD5 fb345125e23c787df0818ff7caad5515 linphone-1.6.0.tar.gz 7720841
+RMD160 52a98387177da018c35b38fcb24e3f126b8dfb2e linphone-1.6.0.tar.gz 7720841
+SHA256 ba1c32207fd62d374c9397a81fb1247da93edb859e30d0d855dc65e5457f690b linphone-1.6.0.tar.gz 7720841
diff --git a/net-misc/linphone/files/linphone-1.6.0-call.patch b/net-misc/linphone/files/linphone-1.6.0-call.patch
new file mode 100644
index 000000000000..27fe669f8c1c
--- /dev/null
+++ b/net-misc/linphone/files/linphone-1.6.0-call.patch
@@ -0,0 +1,10 @@
+--- linphone-1.6.0.old/console/commands.c 2007-02-02 13:57:55.000000000 +0100
++++ linphone-1.6.0/console/commands.c 2007-02-02 14:25:51.000000000 +0100
+@@ -287,6 +287,7 @@
+ static int
+ lpc_cmd_call(LinphoneCore *lc, char *args)
+ {
++ if ( ! args || ! *args ) return 0;
+ if ( lc->call != NULL )
+ {
+ printf("Terminate current call first.\n");
diff --git a/net-misc/linphone/linphone-1.6.0-r1.ebuild b/net-misc/linphone/linphone-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..c980236ca51d
--- /dev/null
+++ b/net-misc/linphone/linphone-1.6.0-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/linphone/linphone-1.6.0-r1.ebuild,v 1.1 2007/02/02 13:36:13 drizzt Exp $
+
+MY_DPV="${PV%.*}.x"
+
+WANT_AUTOCONF="2.5"
+WANT_AUTOMAKE="1.9"
+
+inherit eutils autotools
+
+DESCRIPTION="Linphone is a SIP phone with a GNOME interface."
+HOMEPAGE="http://www.linphone.org"
+SRC_URI="http://download.savannah.nongnu.org/releases/${PN}/${MY_DPV}/sources/${P}.tar.gz"
+SLOT=1
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="alsa gnome ilbc ipv6 novideo xv"
+
+RDEPEND="dev-libs/glib
+ dev-perl/XML-Parser
+ net-dns/bind-tools
+ >=net-libs/libosip-2.2.0
+ >=media-libs/speex-1.1.6
+ x86? ( xv? ( dev-lang/nasm ) )
+ gnome? ( >=gnome-base/gnome-panel-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=x11-libs/gtk+-2 )
+ alsa? ( media-libs/alsa-lib )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ !novideo? ( >=media-libs/libsdl-1.2.9
+ media-video/ffmpeg
+ >=media-libs/libtheora-1.0_alpha7 )"
+# portaudio? ( >=media-libs/portaudio-19_pre )"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch
+ epatch "${FILESDIR}"/${P}-call.patch
+ ./autogen.sh
+}
+
+src_compile() {
+ local withgnome myconf=""
+
+ use gnome && withgnome="yes" || withgnome="no"
+ use x86 && myconf="--enable-truespeech"
+
+ econf \
+ --libdir=/usr/$(get_libdir)/linphone \
+ --enable-gnome_ui=${withgnome} \
+ $(use_with ilbc) \
+ $(use_enable ipv6) \
+ $(use_enable alsa) \
+ $(use_enable !novideo video) \
+ --disable-portaudio \
+ ${myconf} || die "Unable to configure"
+
+ emake || die "Unable to make"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "Failed to install"
+
+ dodoc ABOUT-NLS AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README
+ dodoc README.arm TODO
+
+ # don't install ortp includes, docs and pkgconfig files
+ # to avoid conflicts with net-libs/ortp
+ rm -rf "${D}"/usr/include/ortp
+ rm -rf "${D}"/usr/share/gtk-doc/html/ortp
+ rm -rf "${D}"/usr/$(get_libdir)/linphone/pkgconfig
+}