summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-16 09:58:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-16 09:58:13 +0000
commit566784fb2f0598bccbc9a81fdbcb5f58011d13c8 (patch)
treeb273e5513f1e2ef22af617472ca74320aa017115 /net-misc/ipv6calc/ipv6calc-0.93.1.ebuild
parentUse patches array rather than prepare phase. (diff)
downloadgentoo-2-566784fb2f0598bccbc9a81fdbcb5f58011d13c8.tar.gz
gentoo-2-566784fb2f0598bccbc9a81fdbcb5f58011d13c8.tar.bz2
gentoo-2-566784fb2f0598bccbc9a81fdbcb5f58011d13c8.zip
Bump
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/ipv6calc/ipv6calc-0.93.1.ebuild')
-rw-r--r--net-misc/ipv6calc/ipv6calc-0.93.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/ipv6calc/ipv6calc-0.93.1.ebuild b/net-misc/ipv6calc/ipv6calc-0.93.1.ebuild
new file mode 100644
index 000000000000..abc64bec4d26
--- /dev/null
+++ b/net-misc/ipv6calc/ipv6calc-0.93.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.93.1.ebuild,v 1.1 2012/03/16 09:58:13 patrick Exp $
+
+EAPI="4"
+inherit fixheadtails
+
+DESCRIPTION="IPv6 address calculator"
+HOMEPAGE="http://www.deepspace6.net/projects/ipv6calc.html"
+SRC_URI="ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="geoip"
+
+DEPEND="geoip? ( >=dev-libs/geoip-1.4.7 )"
+
+src_prepare() {
+ # Tests don't work, will be fixed next release
+ echo true > ipv6calc/test_showinfo.sh || die
+ ht_fix_file configure
+}
+
+src_configure() {
+ econf $(use_enable geoip)
+}
+
+src_compile() {
+ # Disable default CFLAGS (-O2 and -g)
+ emake DEFAULT_CFLAGS=""
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]]; then
+ # Disable tests that fail as root
+ echo true > ipv6logstats/test_ipv6logstats.sh
+ fi
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog CREDITS README TODO USAGE
+}