summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-07-18 16:33:50 +0000
committerJeroen Roovers <jer@gentoo.org>2014-07-18 16:33:50 +0000
commit91f4c11ae6348f17b5af6f0c54eb9156f8ee87ff (patch)
tree69754a3d935460e4258974bc2a479ccc491c3549 /net-misc/iperf
parentinstall editors document to point people to the go wiki page about editor and... (diff)
downloadgentoo-2-91f4c11ae6348f17b5af6f0c54eb9156f8ee87ff.tar.gz
gentoo-2-91f4c11ae6348f17b5af6f0c54eb9156f8ee87ff.tar.bz2
gentoo-2-91f4c11ae6348f17b5af6f0c54eb9156f8ee87ff.zip
Version bump (bug #466508 by Bryan Duff).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-misc/iperf')
-rw-r--r--net-misc/iperf/ChangeLog7
-rw-r--r--net-misc/iperf/iperf-3.0.5.ebuild23
2 files changed, 29 insertions, 1 deletions
diff --git a/net-misc/iperf/ChangeLog b/net-misc/iperf/ChangeLog
index bca379fd4234..ae5bc5e56018 100644
--- a/net-misc/iperf/ChangeLog
+++ b/net-misc/iperf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/iperf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/ChangeLog,v 1.45 2014/07/18 16:15:59 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/ChangeLog,v 1.46 2014/07/18 16:33:50 jer Exp $
+
+*iperf-3.0.5 (18 Jul 2014)
+
+ 18 Jul 2014; Jeroen Roovers <jer@gentoo.org> +iperf-3.0.5.ebuild:
+ Version bump (bug #466508 by Bryan Duff).
18 Jul 2014; Jeroen Roovers <jer@gentoo.org> iperf-2.0.5-r2.ebuild,
files/iperf-bidirectional-tcp-server.patch,
diff --git a/net-misc/iperf/iperf-3.0.5.ebuild b/net-misc/iperf/iperf-3.0.5.ebuild
new file mode 100644
index 000000000000..b397be8e3a67
--- /dev/null
+++ b/net-misc/iperf/iperf-3.0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/iperf-3.0.5.ebuild,v 1.1 2014/07/18 16:33:50 jer Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
+LICENSE="BSD"
+SLOT="0"
+HOMEPAGE="https://github.com/esnet/iperf/"
+SRC_URI="https://codeload.github.com/esnet/${PN}/tar.gz/${PV} -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
+IUSE="static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}