summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-01-02 10:23:06 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-01-02 10:23:06 +0000
commit1f682d72fe667631594f1c6595d86317f09a171d (patch)
tree7018855ca65eee231f59c159d21133a58bf1ebf7 /net-misc/ices
parentCreate stable candidate. (diff)
downloadgentoo-2-1f682d72fe667631594f1c6595d86317f09a171d.tar.gz
gentoo-2-1f682d72fe667631594f1c6595d86317f09a171d.tar.bz2
gentoo-2-1f682d72fe667631594f1c6595d86317f09a171d.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-misc/ices')
-rw-r--r--net-misc/ices/ChangeLog10
-rw-r--r--net-misc/ices/files/ices.initd-r114
-rw-r--r--net-misc/ices/ices-2.0.2.ebuild43
3 files changed, 65 insertions, 2 deletions
diff --git a/net-misc/ices/ChangeLog b/net-misc/ices/ChangeLog
index 22b5a076ffc3..6cdc1c05460f 100644
--- a/net-misc/ices/ChangeLog
+++ b/net-misc/ices/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/ices
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ices/ChangeLog,v 1.29 2014/08/10 20:44:30 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ices/ChangeLog,v 1.30 2015/01/02 10:23:06 polynomial-c Exp $
+
+*ices-2.0.2 (02 Jan 2015)
+
+ 02 Jan 2015; Lars Wendler <polynomial-c@gentoo.org> +ices-2.0.2.ebuild,
+ +files/ices.initd-r1:
+ Version bump.
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> ices-2.0.1-r1.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/net-misc/ices/files/ices.initd-r1 b/net-misc/ices/files/ices.initd-r1
new file mode 100644
index 000000000000..a3cef6f09c8a
--- /dev/null
+++ b/net-misc/ices/files/ices.initd-r1
@@ -0,0 +1,14 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ices/files/ices.initd-r1,v 1.1 2015/01/02 10:23:06 polynomial-c Exp $
+
+description="Icecast OGG streaming client"
+pidfile="/var/run/ices.pid"
+command="/usr/bin/ices"
+command_args="/etc/ices2/ices.xml"
+command_background="true"
+
+depend() {
+ need net
+}
diff --git a/net-misc/ices/ices-2.0.2.ebuild b/net-misc/ices/ices-2.0.2.ebuild
new file mode 100644
index 000000000000..ec35f821e7b4
--- /dev/null
+++ b/net-misc/ices/ices-2.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ices/ices-2.0.2.ebuild,v 1.1 2015/01/02 10:23:06 polynomial-c Exp $
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="Icecast OGG streaming client, supports on the fly re-encoding"
+HOMEPAGE="http://www.icecast.org/ices.php"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2
+ >=media-libs/libshout-2
+ >=media-libs/libvorbis-1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ enewgroup ices
+ enewuser ices -1 -1 -1 ices
+}
+
+src_configure() {
+ econf --sysconfdir=/etc/ices2
+}
+
+src_install() {
+ default
+ insinto /etc/ices2
+ doins conf/*.xml
+ dohtml doc/*.{html,css}
+ newinitd "${FILESDIR}"/ices.initd-r1 ices
+ keepdir /var/log/ices
+ fperms 660 /var/log/ices
+ fowners ices:ices /var/log/ices
+ rm -rf "${D}"/usr/share/ices
+}