summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-05-01 06:03:48 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-05-01 06:03:48 +0000
commitea01e70ee9607bd328aec0c44cd00b0ae8025916 (patch)
tree5ff9d1c00a0093a6d5cf6c2c5920ffe31b69c7a3 /net-misc/gyach/gyach-0.7.6.ebuild
parentNew package (diff)
downloadgentoo-2-ea01e70ee9607bd328aec0c44cd00b0ae8025916.tar.gz
gentoo-2-ea01e70ee9607bd328aec0c44cd00b0ae8025916.tar.bz2
gentoo-2-ea01e70ee9607bd328aec0c44cd00b0ae8025916.zip
Version bump to latest
Diffstat (limited to 'net-misc/gyach/gyach-0.7.6.ebuild')
-rw-r--r--net-misc/gyach/gyach-0.7.6.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/gyach/gyach-0.7.6.ebuild b/net-misc/gyach/gyach-0.7.6.ebuild
new file mode 100644
index 000000000000..ba745601a7d1
--- /dev/null
+++ b/net-misc/gyach/gyach-0.7.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Matthew Kennedy <mbkennedy@ieee.com>
+# Maintainer: Matthew Kennedy <mkennedy@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gyach/gyach-0.7.6.ebuild,v 1.1 2002/05/01 06:03:48 mkennedy Exp $
+
+LICENSE="GPL-2"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+-based Yahoo! chat client"
+SRC_URI="http://www4.infi.net/~cpinkham/gyach/code/${P}.tar.gz"
+HOMEPAGE="http://www4.infi.net/~cpinkham/gyach/"
+
+DEPEND="virtual/glibc
+ >=x11-libs/gtk+-1.2.0"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README* TODO
+ dodoc sample.*
+
+ # install icon and desktop entry for gnome
+ if [ "`use gnome`" ] ; then
+ insinto /usr/share/pixmaps
+ doins ${D}/usr/share/gyach/pixmaps/gyach-icon.xpm
+ insinto /usr/share/gnome/apps/Internet
+ doins ${FILESDIR}/gyach.desktop
+ fi
+
+}