summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-07 05:55:44 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-07 05:55:44 +0000
commit317c85a7f7e034818852182d971a0b3d963eecbb (patch)
treeb2e6cb7ff525688cec2fbd2244a3b1283a424d7d /net-misc/dhcpcd
parentRemove pointless USE=build support. (diff)
downloadgentoo-2-317c85a7f7e034818852182d971a0b3d963eecbb.tar.gz
gentoo-2-317c85a7f7e034818852182d971a0b3d963eecbb.tar.bz2
gentoo-2-317c85a7f7e034818852182d971a0b3d963eecbb.zip
old
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/dhcpcd-2.0.5-r1.ebuild62
-rw-r--r--net-misc/dhcpcd/dhcpcd-3.2.2.ebuild87
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.0_rc5.ebuild86
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.1.ebuild86
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-2.0.0-alwaysup.patch11
5 files changed, 0 insertions, 332 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-2.0.5-r1.ebuild b/net-misc/dhcpcd/dhcpcd-2.0.5-r1.ebuild
deleted file mode 100644
index 8cec11f8d9c8..000000000000
--- a/net-misc/dhcpcd/dhcpcd-2.0.5-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-2.0.5-r1.ebuild,v 1.5 2008/05/06 14:36:04 drac Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A DHCP client only"
-HOMEPAGE="http://developer.berlios.de/projects/dhcpcd/"
-SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="build debug static"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-pkg_setup() {
- if use debug ; then
- ewarn "WARNING: dhcpcd will provide good debugging output with the"
- ewarn "debug USE flag enabled but will not actually configure the"
- ewarn "interface or setup /etc/resolv.conf"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Never take the interface down
- epatch "${FILESDIR}/${PN}-2.0.0-alwaysup.patch"
-
- # Redefine the location of ntp.drift
- sed -i 's:/etc/ntp\.drift:/var/lib/ntp/ntp.drift:' src/dhcpconfig.c
-}
-
-src_compile() {
- local myconf="$(use_enable debug)"
- use static && append-flags -static
-
- econf ${myconf} || die
- emake || die
-}
-
-src_install() {
- into /
- dosbin src/dhcpcd || die
-
- if ! use build ; then
- dodoc AUTHORS ChangeLog NEWS README
- doman src/dhcpcd.8
- fi
-}
-
-pkg_postinst() {
- if use kernel_linux ; then
- ewarn
- ewarn "${PN} requires kernel support for Packet Socket (CONFIG_PACKET)."
- ewarn
- fi
-}
diff --git a/net-misc/dhcpcd/dhcpcd-3.2.2.ebuild b/net-misc/dhcpcd/dhcpcd-3.2.2.ebuild
deleted file mode 100644
index 50d4fcf46980..000000000000
--- a/net-misc/dhcpcd/dhcpcd-3.2.2.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-3.2.2.ebuild,v 1.1 2008/02/20 20:48:51 welp Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="A DHCP client"
-HOMEPAGE="http://roy.marples.name/dhcpcd"
-SRC_URI="http://roy.marples.name/${PN}/${P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="vram zeroconf"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if use zeroconf; then
- elog "ZeroConf support enabled"
- else
- elog "Disabling zeroconf support"
- {
- echo
- echo "/* User indicated no zeroconf support */"
- echo "#undef ENABLE_IPV4LL"
- } >> config.h
- fi
-
- # Disable DUID support if we have volatile storage.
- # LiveCD's *should* enable this USE flag
- if use vram; then
- elog "Disabling DUID support"
- {
- echo
- echo "/* User indicated volatile ram storage */"
- echo "#undef ENABLE_DUID"
- } >> config.h
- else
- elog "DUID support enabled"
- fi
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" INFODIR=/var/lib/dhcpcd || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- if [ -e "${duid}" ] && ! grep -q '..:..:..:..:..:..' "${duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
-
- if ! use vram; then
- use zeroconf && echo
- elog "You have installed dhcpcd with DUID support."
- elog "This means that we will generate a DUID in /var/lib/dhcpcd/dhcpcd.duid"
- elog "This is generated from a MAC address of the card and a timestamp."
- elog "It will be used in every subsequent DHCP transaction, along with a IAID"
- elog "in the ClientID option. This is required by RFC 4361."
- echo
- elog "Some DHCP server implementations require a MAC address only in the"
- elog "ClientID field. These DHCP servers should be updated to be RFC"
- elog "conformant. If you cannot do this, you can revert to the old"
- elog "behaviour by using the -I '' option OR building dhcpcd with the"
- elog "vram USE flag enabled."
- fi
-}
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.0_rc5.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.0_rc5.ebuild
deleted file mode 100644
index f71bdaa43c1b..000000000000
--- a/net-misc/dhcpcd/dhcpcd-4.0.0_rc5.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.0_rc5.ebuild,v 1.1 2008/08/15 19:47:55 armin76 Exp $
-
-EAPI=1
-
-inherit toolchain-funcs
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A DHCP client"
-HOMEPAGE="http://roy.marples.name/dhcpcd"
-SRC_URI="http://roy.marples.name/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="+compat zeroconf"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-
- if use compat; then
- elog "dhcpcd-3 command line support enabled"
- {
- echo
- echo "/* User indicated command line compatability */"
- echo "#define CMDLINE_COMPAT"
- } >> config.h
- fi
-}
-
-pkg_setup() {
- MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
-}
-
-src_compile() {
- [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
- emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
-}
-
-src_install() {
- local hooks="50-ntp.conf"
- use elibc_glibc && hooks="${hooks} 50-yp.conf"
- emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
-}
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.1.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.1.ebuild
deleted file mode 100644
index 67a15b6eb6d7..000000000000
--- a/net-misc/dhcpcd/dhcpcd-4.0.1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.1.ebuild,v 1.1 2008/08/25 10:17:39 remi Exp $
-
-EAPI=1
-
-inherit toolchain-funcs
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A DHCP client"
-HOMEPAGE="http://roy.marples.name/dhcpcd"
-SRC_URI="http://roy.marples.name/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="+compat zeroconf"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-
- if use compat; then
- elog "dhcpcd-3 command line support enabled"
- {
- echo
- echo "/* User indicated command line compatability */"
- echo "#define CMDLINE_COMPAT"
- } >> config.h
- fi
-}
-
-pkg_setup() {
- MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
-}
-
-src_compile() {
- [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
- emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
-}
-
-src_install() {
- local hooks="50-ntp.conf"
- use elibc_glibc && hooks="${hooks} 50-yp.conf"
- emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
-}
diff --git a/net-misc/dhcpcd/files/dhcpcd-2.0.0-alwaysup.patch b/net-misc/dhcpcd/files/dhcpcd-2.0.0-alwaysup.patch
deleted file mode 100644
index 71356383bdbf..000000000000
--- a/net-misc/dhcpcd/files/dhcpcd-2.0.0-alwaysup.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/dhcpcd.c (revision 69)
-+++ src/dhcpcd.c (working copy)
-@@ -75,7 +75,7 @@
- char *ConfigDir = CONFIG_DIR;
- int SetDHCPDefaultRoutes= 1;
- int Persistent = 0;
--int DownIfaceOnStop = 1;
-+int DownIfaceOnStop = 0;
-
- #if 0
- unsigned char ClientMACaddr[ETH_ALEN];