summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-02-14 18:58:48 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-02-14 18:58:48 +0000
commitc8cad20e9588020001401bb85018e3623314e021 (patch)
tree195718981297944814d9571243ca90b7b2c7536d /net-misc/dhcp
parentFixed typos. (diff)
downloadgentoo-2-c8cad20e9588020001401bb85018e3623314e021.tar.gz
gentoo-2-c8cad20e9588020001401bb85018e3623314e021.tar.bz2
gentoo-2-c8cad20e9588020001401bb85018e3623314e021.zip
new dhcp release.
Diffstat (limited to 'net-misc/dhcp')
-rw-r--r--net-misc/dhcp/ChangeLog6
-rw-r--r--net-misc/dhcp/dhcp-3.0.ebuild76
-rw-r--r--net-misc/dhcp/dhcp-3.0_rc12-r6.ebuild89
-rw-r--r--net-misc/dhcp/dhcp-3.0_rc12.ebuild89
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.01
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0_rc121
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0_rc12-r61
7 files changed, 82 insertions, 181 deletions
diff --git a/net-misc/dhcp/ChangeLog b/net-misc/dhcp/ChangeLog
index 4e737899d71a..154f735e8003 100644
--- a/net-misc/dhcp/ChangeLog
+++ b/net-misc/dhcp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/dhcp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.1 2002/02/01 21:53:34 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.2 2002/02/14 18:58:47 drobbins Exp $
+
+*dhcp-3.0 (14 Feb 2002)
+
+ 14 Feb 2002; Daniel Robbins <drobbins@gentoo.org>: New 3.0 release.
*dhcp-3.0_rc12-r6 (1 Feb 2002)
diff --git a/net-misc/dhcp/dhcp-3.0.ebuild b/net-misc/dhcp/dhcp-3.0.ebuild
new file mode 100644
index 000000000000..fdfe8c7df9a0
--- /dev/null
+++ b/net-misc/dhcp/dhcp-3.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0.ebuild,v 1.1 2002/02/14 18:58:48 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="ISC Dynamic Host Configuration Protocol"
+SRC_URI="ftp://ftp.isc.org/isc/dhcp/${P}.tar.gz"
+HOMEPAGE="http://www.isc.org/products/DHCP"
+
+DEPEND="virtual/glibc sys-apps/groff"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/includes
+ cat <<- END >> site.h
+#define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
+#define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
+#define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
+ END
+}
+
+src_compile() {
+ cat <<- END > site.conf
+CC = gcc ${CFLAGS}
+ETC = /etc/dhcp
+VARDB = /var/lib/dhcp
+ADMMANDIR = /usr/share/man/man8
+FFMANDIR = /usr/share/man/man5
+LIBMANDIR = /usr/share/man/man3
+END
+ ./configure --with-nsupdate || die
+ emake || die
+}
+
+src_install() {
+ dodir /var/lib/dhcp
+
+ cd ${S}/work.linux-2.2/client
+ into / ; dosbin dhclient
+ into /usr ; doman *.5 *.8
+
+ cd ../dhcpctl ; dolib libdhcpctl.a ; doman *.3
+ insinto /usr/include ; doins dhcpctl.h
+
+ cd ../omapip ; dolib libomapi.a ; doman *.3
+ cd ../relay ; dosbin dhcrelay ; doman *.8
+ cd ../common ; doman *.5
+ cd ../server ; dosbin dhcpd ; doman *.5 *.8
+
+ cd ${S}/client
+ # admins might wanna edit dhclient-script, so /etc is proper for it.
+ dosed "s:/etc/dhclient-script:/etc/dhcp/dhclient-script:" dhclient.conf
+ insinto /etc/dhcp ; newins dhclient.conf dhclient.conf.sample
+ exeinto /etc/dhcp ; newexe scripts/linux dhclient-script.sample
+
+ cd ${S}/server
+ insinto /etc/dhcp ; newins dhcpd.conf dhcpd.conf.sample
+
+ cd ${S}/includes/omapip
+ insinto /usr/include/omapip ; doins alloc.h buffer.h omapip.h
+
+ cd ${S}/includes/isc-dhcp
+ insinto /usr/include/isc-dhcp
+ doins boolean.h dst.h int.h lang.h list.h result.h types.h
+
+ cd ${S}
+ dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES
+ newdoc client/dhclient.conf dhclient.conf.sample
+ newdoc client/scripts/linux dhclient-script.sample
+ newdoc server/dhcpd.conf dhcpd.conf.sample
+ docinto doc ; dodoc doc/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dhcp.rc6 dhcp
+}
diff --git a/net-misc/dhcp/dhcp-3.0_rc12-r6.ebuild b/net-misc/dhcp/dhcp-3.0_rc12-r6.ebuild
deleted file mode 100644
index 145e45fb1615..000000000000
--- a/net-misc/dhcp/dhcp-3.0_rc12-r6.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0_rc12-r6.ebuild,v 1.1 2001/09/09 09:09:08 woodchip Exp $
-
-P=dhcp-3.0rc12
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="ISC Dynamic Host Configuration Protocol"
-SRC_URI="ftp://ftp.isc.org/isc/dhcp/${A}"
-HOMEPAGE="http://www.isc.org/products/DHCP"
-
-DEPEND="virtual/glibc sys-apps/groff"
-RDEPEND="virtual/glibc"
-
-src_unpack() {
-
- unpack ${A}
- cd ${S}/includes
- cat <<- END >> site.h
- #define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
- #define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
- #define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
- END
-}
-
-src_compile() {
-
- cat <<- END > site.conf
- CC = gcc ${CFLAGS}
- ETC = /etc/dhcp
- VARDB = /var/lib/dhcp
- ADMMANDIR = /usr/share/man/man8
- FFMANDIR = /usr/share/man/man5
- LIBMANDIR = /usr/share/man/man3
- END
-
- ./configure --with-nsupdate || die
- make || die
-}
-
-src_install2() {
-
- # hmm is this misbehaving outside of the tempdir?
- try make DESTDIR=${D} install
-}
-
-src_install() {
-
- dodir /var/lib/dhcp
-
- cd ${S}/work.linux-2.2/client
- into / ; dosbin dhclient
- into /usr ; doman *.5 *.8
-
- cd ../dhcpctl ; dolib libdhcpctl.a ; doman *.3
- insinto /usr/include ; doins dhcpctl.h
-
- cd ../omapip ; dolib libomapi.a ; doman *.3
- cd ../relay ; dosbin dhcrelay ; doman *.8
- cd ../common ; doman *.5
- cd ../server ; dosbin dhcpd ; doman *.5 *.8
-
- cd ${S}/client
- # admins might wanna edit dhclient-script, so /etc is proper for it.
- dosed "s:/etc/dhclient-script:/etc/dhcp/dhclient-script:" dhclient.conf
- insinto /etc/dhcp ; newins dhclient.conf dhclient.conf.sample
- exeinto /etc/dhcp ; newexe scripts/linux dhclient-script.sample
-
- cd ${S}/server
- insinto /etc/dhcp ; newins dhcpd.conf dhcpd.conf.sample
-
- cd ${S}/includes/omapip
- insinto /usr/include/omapip ; doins alloc.h buffer.h omapip.h
-
- cd ${S}/includes/isc-dhcp
- insinto /usr/include/isc-dhcp
- doins boolean.h dst.h int.h lang.h list.h result.h types.h
-
- cd ${S}
- dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES
- newdoc client/dhclient.conf dhclient.conf.sample
- newdoc client/scripts/linux dhclient-script.sample
- newdoc server/dhcpd.conf dhcpd.conf.sample
- docinto doc ; dodoc doc/*
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/dhcp.rc6 dhcp
-}
diff --git a/net-misc/dhcp/dhcp-3.0_rc12.ebuild b/net-misc/dhcp/dhcp-3.0_rc12.ebuild
deleted file mode 100644
index 0d23a5b9f4d7..000000000000
--- a/net-misc/dhcp/dhcp-3.0_rc12.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0_rc12.ebuild,v 1.1 2001/09/09 09:09:08 woodchip Exp $
-
-P=dhcp-3.0rc12
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="ISC Dynamic Host Configuration Protocol"
-SRC_URI="ftp://ftp.isc.org/isc/dhcp/${A}"
-HOMEPAGE="http://www.isc.org/products/DHCP"
-
-DEPEND="virtual/glibc sys-apps/groff"
-RDEPEND="virtual/glibc"
-
-src_unpack() {
-
- unpack ${A}
- cd ${S}/includes
- cat <<- END >> site.h
- #define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
- #define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
- #define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
- END
-}
-
-src_compile() {
-
- cat <<- END > site.conf
- CC = gcc ${CFLAGS}
- ETC = /etc/dhcp
- VARDB = /var/lib/dhcp
- ADMMANDIR = /usr/share/man/man8
- FFMANDIR = /usr/share/man/man5
- LIBMANDIR = /usr/share/man/man3
- END
-
- ./configure --with-nsupdate || die
- make || die
-}
-
-src_install2() {
-
- # hmm is this misbehaving outside of the tempdir?
- try make DESTDIR=${D} install
-}
-
-src_install() {
-
- dodir /var/lib/dhcp
-
- cd ${S}/work.linux-2.2/client
- into / ; dosbin dhclient
- into /usr ; doman *.5 *.8
-
- cd ../dhcpctl ; dolib libdhcpctl.a ; doman *.3
- insinto /usr/include ; doins dhcpctl.h
-
- cd ../omapip ; dolib libomapi.a ; doman *.3
- cd ../relay ; dosbin dhcrelay ; doman *.8
- cd ../common ; doman *.5
- cd ../server ; dosbin dhcpd ; doman *.5 *.8
-
- cd ${S}/client
- # admins might wanna edit dhclient-script, so /etc is proper for it.
- dosed "s:/etc/dhclient-script:/etc/dhcp/dhclient-script:" dhclient.conf
- insinto /etc/dhcp ; newins dhclient.conf dhclient.conf.sample
- exeinto /etc/dhcp ; newexe scripts/linux dhclient-script.sample
-
- cd ${S}/server
- insinto /etc/dhcp ; newins dhcpd.conf dhcpd.conf.sample
-
- cd ${S}/includes/omapip
- insinto /usr/include/omapip ; doins alloc.h buffer.h omapip.h
-
- cd ${S}/includes/isc-dhcp
- insinto /usr/include/isc-dhcp
- doins boolean.h dst.h int.h lang.h list.h result.h types.h
-
- cd ${S}
- dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES
- newdoc client/dhclient.conf dhclient.conf.sample
- newdoc client/scripts/linux dhclient-script.sample
- newdoc server/dhcpd.conf dhcpd.conf.sample
- docinto doc ; dodoc doc/*
-
- exeinto /etc/rc.d/init.d
- newexe ${FILESDIR}/dhcp.rc5 dhcp
-}
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0 b/net-misc/dhcp/files/digest-dhcp-3.0
new file mode 100644
index 000000000000..ce85fb901832
--- /dev/null
+++ b/net-misc/dhcp/files/digest-dhcp-3.0
@@ -0,0 +1 @@
+MD5 06e0247fe787d356ac00933633e1fe71 dhcp-3.0.tar.gz 864786
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0_rc12 b/net-misc/dhcp/files/digest-dhcp-3.0_rc12
deleted file mode 100644
index 0e5c66431d01..000000000000
--- a/net-misc/dhcp/files/digest-dhcp-3.0_rc12
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7aa34ef3cd4a24f0c6857283d5261003 dhcp-3.0rc12.tar.gz 866193
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0_rc12-r6 b/net-misc/dhcp/files/digest-dhcp-3.0_rc12-r6
deleted file mode 100644
index 0e5c66431d01..000000000000
--- a/net-misc/dhcp/files/digest-dhcp-3.0_rc12-r6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7aa34ef3cd4a24f0c6857283d5261003 dhcp-3.0rc12.tar.gz 866193