summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-27 05:34:50 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-27 05:34:50 +0000
commitc5c8d35511de9221a4610b8c8c42041bb530e8fe (patch)
treed7cbc675158b616643a1b0610c3aee412a7a1a49 /net-misc/dante
parentFixed a glibc-2.2.2 header issue and hacked in CFLAGS support (diff)
downloadgentoo-2-c5c8d35511de9221a4610b8c8c42041bb530e8fe.tar.gz
gentoo-2-c5c8d35511de9221a4610b8c8c42041bb530e8fe.tar.bz2
gentoo-2-c5c8d35511de9221a4610b8c8c42041bb530e8fe.zip
A socks package
Diffstat (limited to 'net-misc/dante')
-rw-r--r--net-misc/dante/dante-1.1.9.ebuild43
-rw-r--r--net-misc/dante/files/digest-dante-1.1.91
2 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/dante/dante-1.1.9.ebuild b/net-misc/dante/dante-1.1.9.ebuild
new file mode 100644
index 000000000000..70aab1365aa1
--- /dev/null
+++ b/net-misc/dante/dante-1.1.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dante/dante-1.1.9.ebuild,v 1.1 2001/04/27 05:34:50 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A free socks4,5 and msproxy implemetation"
+SRC_URI="ftp://ftp.inet.no/pub/socks/${A}"
+HOMEPAGE="http://www.inet.no/dante/"
+
+DEPEND="virtual/glibc "
+
+src_compile() {
+ local myconf
+ if [ -z "`use tcpd`" ]
+ then
+ myconf="--disable-libwrap"
+ fi
+ if [ "$DEBUG" ]
+ then
+ myconf="$myconf --enble-debug"
+ fi
+
+ try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} $myconf \
+ --with-socks-conf=/etc/socks/socks.conf --with-sockd-conf=/etc/socks/sockd.conf
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodir /etc/socks
+ dodoc BUGS CREDITS LICENSE NEWS README SUPPORT TODO VERSION
+ docinto txt
+ cd doc
+ dodoc README* *.txt SOCKS4.*
+ docinto example
+ cd ../example
+ dodoc *.conf
+}
+
diff --git a/net-misc/dante/files/digest-dante-1.1.9 b/net-misc/dante/files/digest-dante-1.1.9
new file mode 100644
index 000000000000..7c55cf44190f
--- /dev/null
+++ b/net-misc/dante/files/digest-dante-1.1.9
@@ -0,0 +1 @@
+MD5 83a23e3ffbf41c1b03a2b818d7dd1682 dante-1.1.9.tar.gz