summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-02-04 18:34:05 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-02-04 18:34:05 +0000
commit471f9fc9e08f55c8900675ba4e4503381991f94d (patch)
tree16d60f503f375bdfe3632bd6d9a5f35c0244c4a9 /net-misc/d4x/d4x-2.5.0_rc2.ebuild
parentmasked last -r1 of dev-libs/boost until symlinks are sorted out (diff)
downloadgentoo-2-471f9fc9e08f55c8900675ba4e4503381991f94d.tar.gz
gentoo-2-471f9fc9e08f55c8900675ba4e4503381991f94d.tar.bz2
gentoo-2-471f9fc9e08f55c8900675ba4e4503381991f94d.zip
version bump and cleanup (#37018)
Diffstat (limited to 'net-misc/d4x/d4x-2.5.0_rc2.ebuild')
-rw-r--r--net-misc/d4x/d4x-2.5.0_rc2.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/net-misc/d4x/d4x-2.5.0_rc2.ebuild b/net-misc/d4x/d4x-2.5.0_rc2.ebuild
new file mode 100644
index 000000000000..005d5a7b79a7
--- /dev/null
+++ b/net-misc/d4x/d4x-2.5.0_rc2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/d4x/d4x-2.5.0_rc2.ebuild,v 1.1 2004/02/04 18:34:05 liquidx Exp $
+
+IUSE="nls esd gnome oss kde"
+
+inherit eutils
+
+S="${WORKDIR}/${P/_}"
+DESCRIPTION="GTK based download manager for X."
+SRC_URI="http://www.krasu.ru/soft/chuchelo/files/${P/_}.tar.gz"
+HOMEPAGE="http://www.krasu.ru/soft/chuchelo/"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="Artistic"
+
+DEPEND=">=x11-libs/gtk+-2.0.6
+ >=dev-libs/glib-2.0.6
+ >=sys-devel/gettext-0.11.2
+ esd? ( >=media-sound/esound-0.2.7 )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Use our own $CXXFLAGS
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:CXXFLAGS=\"-O2\":CXXFLAGS=\"${CXXFLAGS}\":g;s:OPTFLAGS=\"-O2\":OPTFLAGS=\"\":g" \
+ configure.orig >configure
+
+ # Fix a miscompile with gcc-3.2.2 and CFLAGS="-O2"
+ # <azarah@gentoo.org> (30 Mar 2003)
+ #epatch ${FILESDIR}/${PN}-2.4.1-fix-statusbar-crash.patch
+}
+
+src_compile() {
+
+ myconf=""
+
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ use esd \
+ && myconf="${myconf} --enable-esd" \
+ || myconf="${myconf} --disable-esd"
+
+ use oss \
+ && myconf="${myconf} --enable-oss" \
+ || myconf="${myconf} --disable-oss"
+
+ econf --enable-release \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+
+ dodir /usr/bin
+ dodir /usr/share/d4x
+
+ einstall || die
+
+ insinto /usr/share/pixmaps
+ doins share/*.png share/*.xpm
+
+ if [ -n "`use kde`" ]
+ then
+ insinto /usr/share/applnk/Internet
+ newins share/nt.desktop d4x.desktop
+ fi
+
+ if [ -n "`use gnome`" ]
+ then
+ echo "Categories=Application;Network;" >> ${S}/share/nt.desktop
+ insinto /usr/share/applications
+ newins share/nt.desktop d4x.desktop
+ fi
+
+ rm -rf ${D}/usr/share/d4x/{FAQ*,INSTALL*,README*,LICENSE,NAMES,TROUBLES}
+ dodoc AUTHORS COPYING ChangeLog* NEWS PLANS TODO \
+ DOC/{FAQ*,LICENSE,NAMES,README*,TROUBLES,THANKS}
+}
+