summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-06-12 09:31:45 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-06-12 09:31:45 +0000
commit279f0dc6b4a0d2171480290b558c7ffd70f3b51a (patch)
treecef53c8cfddd827fd4ddfbcdce4b5ec39d0b9be2 /net-misc/cgminer
parentAdd fix for qlop tests #551806 by Nikoli. (diff)
downloadgentoo-2-279f0dc6b4a0d2171480290b558c7ffd70f3b51a.tar.gz
gentoo-2-279f0dc6b4a0d2171480290b558c7ffd70f3b51a.tar.bz2
gentoo-2-279f0dc6b4a0d2171480290b558c7ffd70f3b51a.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/cgminer')
-rw-r--r--net-misc/cgminer/ChangeLog8
-rw-r--r--net-misc/cgminer/cgminer-4.9.2.ebuild86
-rw-r--r--net-misc/cgminer/metadata.xml3
3 files changed, 96 insertions, 1 deletions
diff --git a/net-misc/cgminer/ChangeLog b/net-misc/cgminer/ChangeLog
index 96141134dcbc..3fcbbf58a349 100644
--- a/net-misc/cgminer/ChangeLog
+++ b/net-misc/cgminer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/cgminer
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.86 2015/02/03 12:22:57 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.87 2015/06/12 09:31:45 blueness Exp $
+
+*cgminer-4.9.2 (12 Jun 2015)
+
+ 12 Jun 2015; Anthony G. Basile <blueness@gentoo.org> +cgminer-4.9.2.ebuild,
+ metadata.xml:
+ Version bump.
*cgminer-4.9.1 (03 Feb 2015)
diff --git a/net-misc/cgminer/cgminer-4.9.2.ebuild b/net-misc/cgminer/cgminer-4.9.2.ebuild
new file mode 100644
index 000000000000..83ffc4cbb468
--- /dev/null
+++ b/net-misc/cgminer/cgminer-4.9.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-4.9.2.ebuild,v 1.1 2015/06/12 09:31:45 blueness Exp $
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
+HOMEPAGE="http://bitcointalk.org/?topic=28402.msg357369 http://github.com/ckolivas/cgminer"
+SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
+#SRC_URI="http://ck.kolivas.org/apps/cgminer/4.5/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+HARDWARE="ants1 ants2 ants3 avalon avalon2 avalon4 bab bflsc bitforce bitfury bitmine_A1 blockerupter cointerra drillbit hashfast hashratio icarus klondike knc minion modminer sp10 sp30"
+IUSE="doc examples udev hardened ncurses ${HARDWARE}"
+
+REQUIRED_USE="|| ( ${HARDWARE} )"
+
+RDEPEND="net-misc/curl
+ >=dev-libs/jansson-2.6
+ virtual/libusb:1[udev]
+ ncurses? ( sys-libs/ncurses )
+ udev? ( virtual/libudev )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_configure() {
+ use hardened && append-cflags "-nopie"
+
+ # PKG_CHECK_MODULES needs PKG_CONFIG for --with-system-jansson.
+ export PKG_CONFIG=/usr/bin/pkg-config
+ econf $(use_with ncurses curses) \
+ $(use_enable ants1) \
+ $(use_enable ants2) \
+ $(use_enable ants3) \
+ $(use_enable avalon) \
+ $(use_enable avalon2) \
+ $(use_enable avalon4) \
+ $(use_enable bab) \
+ $(use_enable bitmine_A1) \
+ $(use_enable bflsc) \
+ $(use_enable bitforce) \
+ $(use_enable bitfury) \
+ $(use_enable blockerupter) \
+ $(use_enable cointerra) \
+ $(use_enable drillbit) \
+ $(use_enable hashfast) \
+ $(use_enable hashratio) \
+ $(use_enable icarus) \
+ $(use_enable klondike) \
+ $(use_enable knc) \
+ $(use_enable minion) \
+ $(use_enable modminer) \
+ $(use_enable sp10) \
+ $(use_enable sp30) \
+ $(use_enable udev) \
+ --disable-forcecombo \
+ --with-system-libusb \
+ --with-system-jansson
+ # sanitize directories (is this still needed?)
+ sed -i 's~^\(\#define CGMINER_PREFIX \).*$~\1"'"${EPREFIX}/usr/lib/cgminer"'"~' config.h
+}
+
+src_install() { # How about using some make install?
+ dobin cgminer
+
+ if use udev; then
+ insinto /lib/udev/rules.d
+ use udev && doins 01-cgminer.rules
+ fi
+
+ if use doc; then
+ dodoc AUTHORS NEWS README API-README
+ use icarus || use bitforce || use modminer && dodoc FPGA-README
+ use avalon || use bflsc && dodoc ASIC-README
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc api-example.php miner.php API.java api-example.c example.conf
+ fi
+}
diff --git a/net-misc/cgminer/metadata.xml b/net-misc/cgminer/metadata.xml
index 521b6f068c6b..38771f3382fe 100644
--- a/net-misc/cgminer/metadata.xml
+++ b/net-misc/cgminer/metadata.xml
@@ -13,6 +13,7 @@
<use>
<flag name="ants1">Enable support for Antminer S1 Bitmain</flag>
<flag name="ants2">Enable support for Antminer S2 Bitmain</flag>
+ <flag name="ants3">Enable support for Antminer S3 Bitmain</flag>
<flag name="avalon">Enable support for Avalon ASICs</flag>
<flag name="avalon2">Enable support for Avalon2 ASICs</flag>
<flag name="avalon4">Enable support for Avalon4 ASICs</flag>
@@ -32,5 +33,7 @@
<flag name="minion">Enable support for mining with BlackArrow Bitfury </flag>
<flag name="modminer">Enable support for mining with ModMiner FPGAs</flag>
<flag name='spondoolies'>Enable support for Spondoolies</flag>
+ <flag name='sp10'>Enable support for Spondoolies SP10</flag>
+ <flag name='sp30'>Enable support for Spondoolies SP30</flag>
</use>
</pkgmetadata>