summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-06-18 11:36:58 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-06-18 11:36:58 +0000
commit811802461fec6f6fec68ac54b83d6e45225ca6c8 (patch)
tree7606bbda6c1ba9ec13c7adbb525a59ff8c59260d /net-misc/bfgminer/files
parentSuppress JPL unit test causing known stack overflow (diff)
downloadgentoo-2-811802461fec6f6fec68ac54b83d6e45225ca6c8.tar.gz
gentoo-2-811802461fec6f6fec68ac54b83d6e45225ca6c8.tar.bz2
gentoo-2-811802461fec6f6fec68ac54b83d6e45225ca6c8.zip
Fix bug #473316
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/bfgminer/files')
-rw-r--r--net-misc/bfgminer/files/3.1.0-Bugfix-opencl-Add-missing-include-for-fpgautils.h-ne.patch25
-rw-r--r--net-misc/bfgminer/files/3.1.0-Bugfix-opencl-Build-fpgautils-even-if-OpenCL-is-the-.patch26
2 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/bfgminer/files/3.1.0-Bugfix-opencl-Add-missing-include-for-fpgautils.h-ne.patch b/net-misc/bfgminer/files/3.1.0-Bugfix-opencl-Add-missing-include-for-fpgautils.h-ne.patch
new file mode 100644
index 000000000000..3c941f386f3d
--- /dev/null
+++ b/net-misc/bfgminer/files/3.1.0-Bugfix-opencl-Add-missing-include-for-fpgautils.h-ne.patch
@@ -0,0 +1,25 @@
+From d65e37e05203a4e88b42680fd9504c54833f28a6 Mon Sep 17 00:00:00 2001
+From: Luke Dashjr <luke-jr+git@utopios.org>
+Date: Fri, 14 Jun 2013 18:06:02 +0000
+Subject: [PATCH] Bugfix: opencl: Add missing include for fpgautils.h (needed
+ for open_bitstream)
+
+---
+ ocl.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/ocl.c b/ocl.c
+index 15bd86c..12a3d29 100644
+--- a/ocl.c
++++ b/ocl.c
+@@ -34,6 +34,7 @@
+ #define OMIT_OPENCL_API
+
+ #include "findnonce.h"
++#include "fpgautils.h"
+ #include "ocl.h"
+
+ /* Platform API */
+--
+1.8.1.5
+
diff --git a/net-misc/bfgminer/files/3.1.0-Bugfix-opencl-Build-fpgautils-even-if-OpenCL-is-the-.patch b/net-misc/bfgminer/files/3.1.0-Bugfix-opencl-Build-fpgautils-even-if-OpenCL-is-the-.patch
new file mode 100644
index 000000000000..27eef4d50b16
--- /dev/null
+++ b/net-misc/bfgminer/files/3.1.0-Bugfix-opencl-Build-fpgautils-even-if-OpenCL-is-the-.patch
@@ -0,0 +1,26 @@
+From fa2f27dbc7b1bffc77526a752824a7dc7cfa6a77 Mon Sep 17 00:00:00 2001
+From: Luke Dashjr <luke-jr+git@utopios.org>
+Date: Sat, 15 Jun 2013 19:20:47 +0000
+Subject: [PATCH] Bugfix: opencl: Build fpgautils even if OpenCL is the only
+ driver, now that it uses it for kernel-finding
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 97aa8c7..c69d01d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -525,7 +525,7 @@ AC_SUBST(libblkmaker_LIBS)
+
+ AM_CONDITIONAL([NEED_LIBBLKMAKER], [test x$with_system_libblkmaker != xyes])
+ AM_CONDITIONAL([NEED_DYNCLOCK], [test x$icarus$modminer$x6500$ztex != xnonono])
+-AM_CONDITIONAL([NEED_FPGAUTILS], [test x$avalon$icarus$bitforce$modminer$x6500$ztex != xnononononono])
++AM_CONDITIONAL([NEED_FPGAUTILS], [test x$avalon$icarus$bitforce$modminer$opencl$x6500$ztex != xnonononononono])
+ AM_CONDITIONAL([HAS_SCRYPT], [test x$scrypt = xyes])
+ AM_CONDITIONAL([HAVE_CURSES], [test x$curses = xyes])
+ AM_CONDITIONAL([HAVE_SENSORS], [test x$with_sensors = xyes])
+--
+1.8.1.5
+