summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-06-16 22:51:30 +0000
committerMichael Weber <xmw@gentoo.org>2012-06-16 22:51:30 +0000
commit039c569b37e45a5d78177624e34e476ee275c035 (patch)
tree5a27bf71972506c9bb8c0a108803a64c07f63ec7 /net-misc/balance
parentRemoved broken 0.5.x, add fixes (diff)
downloadgentoo-2-039c569b37e45a5d78177624e34e476ee275c035.tar.gz
gentoo-2-039c569b37e45a5d78177624e34e476ee275c035.tar.bz2
gentoo-2-039c569b37e45a5d78177624e34e476ee275c035.zip
Version bump (bug 365965, thanks CJ Kucera), respect LDFLAGS (bug 336958)
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/balance')
-rw-r--r--net-misc/balance/ChangeLog8
-rw-r--r--net-misc/balance/balance-3.54.ebuild31
-rw-r--r--net-misc/balance/files/balance-3.54-Makefile.patch52
3 files changed, 90 insertions, 1 deletions
diff --git a/net-misc/balance/ChangeLog b/net-misc/balance/ChangeLog
index 5b0670ae8529..2ceedf9b8070 100644
--- a/net-misc/balance/ChangeLog
+++ b/net-misc/balance/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/balance
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/balance/ChangeLog,v 1.19 2012/06/16 09:23:55 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/balance/ChangeLog,v 1.20 2012/06/16 22:51:30 xmw Exp $
+
+*balance-3.54 (16 Jun 2012)
+
+ 16 Jun 2012; Michael Weber <xmw@gentoo.org> +balance-3.54.ebuild,
+ +files/balance-3.54-Makefile.patch:
+ Version bump (bug 365965, thanks CJ Kucera), respect LDFLAGS (bug 336958)
16 Jun 2012; Michael Weber <xmw@gentoo.org> metadata.xml:
Taking maint.
diff --git a/net-misc/balance/balance-3.54.ebuild b/net-misc/balance/balance-3.54.ebuild
new file mode 100644
index 000000000000..bb02eb180a6d
--- /dev/null
+++ b/net-misc/balance/balance-3.54.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/balance/balance-3.54.ebuild,v 1.1 2012/06/16 22:51:30 xmw Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="TCP Load Balancing Port Forwarder"
+HOMEPAGE="http://www.inlab.de/balance.html"
+SRC_URI="http://www.inlab.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-text/ghostscript-gpl
+ sys-apps/groff )"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ tc-export CC
+ use doc || touch balance.pdf
+}
+
+src_install() {
+ default
+ use doc && dodoc balance.pdf
+}
diff --git a/net-misc/balance/files/balance-3.54-Makefile.patch b/net-misc/balance/files/balance-3.54-Makefile.patch
new file mode 100644
index 000000000000..db378f97a777
--- /dev/null
+++ b/net-misc/balance/files/balance-3.54-Makefile.patch
@@ -0,0 +1,52 @@
+--- balance-3.54/Makefile
++++ balance-3.54/Makefile
+@@ -1,14 +1,14 @@
+ # $Id: balance-3.54-Makefile.patch,v 1.1 2012/06/16 22:51:30 xmw Exp $
+
+ #CFLAGS=-g -I.
+-CFLAGS=-O2 -Wall -Wstrict-prototypes -Wuninitialized
++CFLAGS+=-Wall -Wstrict-prototypes -Wuninitialized
+
+ # uncomment for any OS other than Cygwin
+ BALANCE=balance
+ ROOT=root
+ INSTALL=install
+ BINDIR=/usr/sbin
+-MANDIR=${BINDIR}/../man/man1
++MANDIR=/usr/share/man/man1
+
+ # uncomment for Solaris:
+ # LIBRARIES=-lsocket -lnsl
+@@ -20,13 +20,13 @@
+ # BALANCE=balance.exe
+ # ROOT=Administrators
+
+-CC=gcc
++CC?=gcc
+ RELEASE=3.54
+
+ all: balance
+
+ balance: balance.o butils.o
+- $(CC) $(CFLAGS) -I. -o balance balance.o butils.o $(LIBRARIES)
++ $(CC) $(CFLAGS) $(LDFLAGS) -I. -o balance balance.o butils.o $(LIBRARIES)
+
+ balance.o: balance.c balance.h
+ $(CC) $(CFLAGS) -I. -c balance.c
+@@ -48,12 +48,15 @@
+ rm -f $(BALANCE) *.o balance.ps balance.pdf
+
+ install:
++ $(INSTALL) -o $(ROOT) -g $(ROOT) -m 755 -d \
++ $(DESTDIR)$(BINDIR) \
++ $(DESTDIR)$(MANDIR)
+ $(INSTALL) -o $(ROOT) -g $(ROOT) -m 755 $(BALANCE) \
+ $(DESTDIR)$(BINDIR)/$(BALANCE)
+ $(INSTALL) -o $(ROOT) -g $(ROOT) -m 755 balance.1 \
+ $(DESTDIR)$(MANDIR)
+ mkdir -p $(DESTDIR)/var/run/balance
+- chmod 1777 $(DESTDIR)/var/run/balance
++ chmod 1755 $(DESTDIR)/var/run/balance
+
+ release: balance.pdf
+ rm -rf ./releases/balance-$(RELEASE)