summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-09-16 17:31:54 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-09-16 17:31:54 +0000
commit54ae63094e315888760d7831f4265b9fe91bf557 (patch)
treeb952a1e1c16d84b77dcdb233291e7d9f335e2aa7 /net-misc/asterisk/files
parentvirtual/glut -> media-libs/glut (diff)
downloadgentoo-2-54ae63094e315888760d7831f4265b9fe91bf557.tar.gz
gentoo-2-54ae63094e315888760d7831f4265b9fe91bf557.tar.bz2
gentoo-2-54ae63094e315888760d7831f4265b9fe91bf557.zip
Add peerstatus to IAX2, closes bug #330135. Correct rotate keyword in logrotate file, closes bug #336066. Add USE="doc", closes bug #331613. Invoke DAHDIRAS differently so non-root works, closes bug #337297. Backported bri_net_ptmp from 1.8 branch, closes bug #337591. Many thanks to Jaco Kroon for all these bugfixes & improvements.
(Portage version: 2.1.9.6/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/asterisk/files')
-rw-r--r--net-misc/asterisk/files/1.6.2/asterisk-1.6.2.13-backport-bri-net-ptmp.patch35
-rw-r--r--net-misc/asterisk/files/1.6.2/asterisk-1.6.2.13-dahdiras-without-root.patch12
-rw-r--r--net-misc/asterisk/files/1.6.2/asterisk-1.6.2.13-iax2-peerstate.patch12
-rw-r--r--net-misc/asterisk/files/1.6.2/asterisk.logrotate229
4 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.13-backport-bri-net-ptmp.patch b/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.13-backport-bri-net-ptmp.patch
new file mode 100644
index 000000000000..18f8dcce8090
--- /dev/null
+++ b/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.13-backport-bri-net-ptmp.patch
@@ -0,0 +1,35 @@
+diff -uNr asterisk-1.6.2.13.ORIG//channels/chan_dahdi.c asterisk-1.6.2.13/channels/chan_dahdi.c
+--- asterisk-1.6.2.13.ORIG//channels/chan_dahdi.c 2010-09-16 18:25:04.000000000 +0100
++++ asterisk-1.6.2.13/channels/chan_dahdi.c 2010-09-16 18:25:21.000000000 +0100
+@@ -16630,7 +16630,12 @@
+ confp->chan.sig = SIG_BRI_PTMP;
+ confp->pri.nodetype = PRI_CPE;
+ } else if (!strcasecmp(v->value, "bri_net_ptmp")) {
++#if defined(HAVE_PRI_CALL_HOLD)
++ confp->chan.sig = SIG_BRI_PTMP;
++ confp->pri.nodetype = PRI_NETWORK;
++#else
+ ast_log(LOG_WARNING, "How cool would it be if someone implemented this mode! For now, sucks for you. (line %d)\n", v->lineno);
++#endif
+ } else if (!strcasecmp(v->value, "gr303fxoks_net")) {
+ confp->chan.sig = SIG_GR303FXOKS;
+ confp->pri.nodetype = PRI_NETWORK;
+diff -uNr asterisk-1.6.2.13.ORIG//configure.ac asterisk-1.6.2.13/configure.ac
+--- asterisk-1.6.2.13.ORIG//configure.ac 2010-09-16 18:25:04.000000000 +0100
++++ asterisk-1.6.2.13/configure.ac 2010-09-16 18:25:21.000000000 +0100
+@@ -334,6 +334,7 @@
+ AST_EXT_LIB_SETUP([PORTAUDIO], [PortAudio], [portaudio])
+ AST_EXT_LIB_SETUP([PRI], [ISDN PRI], [pri])
+ AST_EXT_LIB_SETUP_DEPENDENT([PRI_INBANDDISCONNECT], [ISDN PRI set_inbanddisconnect], [PRI], [pri])
++AST_EXT_LIB_SETUP_DEPENDENT([PRI_CALL_HOLD], [ISDN PRI call hold], [PRI], [pri])
+ AST_EXT_LIB_SETUP([PWLIB], [PWlib], [pwlib])
+ AST_EXT_LIB_SETUP([RADIUS], [Radius Client], [radius])
+ AST_EXT_LIB_SETUP([RESAMPLE], [LIBRESAMPLE], [resample])
+@@ -1490,6 +1491,7 @@
+ AST_EXT_LIB_CHECK([PORTAUDIO], [portaudio], [Pa_GetDeviceCount], [portaudio.h])
+
+ AST_EXT_LIB_CHECK([PRI], [pri], [pri_new_bri], [libpri.h])
++AST_EXT_LIB_CHECK([PRI_CALL_HOLD], [pri], [pri_hold_enable], [libpri.h])
+
+ AST_EXT_LIB_CHECK([PRI_PROG_W_CAUSE], [pri], [pri_progress_with_cause], [libpri.h])
+
diff --git a/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.13-dahdiras-without-root.patch b/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.13-dahdiras-without-root.patch
new file mode 100644
index 000000000000..94f3d3681288
--- /dev/null
+++ b/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.13-dahdiras-without-root.patch
@@ -0,0 +1,12 @@
+diff -uNr asterisk-1.6.2.13.ORIG/apps/app_dahdiras.c asterisk-1.6.2.13/apps/app_dahdiras.c
+--- asterisk-1.6.2.13.ORIG/apps/app_dahdiras.c 2010-09-16 17:40:39.000000000 +0100
++++ asterisk-1.6.2.13/apps/app_dahdiras.c 2010-09-16 17:41:05.000000000 +0100
+@@ -119,8 +119,6 @@
+ c = strsep(&stringp, ",");
+ }
+
+- argv[argc++] = "plugin";
+- argv[argc++] = "dahdi.so";
+ argv[argc++] = "stdin";
+
+ /* Finally launch PPP */
diff --git a/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.13-iax2-peerstate.patch b/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.13-iax2-peerstate.patch
new file mode 100644
index 000000000000..c9eb8d579205
--- /dev/null
+++ b/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.13-iax2-peerstate.patch
@@ -0,0 +1,12 @@
+diff -uNr asterisk-1.6.2.13.ORIG/channels/chan_iax2.c asterisk-1.6.2.13/channels/chan_iax2.c
+--- asterisk-1.6.2.13.ORIG/channels/chan_iax2.c 2010-09-16 13:18:19.000000000 +0100
++++ asterisk-1.6.2.13/channels/chan_iax2.c 2010-09-16 13:18:41.000000000 +0100
+@@ -8403,7 +8403,7 @@
+ ast_db_put("IAX/Registry", p->name, data);
+ ast_verb(3, "Registered IAX2 '%s' (%s) at %s:%d\n", p->name,
+ ast_test_flag(&iaxs[callno]->state, IAX_STATE_AUTHENTICATED) ? "AUTHENTICATED" : "UNAUTHENTICATED", ast_inet_ntoa(sin->sin_addr), ntohs(sin->sin_port));
+- manager_event(EVENT_FLAG_SYSTEM, "PeerStatus", "ChannelType: IAX2\r\nPeer: IAX2/%s\r\nPeerStatus: Registered\r\n", p->name);
++ manager_event(EVENT_FLAG_SYSTEM, "PeerStatus", "ChannelType: IAX2\r\nPeer: IAX2/%s\r\nPeerStatus: Registered\r\nAddress: %s\r\nPost: %d\r\n", p->name, ast_inet_ntoa(sin->sin_addr), ntohs(sin->sin_port));
+ register_peer_exten(p, 1);
+ ast_devstate_changed(AST_DEVICE_UNKNOWN, "IAX2/%s", p->name); /* Activate notification */
+ } else if (!ast_test_flag(p, IAX_TEMPONLY)) {
diff --git a/net-misc/asterisk/files/1.6.2/asterisk.logrotate2 b/net-misc/asterisk/files/1.6.2/asterisk.logrotate2
new file mode 100644
index 000000000000..4233d231665e
--- /dev/null
+++ b/net-misc/asterisk/files/1.6.2/asterisk.logrotate2
@@ -0,0 +1,29 @@
+/var/log/asterisk/messages /var/log/asterisk/queue_log {
+ missingok
+ notifempty
+
+ postrotate
+ /usr/sbin/asterisk -rx "logger reload"
+ endscript
+}
+
+/var/log/asterisk/debug /var/log/asterisk/full {
+ missingok
+ notifempty
+ daily
+
+ postrotate
+ /usr/sbin/asterisk -rx "logger reload"
+ endscript
+}
+
+/var/log/asterisk/cdr-csv/*.csv /var/log/asterisk/cdr-custom/*.csv {
+ missingok
+ notifempty
+ weekly
+ rotate 52
+
+ postrotate
+ /usr/sbin/asterisk -rx "logger reload"
+ endscript
+}