summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-11-12 17:45:32 +0000
committerMichał Górny <mgorny@gentoo.org>2012-11-12 17:45:32 +0000
commitceeb50c839c2afcd1a9973dba199a7eb48f0a265 (patch)
tree15a4571ef04fc74e1660fa9a835d19183b33e75a /net-misc/aria2
parentVersion bump with various bugfixes. Drop old. (diff)
downloadgentoo-2-ceeb50c839c2afcd1a9973dba199a7eb48f0a265.tar.gz
gentoo-2-ceeb50c839c2afcd1a9973dba199a7eb48f0a265.tar.bz2
gentoo-2-ceeb50c839c2afcd1a9973dba199a7eb48f0a265.zip
Version bump. Rework the USE flags, clean up the ebuild a bit.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'net-misc/aria2')
-rw-r--r--net-misc/aria2/ChangeLog8
-rw-r--r--net-misc/aria2/aria2-1.15.2.ebuild133
-rw-r--r--net-misc/aria2/metadata.xml14
3 files changed, 149 insertions, 6 deletions
diff --git a/net-misc/aria2/ChangeLog b/net-misc/aria2/ChangeLog
index 1976bbdcf6c0..3e3f8a157956 100644
--- a/net-misc/aria2/ChangeLog
+++ b/net-misc/aria2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/aria2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/ChangeLog,v 1.82 2012/11/11 16:56:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/ChangeLog,v 1.83 2012/11/12 17:45:32 mgorny Exp $
+
+*aria2-1.15.2 (12 Nov 2012)
+
+ 12 Nov 2012; Michał Górny <mgorny@gentoo.org> +aria2-1.15.2.ebuild,
+ metadata.xml:
+ Version bump. Rework the USE flags, clean up the ebuild a bit.
11 Nov 2012; Justin Lecher <jlec@gentoo.org> aria2-1.12.1.ebuild,
aria2-1.14.1.ebuild, aria2-1.15.0.ebuild, metadata.xml:
diff --git a/net-misc/aria2/aria2-1.15.2.ebuild b/net-misc/aria2/aria2-1.15.2.ebuild
new file mode 100644
index 000000000000..e238cd385a20
--- /dev/null
+++ b/net-misc/aria2/aria2-1.15.2.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/aria2-1.15.2.ebuild,v 1.1 2012/11/12 17:45:32 mgorny Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="A download utility with segmented downloading with BitTorrent support"
+HOMEPAGE="http://aria2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+SLOT="0"
+IUSE="adns bittorrent +gnutls +libxml2 metalink +nettle nls sqlite scripts ssl test xmlrpc"
+
+CDEPEND="sys-libs/zlib
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.9 )
+ !gnutls? ( dev-libs/openssl ) )
+ adns? ( >=net-dns/c-ares-1.5.0 )
+ bittorrent? (
+ ssl? (
+ gnutls? (
+ nettle? ( >=dev-libs/nettle-2.4[gmp] >=dev-libs/gmp-5 )
+ !nettle? ( >=dev-libs/libgcrypt-1.2.2 ) ) )
+ !ssl? (
+ nettle? ( >=dev-libs/nettle-2.4[gmp] >=dev-libs/gmp-5 )
+ !nettle? ( >=dev-libs/libgcrypt-1.2.2 ) ) )
+ metalink? (
+ libxml2? ( >=dev-libs/libxml2-2.6.26 )
+ !libxml2? ( dev-libs/expat ) )
+ sqlite? ( dev-db/sqlite:3 )
+ xmlrpc? (
+ libxml2? ( >=dev-libs/libxml2-2.6.26 )
+ !libxml2? ( dev-libs/expat ) )"
+
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( >=dev-util/cppunit-1.12.0 )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libiconv virtual/libintl )
+ scripts? ( dev-lang/ruby )"
+
+pkg_setup() {
+ if use scripts && use !xmlrpc && use !metalink; then
+ ewarn "Please note that you may need to enable USE=xmlrpc to run the aria2rpc"
+ ewarn "and aria2mon scripts against the local aria2."
+ fi
+}
+
+src_prepare() {
+ epatch_user
+ sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
+}
+
+src_configure() {
+ # Notes:
+ # - always enable gzip/http compression since zlib should always be available anyway
+ # - always enable epoll since we can assume kernel 2.6.x
+ # - other options for threads: solaris, pth, win32
+ local myconf=(
+ --enable-epoll
+ --enable-threads=posix
+ --with-libz
+ $(use_enable nls)
+ $(use_enable metalink)
+ $(use_with sqlite sqlite3)
+ $(use_enable bittorrent)
+ $(use_with adns libcares)
+ )
+
+ # SSL := gnutls / openssl
+ # USE=ssl
+ # + USE=gnutls -> gnutls
+ # + USE=-gnutls -> openssl
+
+ if use ssl; then
+ myconf+=( $(use_with gnutls) $(use_with !gnutls openssl) )
+ else
+ myconf+=( --without-gnutls --without-openssl )
+ fi
+
+ # message-digest := nettle / gcrypt / openssl
+ # bignum := nettle+gmp / gcrypt / openssl
+ # bittorrent := message-digest + bignum
+ # USE=bittorrent
+ # + USE=(ssl -gnutls) -> openssl
+ # + USE=nettle -> nettle+gmp
+ # + USE=-nettle -> gcrypt
+
+ if use !bittorrent || use ssl && use !gnutls; then
+ myconf+=( --without-libgcrypt --without-libnettle --without-libgmp )
+ else
+ myconf+=( $(use_with !nettle libgcrypt)
+ $(use_with nettle libnettle) $(use_with nettle libgmp) )
+ fi
+
+ # metalink+xmlrpc := libxml2 / expat
+ # USE=(metalink || xmlrpc)
+ # + USE=libxml2 -> libxml2
+ # + USE=-libxml2 -> expat
+
+ if use metalink || use xmlrpc; then
+ myconf+=( $(use_with !libxml2 libexpat) $(use_with libxml2) )
+ else
+ myconf+=( --without-libexpat --without-libxml2 )
+ fi
+
+ # Note:
+ # - always enable gzip/http compression since zlib should always be available anyway
+ # - always enable epoll since we can assume kernel 2.6.x
+ # - other options for threads: solaris, pth, win32
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ rm -rf "${D}"/usr/share/doc/aria2 \
+ "${D}"/usr/share/doc/${PF}/README{,.html}
+
+ dobashcomp doc/bash_completion/aria2c
+ use scripts && dobin doc/xmlrpc/aria2{mon,rpc}
+}
+
+pkg_postinst() {
+ if use xmlrpc || use metalink; then
+ elog "If you would like to use the additional aria2mon and aria2rpc tools,"
+ elog "you need to have \033[1mdev-lang/ruby\033[0m installed."
+ fi
+}
diff --git a/net-misc/aria2/metadata.xml b/net-misc/aria2/metadata.xml
index 23664afd5333..39f54f45efd6 100644
--- a/net-misc/aria2/metadata.xml
+++ b/net-misc/aria2/metadata.xml
@@ -5,13 +5,17 @@
<email>dev-zero@gentoo.org</email>
<name>Tiziano Müller</name>
</maintainer>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
<use>
<flag name="ares">Enables support for asynchronous DNS using the c-ares library</flag>
- <flag name="bittorrent">Enables support for the bittorrent protocol</flag>
- <flag name="nettle">Use <pkg>dev-libs/nettle</pkg> and <pkg>dev-libs/gmp</pkg>
- for bittorrent/metalink crypto instead of <pkg>dev-libs/libgcrypt</pkg> when using <pkg>net-libs/gnutls</pkg> for SSL or without SSL support at all.</flag>
- <flag name="metalink">Enables support for metalink</flag>
- <flag name="scripts">Install additional scripts which use aria2's xmlrpc functionality</flag>
+ <flag name="bittorrent">Enable support for the bittorrent protocol.</flag>
+ <flag name="libxml2">Use <pkg>dev-libs/libxml2</pkg> for XML parsing (preferred) instead of <pkg>dev-libs/expat</pkg>.</flag>
+ <flag name="nettle">Use <pkg>dev-libs/nettle</pkg> and <pkg>dev-libs/gmp</pkg> for bittorrent/metalink crypto instead of <pkg>dev-libs/libgcrypt</pkg> (when <pkg>dev-libs/openssl</pkg> is not being used).</flag>
+ <flag name="metalink">Enable support for metalink.</flag>
+ <flag name="scripts">Install additional scripts which use aria2's xmlrpc functionality.</flag>
</use>
<upstream>
<remote-id type="sourceforge">aria2</remote-id>