summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-07-25 21:17:49 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-07-25 21:17:49 +0000
commit9e02b6591db24406e81ea47629c05e0832a164aa (patch)
tree643eca367c64ffb3e21f8bef1de0f10e316c1a88 /net-misc/LinNeighborhood
parentFix compilation with gcc-4.4 , closes bug 269320 (diff)
downloadgentoo-2-9e02b6591db24406e81ea47629c05e0832a164aa.tar.gz
gentoo-2-9e02b6591db24406e81ea47629c05e0832a164aa.tar.bz2
gentoo-2-9e02b6591db24406e81ea47629c05e0832a164aa.zip
Fix compilation with gcc-4.4. Patch by Vistor Ostorga <vostorga AT gentoo DOT org>; bug #273990
(Portage version: 2.2_rc33-r1/cvs/Linux i686)
Diffstat (limited to 'net-misc/LinNeighborhood')
-rw-r--r--net-misc/LinNeighborhood/ChangeLog9
-rw-r--r--net-misc/LinNeighborhood/LinNeighborhood-0.6.5.ebuild7
-rw-r--r--net-misc/LinNeighborhood/files/linneighborhood-0.6.5-gcc44.patch16
3 files changed, 27 insertions, 5 deletions
diff --git a/net-misc/LinNeighborhood/ChangeLog b/net-misc/LinNeighborhood/ChangeLog
index bcbfc76af615..5686b4e0e543 100644
--- a/net-misc/LinNeighborhood/ChangeLog
+++ b/net-misc/LinNeighborhood/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/LinNeighborhood
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/LinNeighborhood/ChangeLog,v 1.15 2008/12/18 12:23:21 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/LinNeighborhood/ChangeLog,v 1.16 2009/07/25 21:17:49 halcy0n Exp $
+
+ 25 Jul 2009; Mark Loeser <halcy0n@gentoo.org>
+ LinNeighborhood-0.6.5.ebuild, +files/linneighborhood-0.6.5-gcc44.patch:
+ Fix compilation with gcc-4.4. Patch by Vistor Ostorga <vostorga AT gentoo
+ DOT org>; bug #273990
18 Dec 2008; Diego E. Pettenò <flameeyes@gentoo.org>
LinNeighborhood-0.6.5.ebuild:
diff --git a/net-misc/LinNeighborhood/LinNeighborhood-0.6.5.ebuild b/net-misc/LinNeighborhood/LinNeighborhood-0.6.5.ebuild
index 33e6dbe92054..0b0b3bf53947 100644
--- a/net-misc/LinNeighborhood/LinNeighborhood-0.6.5.ebuild
+++ b/net-misc/LinNeighborhood/LinNeighborhood-0.6.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/LinNeighborhood/LinNeighborhood-0.6.5.ebuild,v 1.17 2008/12/18 12:23:21 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/LinNeighborhood/LinNeighborhood-0.6.5.ebuild,v 1.18 2009/07/25 21:17:49 halcy0n Exp $
inherit eutils
@@ -19,7 +19,8 @@ DEPEND="=x11-libs/gtk+-1.2* net-fs/samba
src_compile() {
local myopts
- epatch ${FILESDIR}/linneighborhood-0.6.5-samba301.patch
+ epatch "${FILESDIR}"/linneighborhood-0.6.5-samba301.patch
+ epatch "${FILESDIR}"/linneighborhood-0.6.5-gcc44.patch
use nls || myopts="--disable-nls"
./configure --prefix=/usr \
diff --git a/net-misc/LinNeighborhood/files/linneighborhood-0.6.5-gcc44.patch b/net-misc/LinNeighborhood/files/linneighborhood-0.6.5-gcc44.patch
new file mode 100644
index 000000000000..b468be012731
--- /dev/null
+++ b/net-misc/LinNeighborhood/files/linneighborhood-0.6.5-gcc44.patch
@@ -0,0 +1,16 @@
+diff -NrU5 LinNeighborhood-0.6.5.orig/src/smbbrowse.c LinNeighborhood-0.6.5/src/smbbrowse.c
+--- LinNeighborhood-0.6.5.orig/src/smbbrowse.c 2009-06-30 18:16:03.000000000 -0600
++++ LinNeighborhood-0.6.5/src/smbbrowse.c 2009-06-30 18:17:18.000000000 -0600
+@@ -368,11 +368,11 @@
+ break;
+ case search_entry:
+ if(browsedat->linepos>=browsedat->master1pos && /*no master allowed*/
+ #ifdef EXPANDTABS
+ !strncmp(browsedat->linebuf," ",4))
+-#elif
++#else
+ browsedat->linebuf[0]=='\t')
+ #endif
+ {
+ groupmasterentry=g_malloc(sizeof(GROUPMASTER_STRUCT));
+ copyentrystr(groupmasterentry->group_name,browsedat->linebuf,