summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2008-03-11 16:27:06 +0000
committerWolfram Schlich <wschlich@gentoo.org>2008-03-11 16:27:06 +0000
commitd9a73c18d10eb6ef5f483b0d99dee48e47c3ec43 (patch)
treedd96f6287fbb29f61a9912e2c93acd566d218440 /net-mail
parentMarking lince-0.99.1 ~ppc64 for bug 211992 (diff)
downloadgentoo-2-d9a73c18d10eb6ef5f483b0d99dee48e47c3ec43.tar.gz
gentoo-2-d9a73c18d10eb6ef5f483b0d99dee48e47c3ec43.tar.bz2
gentoo-2-d9a73c18d10eb6ef5f483b0d99dee48e47c3ec43.zip
added patches for fetch_bodystructure/imap_bodystructure_write
(Portage version: 2.1.4)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot/ChangeLog10
-rw-r--r--net-mail/dovecot/dovecot-1.0.13-r1.ebuild232
-rw-r--r--net-mail/dovecot/dovecot-1.1_rc3-r1.ebuild249
-rw-r--r--net-mail/dovecot/files/dovecot-1.0.13-body.patch24
-rw-r--r--net-mail/dovecot/files/dovecot-1.1_rc3-body.patch128
5 files changed, 642 insertions, 1 deletions
diff --git a/net-mail/dovecot/ChangeLog b/net-mail/dovecot/ChangeLog
index 495395f84938..dc3c825f9356 100644
--- a/net-mail/dovecot/ChangeLog
+++ b/net-mail/dovecot/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/dovecot
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.149 2008/03/10 15:30:38 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.150 2008/03/11 16:27:05 wschlich Exp $
+
+*dovecot-1.1_rc3-r1 (11 Mar 2008)
+*dovecot-1.0.13-r1 (11 Mar 2008)
+
+ 11 Mar 2008; Wolfram Schlich <wschlich@gentoo.org>
+ +files/dovecot-1.0.13-body.patch, +files/dovecot-1.1_rc3-body.patch,
+ +dovecot-1.0.13-r1.ebuild, +dovecot-1.1_rc3-r1.ebuild:
+ added patches for fetch_bodystructure/imap_bodystructure_write
10 Mar 2008; Wolfram Schlich <wschlich@gentoo.org>
-dovecot-1.0.10-r1.ebuild, -dovecot-1.0.11.ebuild, -dovecot-1.0.12.ebuild,
diff --git a/net-mail/dovecot/dovecot-1.0.13-r1.ebuild b/net-mail/dovecot/dovecot-1.0.13-r1.ebuild
new file mode 100644
index 000000000000..5b24ef673489
--- /dev/null
+++ b/net-mail/dovecot/dovecot-1.0.13-r1.ebuild
@@ -0,0 +1,232 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0.13-r1.ebuild,v 1.1 2008/03/11 16:27:05 wschlich Exp $
+
+inherit autotools eutils ssl-cert versionator
+
+MY_P="${P/_/.}"
+MY_PV12=$(get_version_component_range 1-2 ${PV})
+S="${WORKDIR}/${MY_P}"
+SIEVE="dovecot-sieve-1.0.2"
+SIEVE_S="${WORKDIR}/${SIEVE}"
+MANAGESIEVE="MANAGESIEVE-v9.2"
+
+SRC_URI="http://dovecot.org/releases/1.0/${MY_P}.tar.gz
+sieve? ( http://dovecot.org/releases/sieve/${SIEVE}.tar.gz )
+managesieve? ( http://www.rename-it.nl/${PN}/${MY_PV12}/${MY_P}-${MANAGESIEVE}.diff.gz )"
+
+DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
+HOMEPAGE="http://www.dovecot.org/"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug doc ipv6 kerberos ldap managesieve mbox mysql pop3d pam postgres sieve ssl suid vpopmail"
+
+# Developer documentation, controlled by the doc USE flag
+DEVDOCS="auth-protocol index multiaccess securecoding"
+
+DEPEND=">=sys-apps/sed-4
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )
+ postgres? ( dev-db/postgresql )
+ mysql? ( virtual/mysql )
+ vpopmail? ( net-mail/vpopmail )"
+
+RDEPEND="${DEPEND}
+ >=net-mail/mailbase-0.00-r8"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # http://hg.dovecot.org/dovecot-1.0/rev/538f8892a2f1
+ epatch "${FILESDIR}"/${P}-body.patch
+ if use managesieve; then
+ epatch "${WORKDIR}"/${MY_P}-${MANAGESIEVE}.diff
+ eautoreconf
+ fi
+}
+
+pkg_setup() {
+ if ! use sieve && use managesieve; then
+ eerror "managesieve USE flag selected but sieve USE flag unselected"
+ die "USE flag problem"
+ fi
+ # Add user and group for login process (same as for fedora/redhat)
+ enewgroup dovecot 97
+ enewuser dovecot 97 -1 /dev/null dovecot
+}
+
+src_compile() {
+ local myconf=
+ use ssl && myconf="${myconf} --with-ssl=openssl" \
+ || myconf="${myconf} --without-ssl"
+ econf \
+ --localstatedir=/var \
+ --sysconfdir=/etc/dovecot \
+ --enable-header-install \
+ --with-ioloop=best \
+ --with-poll=best \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with kerberos gssapi) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with pam) \
+ $(use_with pop3d) \
+ $(use_with postgres pgsql) \
+ $(use_with vpopmail) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die "make failed"
+
+ if use sieve; then
+ einfo "Building sieve"
+ cd "${SIEVE_S}"
+ econf --with-dovecot="${S}" || die "configure failed (sieve)"
+ emake || die "make failed (sieve)"
+ fi
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ use suid && fperms u+s /usr/libexec/dovecot/deliver
+
+ rm -f "${D}"/etc/dovecot/dovecot-{ldap,sql}-example.conf
+
+ newinitd "${FILESDIR}"/dovecot.init dovecot
+
+ # Documentation
+ rm -rf "${D}"/usr/share/doc/dovecot
+ dodoc AUTHORS NEWS README TODO dovecot-example.conf
+ use managesieve && dodoc README.managesieve
+ if use doc; then
+ dodoc doc/*.txt
+ else
+ local x= n=
+ for x in doc/*.txt; do
+ n=$(basename "${x}" .txt)
+ [[ " ${DEVDOCS} " != *" ${n} "* ]] && dodoc "${x}"
+ done
+ fi
+
+ # Create the dovecot.conf file from the dovecot-example.conf file that
+ # the dovecot folks nicely left for us....
+ local conf="${D}/etc/dovecot/dovecot.conf"
+ mv "${D}"/etc/dovecot/dovecot-example.conf "${D}"/etc/dovecot/dovecot.conf
+
+ # .maildir is the Gentoo default, but we need to support mbox to
+ local mail_location="maildir:~/.maildir"
+ if use mbox; then
+ mail_location="mbox:/var/spool/mail/%u:INDEX=/var/dovecot/%u"
+ keepdir /var/dovecot
+ sed -i -e 's|#mail_extra_groups =|mail_extra_groups = mail|' "${conf}"
+ fi
+ sed -i -e \
+ "s|#mail_location =|mail_location = ${mail_location}|" "${conf}" \
+ || die "failed to update mail location settings in dovecot.conf"
+
+ # We're using pam files (imap and pop3) provided by mailbase
+ if use pam; then
+ sed -i -e '/passdb pam/, /^[ \t]*}/ s|#args = dovecot|args = "\*"|' \
+ "${conf}" || die "failed to update PAM settings in dovecot.conf"
+ fi
+
+ # Listen on ipv6 and ipv4
+ if use ipv6; then
+ sed -i -e 's/^#listen = \*/listen = \[::\]/g' "${conf}" \
+ || die "failed to update listen settings in dovecot.conf"
+ fi
+
+ # Update ssl cert locations
+ if use ssl; then
+ sed -i -e 's,^#ssl_cert_file =.*,ssl_cert_file = /etc/ssl/dovecot/server.pem,' \
+ -e 's,^#ssl_key_file =.*,ssl_key_file = /etc/ssl/dovecot/server.key,' \
+ "${conf}" || die "failed to update SSL settings in dovecot.conf"
+ fi
+
+ # Install SQL configuration
+ if use mysql || use postgres; then
+ cp doc/dovecot-sql-example.conf "${D}"/etc/dovecot/dovecot-sql.conf
+ fperms 600 /etc/dovecot/dovecot-sql.conf
+ sed -i -e '/db sql/,/args/ s|=|= /etc/dovecot-sql.conf|' "${conf}" \
+ || die "failed to update SQL settings in dovecot-sql.conf"
+ dodoc doc/dovecot-sql-example.conf
+ fi
+
+ # Install LDAP configuration
+ if use ldap; then
+ cp doc/dovecot-ldap-example.conf "${D}"/etc/dovecot/dovecot-ldap.conf
+ fperms 600 /etc/dovecot/dovecot-ldap.conf
+ sed -i -e '/db ldap/,/args/ s|=|= /etc/dovecot-ldap.conf|' "${conf}" \
+ || die "failed to update LDAP settings in dovecot-ldap.conf"
+ dodoc doc/dovecot-ldap-example.conf
+ fi
+
+ # Install sieve plugin
+ if use sieve; then
+ make -C "${SIEVE_S}" DESTDIR="${D}" install \
+ || die "make install failed (sieve)"
+ fi
+
+ dodir /var/run/dovecot
+ fowners root:0 /var/run/dovecot
+ fperms 0755 /var/run/dovecot
+ keepdir /var/run/dovecot/login
+ fowners root:dovecot /var/run/dovecot/login
+ fperms 0750 /var/run/dovecot/login
+}
+
+get_config_var() {
+ local varname=${1}
+ if [[ -z ${varname} ]]; then
+ die "${FUNCNAME}: variable name missing"
+ fi
+ sed -n 's/^[[:space:]]\?'"${varname}"'[[:space:]]*="*\([^#"]\+\)"*/\1/p' \
+ "${ROOT}"/etc/dovecot/dovecot.conf
+}
+
+pkg_postinst() {
+ elog "The Dovecot configuration has vastly changed since 0.99."
+ elog "You are encouraged to start afresh with a new configuration file."
+ elog "see http://wiki.dovecot.org/ for configuration examples."
+
+ if [[ -e "${ROOT}"/etc/dovecot.conf ]]; then
+ echo
+ ewarn "The Dovecot configuration now resides in ${ROOT}/etc/dovecot"
+ fi
+
+ local base_dir="$(get_config_var base_dir)"
+ base_dir="${base_dir:-/var/run/dovecot}"
+ if use ssl; then
+ # Let's not make a new certificate if we already have one
+ if ! [[ -e "${ROOT}"/etc/ssl/dovecot/server.pem && \
+ -e "${ROOT}"/etc/ssl/dovecot/server.key ]]; then
+ einfo "Creating SSL certificate"
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-Dovecot IMAP Server}"
+ install_cert /etc/ssl/dovecot/server
+ chown dovecot:mail "${ROOT}"/etc/ssl/dovecot/server.{key,pem}
+ fi
+ if [[ ! -e "${ROOT}${base_dir}/login/ssl-parameters.dat" ]]; then
+ echo
+ elog "Dovecot requires DH SSL Parameters if you use SSL connections"
+ elog "These take some time to make, and dovecot will create them before"
+ elog "it allows any SSL connections."
+ elog "You can create them now before starting dovecot like so"
+ elog " emerge --config =${PF}"
+ fi
+ fi
+}
+
+pkg_config() {
+ local base_dir="$(get_config_var base_dir)"
+ base_dir="${base_dir:-/var/run/dovecot}"
+
+ if use ssl; then
+ einfo "Regenerating SSL parameters. This will take some time."
+ "${ROOT}"/usr/libexec/dovecot/ssl-build-param "${base_dir}/login/ssl-parameters.dat"
+ fi
+}
diff --git a/net-mail/dovecot/dovecot-1.1_rc3-r1.ebuild b/net-mail/dovecot/dovecot-1.1_rc3-r1.ebuild
new file mode 100644
index 000000000000..0a2aa34a1d3c
--- /dev/null
+++ b/net-mail/dovecot/dovecot-1.1_rc3-r1.ebuild
@@ -0,0 +1,249 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.1_rc3-r1.ebuild,v 1.1 2008/03/11 16:27:05 wschlich Exp $
+
+inherit autotools eutils ssl-cert versionator
+
+MY_P="${P/_/.}"
+MY_PV12=$(get_version_component_range 1-2 ${PV})
+S="${WORKDIR}/${MY_P}"
+SIEVE="dovecot-sieve-1.1.4"
+SIEVE_S="${WORKDIR}/${SIEVE}"
+MANAGESIEVE_PATCH="managesieve-0.10.1"
+MANAGESIEVE="managesieve-0.10.1"
+MANAGESIEVE_S="${WORKDIR}/${PN}-${MY_PV12}-${MANAGESIEVE}"
+
+SRC_URI="http://dovecot.org/releases/${MY_PV12}/rc/${MY_P}.tar.gz
+sieve? ( http://dovecot.org/releases/sieve/${SIEVE}.tar.gz )
+managesieve? ( http://www.rename-it.nl/${PN}/${MY_PV12}/${MY_P}-${MANAGESIEVE_PATCH}.diff.gz
+http://www.rename-it.nl/${PN}/${MY_PV12}/${PN}-${MY_PV12}-${MANAGESIEVE}.tar.gz )"
+
+DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
+HOMEPAGE="http://www.dovecot.org/"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="-* ~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug doc ipv6 kerberos ldap managesieve mbox mysql pop3d pam postgres sieve ssl suid vpopmail"
+
+# Developer documentation, controlled by the doc USE flag
+DEVDOCS="auth-protocol index multiaccess securecoding"
+
+DEPEND=">=sys-apps/sed-4
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )
+ postgres? ( dev-db/postgresql )
+ mysql? ( virtual/mysql )
+ vpopmail? ( net-mail/vpopmail )"
+
+RDEPEND="${DEPEND}
+ >=net-mail/mailbase-0.00-r8"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # http://hg.dovecot.org/dovecot-1.1/rev/7e27d67d3abe
+ epatch "${FILESDIR}"/${P}-body.patch
+ if use managesieve; then
+ epatch "${WORKDIR}"/${MY_P}-${MANAGESIEVE_PATCH}.diff
+ eautoreconf
+ fi
+}
+
+pkg_setup() {
+ if ! use sieve && use managesieve; then
+ eerror "managesieve USE flag selected but sieve USE flag unselected"
+ die "USE flag problem"
+ fi
+ # Add user and group for login process (same as for fedora/redhat)
+ enewgroup dovecot 97
+ enewuser dovecot 97 -1 /dev/null dovecot
+}
+
+src_compile() {
+ local myconf=
+ use ssl && myconf="${myconf} --with-ssl=openssl" \
+ || myconf="${myconf} --without-ssl"
+ econf \
+ --localstatedir=/var \
+ --sysconfdir=/etc/dovecot \
+ --enable-header-install \
+ --with-ioloop=best \
+ --with-poll=best \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with kerberos gssapi) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with pam) \
+ $(use_with pop3d) \
+ $(use_with postgres pgsql) \
+ $(use_with vpopmail) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die "make failed"
+
+ if use sieve; then
+ einfo "Building sieve"
+ cd "${SIEVE_S}"
+ econf --with-dovecot="${S}" || die "configure failed (sieve)"
+ emake || die "make failed (sieve)"
+ fi
+
+ if use managesieve; then
+ einfo "Building managesieve"
+ cd "${MANAGESIEVE_S}"
+ econf --with-dovecot="${S}" --with-dovecot-sieve="${SIEVE_S}" \
+ || die "configure failed (managesieve)"
+ emake || die "make failed (managesieve)"
+ fi
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ use suid && fperms u+s /usr/libexec/dovecot/deliver
+
+ rm -f "${D}"/etc/dovecot/dovecot-{ldap,sql}-example.conf
+
+ newinitd "${FILESDIR}"/dovecot.init dovecot
+
+ # Documentation
+ rm -rf "${D}"/usr/share/doc/dovecot
+ dodoc AUTHORS NEWS README TODO dovecot-example.conf
+ use managesieve && newdoc ${MANAGESIEVE_S}/README README.managesieve
+ if use doc; then
+ dodoc doc/*.txt
+ else
+ local x= n=
+ for x in doc/*.txt; do
+ n=$(basename "${x}" .txt)
+ [[ " ${DEVDOCS} " != *" ${n} "* ]] && dodoc "${x}"
+ done
+ fi
+
+ # Create the dovecot.conf file from the dovecot-example.conf file that
+ # the dovecot folks nicely left for us....
+ local conf="${D}/etc/dovecot/dovecot.conf"
+ mv "${D}"/etc/dovecot/dovecot-example.conf "${D}"/etc/dovecot/dovecot.conf
+
+ # .maildir is the Gentoo default, but we need to support mbox to
+ local mail_location="maildir:~/.maildir"
+ if use mbox; then
+ mail_location="mbox:/var/spool/mail/%u:INDEX=/var/dovecot/%u"
+ keepdir /var/dovecot
+ sed -i -e 's|#mail_extra_groups =|mail_extra_groups = mail|' "${conf}"
+ fi
+ sed -i -e \
+ "s|#mail_location =|mail_location = ${mail_location}|" "${conf}" \
+ || die "failed to update mail location settings in dovecot.conf"
+
+ # We're using pam files (imap and pop3) provided by mailbase
+ if use pam; then
+ sed -i -e '/passdb pam/, /^[ \t]*}/ s|#args = dovecot|args = "\*"|' \
+ "${conf}" || die "failed to update PAM settings in dovecot.conf"
+ fi
+
+ # Listen on ipv6 and ipv4
+ if use ipv6; then
+ sed -i -e 's/^#listen = \*/listen = \[::\]/g' "${conf}" \
+ || die "failed to update listen settings in dovecot.conf"
+ fi
+
+ # Update ssl cert locations
+ if use ssl; then
+ sed -i -e 's,^#ssl_cert_file =.*,ssl_cert_file = /etc/ssl/dovecot/server.pem,' \
+ -e 's,^#ssl_key_file =.*,ssl_key_file = /etc/ssl/dovecot/server.key,' \
+ "${conf}" || die "failed to update SSL settings in dovecot.conf"
+ fi
+
+ # Install SQL configuration
+ if use mysql || use postgres; then
+ cp doc/dovecot-sql-example.conf "${D}"/etc/dovecot/dovecot-sql.conf
+ fperms 600 /etc/dovecot/dovecot-sql.conf
+ sed -i -e '/db sql/,/args/ s|=|= /etc/dovecot-sql.conf|' "${conf}" \
+ || die "failed to update SQL settings in dovecot-sql.conf"
+ dodoc doc/dovecot-sql-example.conf
+ fi
+
+ # Install LDAP configuration
+ if use ldap; then
+ cp doc/dovecot-ldap-example.conf "${D}"/etc/dovecot/dovecot-ldap.conf
+ fperms 600 /etc/dovecot/dovecot-ldap.conf
+ sed -i -e '/db ldap/,/args/ s|=|= /etc/dovecot-ldap.conf|' "${conf}" \
+ || die "failed to update LDAP settings in dovecot-ldap.conf"
+ dodoc doc/dovecot-ldap-example.conf
+ fi
+
+ # Install sieve plugin
+ if use sieve; then
+ make -C "${SIEVE_S}" DESTDIR="${D}" install \
+ || die "make install failed (sieve)"
+ fi
+
+ # Install managesieve
+ if use managesieve; then
+ make -C "${MANAGESIEVE_S}" DESTDIR="${D}" install \
+ || die "make install failed (managesieve)"
+ fi
+
+ dodir /var/run/dovecot
+ fowners root:0 /var/run/dovecot
+ fperms 0755 /var/run/dovecot
+ keepdir /var/run/dovecot/login
+ fowners root:dovecot /var/run/dovecot/login
+ fperms 0750 /var/run/dovecot/login
+}
+
+get_config_var() {
+ local varname=${1}
+ if [[ -z ${varname} ]]; then
+ die "${FUNCNAME}: variable name missing"
+ fi
+ sed -n 's/^[[:space:]]\?'"${varname}"'[[:space:]]*="*\([^#"]\+\)"*/\1/p' \
+ "${ROOT}"/etc/dovecot/dovecot.conf
+}
+
+pkg_postinst() {
+ elog "The Dovecot configuration has vastly changed since 0.99."
+ elog "You are encouraged to start afresh with a new configuration file."
+ elog "see http://wiki.dovecot.org/ for configuration examples."
+
+ if [[ -e "${ROOT}"/etc/dovecot.conf ]]; then
+ echo
+ ewarn "The Dovecot configuration now resides in ${ROOT}/etc/dovecot"
+ fi
+
+ local base_dir="$(get_config_var base_dir)"
+ base_dir="${base_dir:-/var/run/dovecot}"
+ if use ssl; then
+ # Let's not make a new certificate if we already have one
+ if ! [[ -e "${ROOT}"/etc/ssl/dovecot/server.pem && \
+ -e "${ROOT}"/etc/ssl/dovecot/server.key ]]; then
+ einfo "Creating SSL certificate"
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-Dovecot IMAP Server}"
+ install_cert /etc/ssl/dovecot/server
+ chown dovecot:mail "${ROOT}"/etc/ssl/dovecot/server.{key,pem}
+ fi
+ if [[ ! -e "${ROOT}${base_dir}/login/ssl-parameters.dat" ]]; then
+ echo
+ elog "Dovecot requires DH SSL Parameters if you use SSL connections"
+ elog "These take some time to make, and dovecot will create them before"
+ elog "it allows any SSL connections."
+ elog "You can create them now before starting dovecot like so"
+ elog " emerge --config =${PF}"
+ fi
+ fi
+}
+
+pkg_config() {
+ local base_dir="$(get_config_var base_dir)"
+ base_dir="${base_dir:-/var/run/dovecot}"
+
+ if use ssl; then
+ einfo "Regenerating SSL parameters. This will take some time."
+ "${ROOT}"/usr/libexec/dovecot/ssl-build-param "${base_dir}/login/ssl-parameters.dat"
+ fi
+}
diff --git a/net-mail/dovecot/files/dovecot-1.0.13-body.patch b/net-mail/dovecot/files/dovecot-1.0.13-body.patch
new file mode 100644
index 000000000000..3b134e2947a1
--- /dev/null
+++ b/net-mail/dovecot/files/dovecot-1.0.13-body.patch
@@ -0,0 +1,24 @@
+
+# HG changeset patch
+# User Timo Sirainen <tss@iki.fi>
+# Date 1205200413 -7200
+# Node ID 538f8892a2f159eb156808f037a0ed90e14ccd14
+# Parent 975d78cadc1ed50adc9cd97b8b19faffb36b14fe
+BODY/BODYSTRUCTURE fetch: Don't crash if we already had message parts
+parsed.
+
+--- a/src/lib-storage/index/index-mail.c Sun Mar 09 12:50:15 2008 +0200
++++ b/src/lib-storage/index/index-mail.c Tue Mar 11 03:53:33 2008 +0200
+@@ -569,9 +569,8 @@ static void index_mail_parse_bodystructu
+ i_assert(data->parts->next == NULL);
+
+ old_offset = data->stream->v_offset;
+- i_stream_seek(data->stream,
+- data->hdr_size.physical_size);
+- message_parse_from_parts(data->parts->children,
++ i_stream_seek(data->stream, 0);
++ message_parse_from_parts(data->parts,
+ data->stream,
+ parse_bodystructure_part_header,
+ mail->data_pool);
+
diff --git a/net-mail/dovecot/files/dovecot-1.1_rc3-body.patch b/net-mail/dovecot/files/dovecot-1.1_rc3-body.patch
new file mode 100644
index 000000000000..ba684998a395
--- /dev/null
+++ b/net-mail/dovecot/files/dovecot-1.1_rc3-body.patch
@@ -0,0 +1,128 @@
+
+# HG changeset patch
+# User Timo Sirainen <tss@iki.fi>
+# Date 1205222885 -7200
+# Node ID 7e27d67d3abe53e004a761abe91d76e105c90c21
+# Parent 81994d76fd2467e5c871d3a2ad32b1ecee3d1dcf
+BODY/BODYSTRUCTURE may have been returned as NULL in some situations.
+
+--- a/src/lib-storage/index/index-mail.c Tue Mar 11 09:08:50 2008 +0200
++++ b/src/lib-storage/index/index-mail.c Tue Mar 11 10:08:05 2008 +0200
+@@ -566,17 +566,14 @@ index_mail_body_parsed_cache_bodystructu
+ mail_cache_field_want_add(mail->trans->cache_trans,
+ data->seq, cache_field_bodystructure);
+ }
+- if (field == MAIL_CACHE_IMAP_BODYSTRUCTURE || cache_bodystructure) {
++ if (cache_bodystructure) {
+ str = str_new(mail->data_pool, 128);
+ imap_bodystructure_write(data->parts, str, TRUE);
+ data->bodystructure = str_c(str);
+
+- if (cache_bodystructure) {
+- index_mail_cache_add(mail,
+- MAIL_CACHE_IMAP_BODYSTRUCTURE,
+- str_c(str), str_len(str)+1);
+- bodystructure_cached = TRUE;
+- }
++ index_mail_cache_add(mail, MAIL_CACHE_IMAP_BODYSTRUCTURE,
++ str_c(str), str_len(str)+1);
++ bodystructure_cached = TRUE;
+ } else {
+ bodystructure_cached =
+ mail_cache_field_exists(mail->trans->cache_view,
+@@ -601,15 +598,13 @@ index_mail_body_parsed_cache_bodystructu
+ data->seq, cache_field_body);
+ }
+
+- if (field == MAIL_CACHE_IMAP_BODY || cache_body) {
++ if (cache_body) {
+ str = str_new(mail->data_pool, 128);
+ imap_bodystructure_write(data->parts, str, FALSE);
+ data->body = str_c(str);
+
+- if (cache_body) {
+- index_mail_cache_add(mail, MAIL_CACHE_IMAP_BODY,
+- str_c(str), str_len(str)+1);
+- }
++ index_mail_cache_add(mail, MAIL_CACHE_IMAP_BODY,
++ str_c(str), str_len(str)+1);
+ }
+ }
+
+@@ -841,25 +836,47 @@ static int index_mail_parse_bodystructur
+ enum index_cache_field field)
+ {
+ struct index_mail_data *data = &mail->data;
++ string_t *str;
+
+ if (data->parsed_bodystructure) {
+ /* we have everything parsed already, but just not written to
+ a string */
+ index_mail_body_parsed_cache_bodystructure(mail, field);
+- return 0;
+- }
+-
+- if (data->save_bodystructure_header ||
+- !data->save_bodystructure_body) {
+- /* we haven't parsed the header yet */
+- data->save_bodystructure_header = TRUE;
+- data->save_bodystructure_body = TRUE;
+- (void)get_cached_parts(mail);
+- if (index_mail_parse_headers(mail, NULL) < 0)
++ } else {
++ if (data->save_bodystructure_header ||
++ !data->save_bodystructure_body) {
++ /* we haven't parsed the header yet */
++ data->save_bodystructure_header = TRUE;
++ data->save_bodystructure_body = TRUE;
++ (void)get_cached_parts(mail);
++ if (index_mail_parse_headers(mail, NULL) < 0)
++ return -1;
++ }
++
++ if (index_mail_parse_body(mail, field) < 0)
+ return -1;
+ }
+-
+- return index_mail_parse_body(mail, field);
++ /* if we didn't want to have the body(structure) cached,
++ it's still not written. */
++ switch (field) {
++ case MAIL_CACHE_IMAP_BODY:
++ if (data->body == NULL) {
++ str = str_new(mail->data_pool, 128);
++ imap_bodystructure_write(data->parts, str, FALSE);
++ data->body = str_c(str);
++ }
++ break;
++ case MAIL_CACHE_IMAP_BODYSTRUCTURE:
++ if (data->bodystructure == NULL) {
++ str = str_new(mail->data_pool, 128);
++ imap_bodystructure_write(data->parts, str, TRUE);
++ data->bodystructure = str_c(str);
++ }
++ break;
++ default:
++ i_unreached();
++ }
++ return 0;
+ }
+
+ static void
+@@ -932,6 +949,7 @@ int index_mail_get_special(struct mail *
+ MAIL_CACHE_IMAP_BODY) < 0)
+ return -1;
+ }
++ i_assert(data->body != NULL);
+ *value_r = data->body;
+ return 0;
+ }
+@@ -960,6 +978,7 @@ int index_mail_get_special(struct mail *
+ MAIL_CACHE_IMAP_BODYSTRUCTURE) < 0)
+ return -1;
+ }
++ i_assert(data->bodystructure != NULL);
+ *value_r = data->bodystructure;
+ return 0;
+ }
+