summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-04-24 09:51:50 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-04-24 09:51:50 +0000
commit7da04c27f8c540ca95129a9f15cab95124df4653 (patch)
tree6e48b6d285787d72dc1190b12429213e243677e7 /net-mail
parentUpdate to use mirror://. (diff)
downloadgentoo-2-7da04c27f8c540ca95129a9f15cab95124df4653.tar.gz
gentoo-2-7da04c27f8c540ca95129a9f15cab95124df4653.tar.bz2
gentoo-2-7da04c27f8c540ca95129a9f15cab95124df4653.zip
Synced ebuilds structures between notmuch-0.10.2-r3 and notmuch-0.11-r3 and in
result dropped autotools-utils usage in notmuch-0.10.2 and added nmbug script installation. (Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/ChangeLog8
-rw-r--r--net-mail/notmuch/notmuch-0.10.2-r3.ebuild27
-rw-r--r--net-mail/notmuch/notmuch-0.11.1-r3.ebuild11
3 files changed, 33 insertions, 13 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index 530e3e2dd269..c792a5ea697d 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.43 2012/04/24 09:30:17 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.44 2012/04/24 09:51:50 aidecoe Exp $
+
+ 24 Apr 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> notmuch-0.10.2-r3.ebuild,
+ notmuch-0.11.1-r3.ebuild:
+ Synced ebuilds structures between notmuch-0.10.2-r3 and notmuch-0.11-r3 and in
+ result dropped autotools-utils usage in notmuch-0.10.2 and added nmbug script
+ installation.
*notmuch-0.11.1-r3 (24 Apr 2012)
*notmuch-0.10.2-r3 (24 Apr 2012)
diff --git a/net-mail/notmuch/notmuch-0.10.2-r3.ebuild b/net-mail/notmuch/notmuch-0.10.2-r3.ebuild
index 87fdabfbf322..63ce34de4966 100644
--- a/net-mail/notmuch/notmuch-0.10.2-r3.ebuild
+++ b/net-mail/notmuch/notmuch-0.10.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.10.2-r3.ebuild,v 1.1 2012/04/24 09:30:17 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.10.2-r3.ebuild,v 1.2 2012/04/24 09:51:50 aidecoe Exp $
EAPI=4
@@ -8,8 +8,7 @@ PYTHON_DEPEND="python? 2:2.6"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.[45] 3.*"
-inherit elisp-common pax-utils distutils
-inherit autotools-utils
+inherit elisp-common eutils pax-utils distutils
DESCRIPTION="The mail indexer"
HOMEPAGE="http://notmuchmail.org/"
@@ -19,7 +18,8 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
REQUIRED_USE="test? ( crypt emacs python )"
-IUSE="bash-completion crypt debug doc emacs python test vim zsh-completion"
+IUSE="bash-completion crypt debug doc emacs nmbug python test vim
+ zsh-completion"
CDEPEND="
>=dev-libs/glib-2.22
@@ -38,6 +38,7 @@ DEPEND="${CDEPEND}
"
RDEPEND="${CDEPEND}
crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git virtual/perl-File-Temp virtual/perl-PodParser )
zsh-completion? ( app-shells/zsh )
"
@@ -50,7 +51,7 @@ PATCHES=(
)
DOCS=( AUTHORS NEWS README TODO )
SITEFILE="50${PN}-gentoo.el"
-MY_LD_LIBRARY_PATH="${WORKDIR}/${P}_build/lib"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
bindings() {
if use $1; then
@@ -69,7 +70,11 @@ pkg_setup() {
}
src_prepare() {
- autotools-utils_src_prepare
+ local p
+ for p in "${PATCHES[@]}"; do
+ epatch "${p}"
+ done
+ default
bindings python distutils_src_prepare
}
@@ -83,11 +88,11 @@ src_configure() {
$(use_with emacs)
$(use_with zsh-completion)
)
- autotools-utils_src_configure
+ econf "${myeconfargs[@]}"
}
src_compile() {
- autotools-utils_src_compile
+ default
bindings python distutils_src_compile
if use doc; then
@@ -109,12 +114,16 @@ src_test() {
}
src_install() {
- autotools-utils_src_install
+ default
if use emacs; then
elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
fi
+ if use nmbug; then
+ dobin contrib/nmbug
+ fi
+
if use vim; then
insinto /usr/share/vim/vimfiles
doins -r vim/plugin vim/syntax
diff --git a/net-mail/notmuch/notmuch-0.11.1-r3.ebuild b/net-mail/notmuch/notmuch-0.11.1-r3.ebuild
index a702db9198c7..de5adba6744a 100644
--- a/net-mail/notmuch/notmuch-0.11.1-r3.ebuild
+++ b/net-mail/notmuch/notmuch-0.11.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.11.1-r3.ebuild,v 1.1 2012/04/24 09:30:17 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.11.1-r3.ebuild,v 1.2 2012/04/24 09:51:50 aidecoe Exp $
EAPI=4
@@ -42,6 +42,9 @@ RDEPEND="${CDEPEND}
zsh-completion? ( app-shells/zsh )
"
+PATCHES=(
+ "${FILESDIR}/${PV}-build-with-gmime-2.4-only.patch"
+ )
DOCS=( AUTHORS NEWS README )
SITEFILE="50${PN}-gentoo.el"
MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
@@ -63,8 +66,10 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/${PV}-build-with-gmime-2.4-only.patch"
-
+ local p
+ for p in "${PATCHES[@]}"; do
+ epatch "${p}"
+ done
default
bindings python distutils_src_prepare
}