summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-05-31 15:38:47 +0000
committerRoy Marples <uberlord@gentoo.org>2006-05-31 15:38:47 +0000
commit5fe2d29cfc0df638735d69a8b0395ec05319c7a0 (patch)
treea1a2ef3a1710984f907bd6b0329c02450de6bce5 /net-mail
parentStable on sparc wrt #135046 (diff)
downloadgentoo-2-5fe2d29cfc0df638735d69a8b0395ec05319c7a0.tar.gz
gentoo-2-5fe2d29cfc0df638735d69a8b0395ec05319c7a0.tar.bz2
gentoo-2-5fe2d29cfc0df638735d69a8b0395ec05319c7a0.zip
Enable epoll, inotify and kqueue depending on installation environment
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot/ChangeLog8
-rw-r--r--net-mail/dovecot/dovecot-1.0_beta8-r1.ebuild23
2 files changed, 18 insertions, 13 deletions
diff --git a/net-mail/dovecot/ChangeLog b/net-mail/dovecot/ChangeLog
index e082d740bdd8..435397ffbdf0 100644
--- a/net-mail/dovecot/ChangeLog
+++ b/net-mail/dovecot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/dovecot
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.48 2006/05/30 14:45:08 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.49 2006/05/31 15:38:47 uberlord Exp $
+
+ 31 May 2006; Roy Marples <uberlord@gentoo.org>
+ dovecot-1.0_beta8-r1.ebuild:
+ For Linux we now enable epoll
+ Also we enable inotify if we have >=glibc-2.4
+ For FreeBSD we now enable kqueue by default
*dovecot-1.0_beta8-r1 (30 May 2006)
diff --git a/net-mail/dovecot/dovecot-1.0_beta8-r1.ebuild b/net-mail/dovecot/dovecot-1.0_beta8-r1.ebuild
index 4e99e50ba02b..b8454a5efc84 100644
--- a/net-mail/dovecot/dovecot-1.0_beta8-r1.ebuild
+++ b/net-mail/dovecot/dovecot-1.0_beta8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0_beta8-r1.ebuild,v 1.1 2006/05/30 14:45:08 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0_beta8-r1.ebuild,v 1.2 2006/05/31 15:38:47 uberlord Exp $
inherit eutils
@@ -39,17 +39,16 @@ src_compile() {
use ssl && myconf="${myconf} --with-ssl=openssl" \
|| myconf="${myconf} --without-ssl"
-# Enable when linux-headers-2.6.13 hits portage for inotify
-# or epoll gets more stable.
-#
-# # Enable Linux only features
-# if [[ ${KERNEL} == "linux" ]] ; then
-# # epoll is too unstable
-# # myconf="${myconf} --with-ioloop=epoll"
-# if has_version ">=sys-kernel/linux-headers-2.6.13" ; then
-# myconf="${myconf} --with-notify=inotify"
-# fi
-# fi
+ # Enable Linux or FreeBSD only features
+ if use kernel_linux ; then
+ myconf="${myconf} --with-ioloop=epoll"
+ if has_version ">=sys-libs/glibc-2.4" ; then
+ myconf="${myconf} --with-notify=inotify"
+ fi
+ elif use kernel_FreeBSD ; then
+ myconf="${myconf} --with-ioloop=kqueue"
+ myconf="${myconf} --with-notify=kqueue"
+ fi
econf --localstatedir=/var \
$(use_enable debug) \