summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2007-05-15 11:44:12 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2007-05-15 11:44:12 +0000
commit4c6f07a7af593057fb177a1871cd1515856af897 (patch)
tree6761b57e2f6fbb3edf3cfa1f0778189bdb420a76 /net-mail
parentAdding to ~amd64 (diff)
downloadgentoo-2-4c6f07a7af593057fb177a1871cd1515856af897.tar.gz
gentoo-2-4c6f07a7af593057fb177a1871cd1515856af897.tar.bz2
gentoo-2-4c6f07a7af593057fb177a1871cd1515856af897.zip
added 2.2.5 rc2 and took maintainership
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dbmail/ChangeLog8
-rw-r--r--net-mail/dbmail/dbmail-2.2.5_rc2.ebuild101
-rw-r--r--net-mail/dbmail/files/digest-dbmail-2.2.5_rc23
-rw-r--r--net-mail/dbmail/metadata.xml4
4 files changed, 113 insertions, 3 deletions
diff --git a/net-mail/dbmail/ChangeLog b/net-mail/dbmail/ChangeLog
index ecc022ca1b68..3791b3f46b4f 100644
--- a/net-mail/dbmail/ChangeLog
+++ b/net-mail/dbmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/dbmail
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.2 2007/04/17 14:36:43 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.3 2007/05/15 11:44:12 lordvan Exp $
+
+*dbmail-2.2.5_rc2 (15 May 2007)
+
+ 15 May 2007; Thomas Raschbacher <lordvan@gentoo.org> metadata.xml,
+ +dbmail-2.2.5_rc2.ebuild:
+ added 2.2.5 rc2 and took maintainership as mentioned by ticho in bug #22331
17 Apr 2007; Christian Faulhammer <opfer@gentoo.org> dbmail-2.2.4.ebuild:
keyworded ~amd64, bug 172696
diff --git a/net-mail/dbmail/dbmail-2.2.5_rc2.ebuild b/net-mail/dbmail/dbmail-2.2.5_rc2.ebuild
new file mode 100644
index 000000000000..6a2736ce78bf
--- /dev/null
+++ b/net-mail/dbmail/dbmail-2.2.5_rc2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.2.5_rc2.ebuild,v 1.1 2007/05/15 11:44:12 lordvan Exp $
+
+inherit eutils
+
+MY_P="${P/_/}" # for rcX
+#MY_P="${P}" # releases
+DESCRIPTION="A mail storage and retrieval daemon that uses MySQL or PostgreSQL as its data store"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/2.2/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres sieve sqlite3 ssl static"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ postgres? ( >=dev-db/postgresql-7.4 )
+ mysql? ( >=virtual/mysql-4.1 )
+ sqlite3? ( >=dev-db/sqlite-3.0 )
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ app-text/asciidoc
+ app-text/xmlto
+ sys-libs/zlib
+ >=dev-libs/gmime-2.1.18
+ >=dev-libs/glib-2.8"
+
+S=${WORKDIR}/${P/_/-}
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_compile() {
+ use sqlite3 && myconf="--with-sqlite"
+ use ldap && myconf=${myconf}" --with-auth-ldap"
+
+ econf \
+ --sysconfdir=/etc/dbmail \
+ ${myconf} \
+ $(use_enable static) \
+ $(use_with sieve) \
+ $(use_with ssl) \
+ $(use_with postgres pgsql) \
+ $(use_with mysql) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS UPGRADING ChangeLog README* INSTALL* NEWS THANKS
+ dodoc sql/mysql/*
+ dodoc sql/postgresql/*
+ dodoc sql/sqlite/*
+
+ cp dbmail.conf.dist dbmail.conf
+ sed -i -e "s:nobody:dbmail:" dbmail.conf
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf
+ #sed -i -e "s:#library_directory:library_directory:" dbmail.conf
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ newinitd "${FILESDIR}"/dbmail-imapd.initd dbmail-imapd
+ newinitd "${FILESDIR}"/dbmail-lmtpd.initd dbmail-lmtpd
+ newinitd "${FILESDIR}"/dbmail-pop3d.initd dbmail-pop3d
+ use sieve && newinitd "${FILESDIR}"/dbmail-timsieved.initd dbmail-timsieved
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+
+}
+
+pkg_postinst() {
+ elog "Please read /usr/share/doc/${PF}/INSTALL.gz"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+ echo
+ elog "Please make sure to run etc-update."
+ elog "If you get an error message about plugins not found"
+ elog "please add the library_directory configuration switch to"
+ elog "dbmail.conf and set it to the correct path"
+ elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
+ elog "A sample can be found in dbmail.conf.dist after etc-update."
+}
diff --git a/net-mail/dbmail/files/digest-dbmail-2.2.5_rc2 b/net-mail/dbmail/files/digest-dbmail-2.2.5_rc2
new file mode 100644
index 000000000000..bba303c6f3ee
--- /dev/null
+++ b/net-mail/dbmail/files/digest-dbmail-2.2.5_rc2
@@ -0,0 +1,3 @@
+MD5 db20bf6a04ae5d78eaf74d8c0142ffce dbmail-2.2.5rc2.tar.gz 879242
+RMD160 918394e580fb0f3bd0d36f387d4dc156ba5a8ef0 dbmail-2.2.5rc2.tar.gz 879242
+SHA256 58aec2309a1a7827ef36847aac25af04af081e2443f9df360411d2a1e727d14a dbmail-2.2.5rc2.tar.gz 879242
diff --git a/net-mail/dbmail/metadata.xml b/net-mail/dbmail/metadata.xml
index 8632ece5bedf..055a37d3cbf5 100644
--- a/net-mail/dbmail/metadata.xml
+++ b/net-mail/dbmail/metadata.xml
@@ -3,8 +3,8 @@
<pkgmetadata>
<herd>net-mail</herd>
<maintainer>
- <email>ticho@gentoo.org</email>
- <name>Andrej Kacian</name>
+ <email>lordvan@gentoo.org</email>
+ <name>Thomas Raschbacher</name>
</maintainer>
<longdescription>Dbmail is the name of a group of programs that enable the possiblilty of storing and retrieving mail messages from a database. Currently MySQL, PostgreSQL and SQLite can be used as database backends.</longdescription>
</pkgmetadata>