summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-30 20:08:13 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-30 20:08:13 +0000
commit41f286e2a49958c790da6ad8e66f21d24381e8e5 (patch)
treebe962e11d3e38cfd1ba3df412e3b8ca23fc0dc13 /net-mail
parentMerge stable keywords from -r1; Drop old. (diff)
downloadgentoo-2-41f286e2a49958c790da6ad8e66f21d24381e8e5.tar.gz
gentoo-2-41f286e2a49958c790da6ad8e66f21d24381e8e5.tar.bz2
gentoo-2-41f286e2a49958c790da6ad8e66f21d24381e8e5.zip
Add dep on dev-perl/File-Copy-Recursive (bug #497474).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/imapsync/ChangeLog7
-rw-r--r--net-mail/imapsync/imapsync-1.584-r1.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/net-mail/imapsync/ChangeLog b/net-mail/imapsync/ChangeLog
index 8f4a7a34fbb2..c9cc3680cbb0 100644
--- a/net-mail/imapsync/ChangeLog
+++ b/net-mail/imapsync/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/imapsync
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/ChangeLog,v 1.89 2014/02/14 07:35:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/ChangeLog,v 1.90 2014/04/30 20:08:13 radhermit Exp $
+
+*imapsync-1.584-r1 (30 Apr 2014)
+
+ 30 Apr 2014; Tim Harder <radhermit@gentoo.org> +imapsync-1.584-r1.ebuild:
+ Add dep on dev-perl/File-Copy-Recursive (bug #497474).
*imapsync-1.584 (14 Feb 2014)
diff --git a/net-mail/imapsync/imapsync-1.584-r1.ebuild b/net-mail/imapsync/imapsync-1.584-r1.ebuild
new file mode 100644
index 000000000000..8aae4bc9a85e
--- /dev/null
+++ b/net-mail/imapsync/imapsync-1.584-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/imapsync-1.584-r1.ebuild,v 1.1 2014/04/30 20:08:13 radhermit Exp $
+
+EAPI=5
+
+DESCRIPTION="A tool allowing incremental and recursive imap transfer from one mailbox to another"
+HOMEPAGE="http://ks.lamiral.info/imapsync/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tgz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/Digest-HMAC
+ dev-perl/File-Copy-Recursive
+ dev-perl/IO-Socket-SSL
+ dev-perl/Mail-IMAPClient
+ dev-perl/TermReadKey
+ virtual/perl-Digest-MD5
+ virtual/perl-MIME-Base64"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -e "s/^install: testp/install:/" \
+ -e "/^DO_IT/,/^$/d" \
+ -i "${S}"/Makefile || die
+}
+
+src_compile() { :; }