summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2014-09-17 12:48:05 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2014-09-17 12:48:05 +0000
commit0a2efbf6b6df503443ed0556892708c9bdd1a09d (patch)
tree83d4d00008786931bddd19463179e467d5911488 /net-mail
parentStable for sparc, wrt bug #522184 (diff)
downloadgentoo-2-0a2efbf6b6df503443ed0556892708c9bdd1a09d.tar.gz
gentoo-2-0a2efbf6b6df503443ed0556892708c9bdd1a09d.tar.bz2
gentoo-2-0a2efbf6b6df503443ed0556892708c9bdd1a09d.zip
Removed automx-0.10.1.ebuild. Added DISTUTILS_SINGLE_IMPL=1 to 0.10.2 to fix installation with mod_wsgi
(Portage version: 2.2.12-r1/cvs/Linux x86_64, signed Manifest commit with key 0x296C6CCA35A64134)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/automx/ChangeLog7
-rw-r--r--net-mail/automx/automx-0.10.1.ebuild62
-rw-r--r--net-mail/automx/automx-0.10.2.ebuild3
3 files changed, 8 insertions, 64 deletions
diff --git a/net-mail/automx/ChangeLog b/net-mail/automx/ChangeLog
index a8ba085c312f..03c28dfaf429 100644
--- a/net-mail/automx/ChangeLog
+++ b/net-mail/automx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/automx
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/automx/ChangeLog,v 1.13 2014/04/27 20:58:21 mschiff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/automx/ChangeLog,v 1.14 2014/09/17 12:48:05 mschiff Exp $
+
+ 17 Sep 2014; Marc Schiffbauer <mschiff@gentoo.org> -automx-0.10.1.ebuild,
+ automx-0.10.2.ebuild:
+ Removed automx-0.10.1.ebuild. Added DISTUTILS_SINGLE_IMPL=1 to 0.10.2 to fix
+ installation with mod_wsgi
*automx-0.10.2 (27 Apr 2014)
diff --git a/net-mail/automx/automx-0.10.1.ebuild b/net-mail/automx/automx-0.10.1.ebuild
deleted file mode 100644
index b906cae69828..000000000000
--- a/net-mail/automx/automx-0.10.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/automx/automx-0.10.1.ebuild,v 1.1 2014/02/02 23:28:34 mschiff Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A mail user agent auto configuration service"
-HOMEPAGE="http://www.automx.org"
-SRC_URI="https://github.com/sys4/${PN}/archive/v${PV}.tar.gz -> automx-${PV}.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ldap memcached sql +tools"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="
- ${DEPEND}
- dev-python/ipaddr[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- || ( www-apache/mod_wsgi[${PYTHON_USEDEP}] www-servers/uwsgi )
- ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
- memcached? ( dev-python/python-memcached )
- sql? ( dev-python/sqlalchemy[${PYTHON_USEDEP}] )
- tools? ( net-dns/bind-tools net-misc/wget )
- "
-
-src_prepare() {
- sed -i '/py_modules=/d' setup.py
-}
-
-src_install() {
- distutils-r1_src_install
-
- dodoc INSTALL CREDITS CHANGES BASIC_CONFIGURATION_README
- dohtml -r doc/html/*
-
- docinto examples
- dodoc src/conf/*example*
-
- doman doc/man/man5/*
-
- if use tools; then
- exeinto /usr/bin
- doexe src/automx-test
- doman doc/man/man1/automx-test.1
- fi
-
- exeinto /usr/lib/${PN}
- doexe src/automx_wsgi.py
-}
-
-pkg_postinst() {
- einfo
- einfo "See /usr/share/doc/${PF}/INSTALL.bz2 for setup instructions"
- einfo
-}
diff --git a/net-mail/automx/automx-0.10.2.ebuild b/net-mail/automx/automx-0.10.2.ebuild
index e7a98648f2b0..61955238541d 100644
--- a/net-mail/automx/automx-0.10.2.ebuild
+++ b/net-mail/automx/automx-0.10.2.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/automx/automx-0.10.2.ebuild,v 1.1 2014/04/27 20:58:21 mschiff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/automx/automx-0.10.2.ebuild,v 1.2 2014/09/17 12:48:05 mschiff Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
+DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1