summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-12 09:43:58 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-12 09:43:58 +0000
commit4a8e24370a961fe94ac1d14b8929886415791a63 (patch)
tree9f8f6d6b9362e3f9a9555d03b13680088519d627 /net-mail/smtptools
parentStable on ppc. Bug 123615 (diff)
downloadgentoo-2-4a8e24370a961fe94ac1d14b8929886415791a63.tar.gz
gentoo-2-4a8e24370a961fe94ac1d14b8929886415791a63.tar.bz2
gentoo-2-4a8e24370a961fe94ac1d14b8929886415791a63.zip
Fix building with newer gcc versions and cleanup implicit warnings that hate 64bit hosts.
(Portage version: 2.1_pre6)
Diffstat (limited to 'net-mail/smtptools')
-rw-r--r--net-mail/smtptools/ChangeLog9
-rw-r--r--net-mail/smtptools/files/smtptools-0.2.3-cleanups.patch61
-rw-r--r--net-mail/smtptools/smtptools-0.2.3.ebuild12
3 files changed, 78 insertions, 4 deletions
diff --git a/net-mail/smtptools/ChangeLog b/net-mail/smtptools/ChangeLog
index de4da9b4de04..9ea7347ebdec 100644
--- a/net-mail/smtptools/ChangeLog
+++ b/net-mail/smtptools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/smtptools
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/smtptools/ChangeLog,v 1.2 2004/12/13 23:24:16 ticho Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/smtptools/ChangeLog,v 1.3 2006/03/12 09:43:58 vapier Exp $
+
+ 12 Mar 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/smtptools-0.2.3-cleanups.patch, smtptools-0.2.3.ebuild:
+ Fix building with newer gcc versions and cleanup implicit warnings that hate
+ 64bit hosts.
14 Dec 2004; Andrej Kacian <ticho@gentoo.org> smtptools-0.2.3.ebuild:
Stable on x86.
diff --git a/net-mail/smtptools/files/smtptools-0.2.3-cleanups.patch b/net-mail/smtptools/files/smtptools-0.2.3-cleanups.patch
new file mode 100644
index 000000000000..6873cf390255
--- /dev/null
+++ b/net-mail/smtptools/files/smtptools-0.2.3-cleanups.patch
@@ -0,0 +1,61 @@
+--- smtptools/usmtpd.c
++++ smtptools/usmtpd.c
+@@ -60,8 +60,8 @@
+ /* run */ static const char *reminfo;
+ /* run */ static const char *relayclient;
+
+-/* opt */ static unsigned long read_timeout=1200;
+-/* opt */ static unsigned long write_timeout=1200;
++/* opt */ static unsigned long u_read_timeout=1200;
++/* opt */ static unsigned long u_write_timeout=1200;
+ /* opt */ static char *log_spec_str=NULL;
+ /* opt */ static unsigned long aging=0;
+
+@@ -108,7 +108,7 @@
+ "Use $QMAILQUEUE to override, overrides --maildir\n", "PATH"},
+ {'r',"relaydb", UOGO_STRING,&relaydbname,1,
+ "Path to relaying control file", "FILE"},
+- {'R',"read-timeout", UOGO_ULONG,&read_timeout,0,
++ {'R',"read-timeout", UOGO_ULONG,&u_read_timeout,0,
+ "Timeout in seconds for reading from remote", "TIMEOUT"},
+ {'s',"max-size", UOGO_ULONG,&maxsize,0,
+ "Maximum size of messages\noverridden by $DATABYTES", "LIMIT"},
+@@ -117,7 +117,7 @@
+ "Used for DNS and envelope sender checking.\n"
+ "Default: accept messages during this time"},
+ /*123456789012345678901234567890123456789012345678901234567890*/
+- {'W',"write-timeout", UOGO_ULONG,&write_timeout,0,
++ {'W',"write-timeout", UOGO_ULONG,&u_write_timeout,0,
+ "Timeout in seconds for writing to remote.","TIMEOUT"},
+ {0,0}
+ };
+@@ -632,9 +632,9 @@
+ }
+
+ uoio_assign_r(&i,0,read,0);
+- i.timeout=read_timeout;
++ i.timeout=u_read_timeout;
+ uoio_assign_w(&o,1,write,0);
+- o.timeout=write_timeout;
++ o.timeout=u_write_timeout;
+
+ if (rblcheck) do_rbl_check(&o);
+
+--- smtptools/relaydb.c
++++ smtptools/relaydb.c
+@@ -1,4 +1,5 @@
+ #include "config.h"
++#include <string.h>
+ #include <unistd.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+--- smtptools/uostr.h
++++ smtptools/uostr.h
+@@ -1,6 +1,7 @@
+ #ifndef UOSTR_H
+ #define UOSTR_H
+
++#include <string.h>
+ #include "uocompiler.h" /* P__ */
+ #include "attribs.h"
+
diff --git a/net-mail/smtptools/smtptools-0.2.3.ebuild b/net-mail/smtptools/smtptools-0.2.3.ebuild
index 9163d45620eb..760e00af4902 100644
--- a/net-mail/smtptools/smtptools-0.2.3.ebuild
+++ b/net-mail/smtptools/smtptools-0.2.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/smtptools/smtptools-0.2.3.ebuild,v 1.9 2006/02/02 23:08:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/smtptools/smtptools-0.2.3.ebuild,v 1.10 2006/03/12 09:43:58 vapier Exp $
+
+inherit eutils
DESCRIPTION="A collection of tools to send or receive mails with SMTP"
HOMEPAGE="http://www.ohse.de/uwe/software/${PN}.html"
@@ -8,11 +10,17 @@ SRC_URI="ftp://ftp.ohse.de/uwe/releases/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 arm m68k mips ppc ppc64 s390 sh x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh x86"
IUSE=""
DEPEND=""
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-cleanups.patch
+}
+
src_compile() {
# the configure check looks for the symbol name 'dn_expand' in
# libresolv but later glibc's use the internal symbol name