summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-11-22 07:06:09 +0000
committerNick Hadaway <raker@gentoo.org>2002-11-22 07:06:09 +0000
commit4d9e4522e3877db4296b14d616d96afaee9bb051 (patch)
tree2fdc48fb657ea97d94bfe34b4287206aafec8730 /net-mail/pine
parentquick fix to use autoconf 2.1 (diff)
downloadgentoo-2-4d9e4522e3877db4296b14d616d96afaee9bb051.tar.gz
gentoo-2-4d9e4522e3877db4296b14d616d96afaee9bb051.tar.bz2
gentoo-2-4d9e4522e3877db4296b14d616d96afaee9bb051.zip
New pine. Lots of bugfixes and feature adds. Updated SSL variables,
fixed a sed statement and sorted patches w/comments. Currently marked unstable.
Diffstat (limited to 'net-mail/pine')
-rw-r--r--net-mail/pine/ChangeLog10
-rw-r--r--net-mail/pine/files/digest-pine-4.501
-rw-r--r--net-mail/pine/pine-4.50.ebuild120
3 files changed, 130 insertions, 1 deletions
diff --git a/net-mail/pine/ChangeLog b/net-mail/pine/ChangeLog
index b5ec1a0d47d9..cc8c4c8442d9 100644
--- a/net-mail/pine/ChangeLog
+++ b/net-mail/pine/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/pine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.6 2002/11/18 03:08:42 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.7 2002/11/22 07:06:09 raker Exp $
+
+*pine-4.50 (22 Nov 2002)
+
+ 22 Nov 2002; Nick Hadaway <raker@gentoo.org> pine-4.50.ebuild,
+ files/digest-pine-4.50 :
+ Version bump. lots of fixes. Threaded index is included.
+ Some SSL cleanup. Updated a sed statement. Sorted through
+ patches.
*pine-4.44-r5 (17 Nov 2002)
diff --git a/net-mail/pine/files/digest-pine-4.50 b/net-mail/pine/files/digest-pine-4.50
new file mode 100644
index 000000000000..81a5a0524429
--- /dev/null
+++ b/net-mail/pine/files/digest-pine-4.50
@@ -0,0 +1 @@
+MD5 5f517297242f625de9a9ccbaf48578f0 pine4.50.tar.gz 3772620
diff --git a/net-mail/pine/pine-4.50.ebuild b/net-mail/pine/pine-4.50.ebuild
new file mode 100644
index 000000000000..e434ffb3d50d
--- /dev/null
+++ b/net-mail/pine/pine-4.50.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.50.ebuild,v 1.1 2002/11/22 07:06:09 raker Exp $
+
+IUSE="ssl ldap"
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="A tool for reading, sending and managing electronic messages."
+SRC_URI="ftp://ftp.cac.washington.edu/${PN}/${PN}${PV}.tar.gz"
+HOMEPAGE="http://www.washington.edu/pine/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )"
+
+SLOT="0"
+LICENSE="PICO"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+
+src_unpack() {
+ unpack ${A}
+
+ # fix for Home and End keys
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.21-fixhome.patch
+
+ # flock() emulation
+ patch -d ${S} -p0 < ${FILESDIR}/imap-4.7c2-flock.patch
+ cp ${FILESDIR}/flock.c ${S}/imap/src/osdep/unix
+
+ # change /bin/passwd to /usr/bin/passwd
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.21-passwd.patch
+
+ if [ "`use ldap`" ] ; then
+ # link to shared ldap libs instead of static
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.30-ldap.patch
+ mkdir ${S}/ldap
+ ln -s /usr/lib ${S}/ldap/libraries
+ ln -s /usr/include ${S}/ldap/include
+ fi
+
+ # small flock() related fix
+ patch -d ${S} -p0 < ${FILESDIR}/pine-4.40-boguswarning.patch
+
+ # segfix? not sure what this is for but it still applies
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.31-segfix.patch
+
+ # change lock files from 0666 to 0600
+ patch -d ${S} -p0 < ${FILESDIR}/pine-4.40-lockfile-perm.patch
+
+ # add missing needed time.h includes
+ patch -d ${S} -p1 < ${FILESDIR}/imap-2000-time.patch
+
+ # gets rid of a call to stripwhitespace()
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.33-whitespace.patch
+
+ # 4.50 adds some support for multibyte character sets
+ #patch -d ${S} -p1 < ${FILESDIR}/pine-4.44-multibyte.patch
+
+ # threaded view and other diplay niceties are now built into
+ # pine 4.50
+ #bzcat ${FILESDIR}/fancy.patch.bz2 | patch -p0 || die "fancy patch failed"
+
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS}:" \
+ < makefile.orig > makefile.lnx
+
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+
+}
+
+src_compile() {
+ BUILDOPTS=""
+ if [ "`use ssl`" ]
+ then
+ BUILDOPTS="${BUILDOPTS} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
+ else
+ BUILDOPTS="${BUILDOPTS} NOSSL"
+ fi
+ if [ "`use ldap`" ]
+ then
+ ./contrib/ldap-setup lnp lnp
+ BUILDOPTS="${BUILDOPTS} LDAPCFLAGS=-DENABLE_LDAP"
+ else
+ BUILDOPTS="${BUILDOPTS} NOLDAP"
+ fi
+
+ ./build ${BUILDOPTS} lnp || die
+}
+
+src_install() {
+ into /usr
+ dobin bin/pine bin/pico bin/pilot bin/mtest bin/rpdump bin/rpload
+
+ doman doc/pine.1 doc/pico.1 doc/pilot.1 doc/rpdump.1 doc/rpload.1
+
+ insinto /etc
+ doins doc/mime.types
+ donewins doc/mailcap.unx mailcap
+
+ dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
+
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/FAQ imap/docs/RELNOTES
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+
+ docinto html/tech-notes
+ dodoc doc/tech-notes/*.html
+}
+
+
+
+