summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-04-12 23:18:10 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-04-12 23:18:10 +0000
commitfef787930b7b6c0c3d417509d0bca3c2a900472a (patch)
tree7678e1ba8ba933e0a3d499ccedbfc806c3e03596 /net-mail/mpack
parentnew upstream release, fixes #78435. added ~amd64 to KEYWORDS. (diff)
downloadgentoo-2-fef787930b7b6c0c3d417509d0bca3c2a900472a.tar.gz
gentoo-2-fef787930b7b6c0c3d417509d0bca3c2a900472a.tar.bz2
gentoo-2-fef787930b7b6c0c3d417509d0bca3c2a900472a.zip
Fix #84828, install some docs.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-mail/mpack')
-rw-r--r--net-mail/mpack/ChangeLog10
-rw-r--r--net-mail/mpack/files/mpack-1.5-malloc-fix.patch33
-rw-r--r--net-mail/mpack/mpack-1.5-r1.ebuild10
3 files changed, 48 insertions, 5 deletions
diff --git a/net-mail/mpack/ChangeLog b/net-mail/mpack/ChangeLog
index b9a9010ad949..b05d4e1396de 100644
--- a/net-mail/mpack/ChangeLog
+++ b/net-mail/mpack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/mpack
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mpack/ChangeLog,v 1.7 2004/07/01 22:33:24 eradicator Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mpack/ChangeLog,v 1.8 2005/04/12 23:18:10 ticho Exp $
+
+ 12 Apr 2005; Andrej Kacian <ticho@gentoo.org>
+ +files/mpack-1.5-malloc-fix.patch, mpack-1.5-r1.ebuild:
+ Fixed compile-time bug #84828, reported by Clemens Fruhwirth
+ <clemens@endorphin.org>. Patch provided by steveb <tp22a@softhome.net>. Also
+ install some documentation.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> mpack-1.5-r1.ebuild,
mpack-1.5.ebuild:
diff --git a/net-mail/mpack/files/mpack-1.5-malloc-fix.patch b/net-mail/mpack/files/mpack-1.5-malloc-fix.patch
new file mode 100644
index 000000000000..69777d87a889
--- /dev/null
+++ b/net-mail/mpack/files/mpack-1.5-malloc-fix.patch
@@ -0,0 +1,33 @@
+--- mpack/xmalloc.c 2005-03-11 10:51:39.000000000 +0100
++++ mpack/xmalloc.c 2005-03-11 10:51:39.000000000 +0100
+@@ -24,7 +24,7 @@
+ */
+ #include <stdio.h>
+ #include <string.h>
+-extern char *malloc(), *realloc();
++extern void *malloc(), *realloc();
+
+ char *xmalloc (size)
+ int size;
+--- mpack/unixos.c 2005-03-11 10:51:27.000000000 +0100
++++ mpack/unixos.c 2005-03-11 10:51:27.000000000 +0100
+@@ -37,7 +37,7 @@
+ #endif
+
+ extern int errno;
+-extern char *malloc();
++extern void *malloc();
+ extern char *getenv();
+
+ int overwrite_files = 0;
+--- mpack/unixpk.c 2005-03-11 10:53:22.000000000 +0100
++++ mpack/unixpk.c 2005-03-11 10:53:22.000000000 +0100
+@@ -165,7 +165,7 @@
+ strcpy(fnamebuf, "/tmp");
+ }
+ strcat(fnamebuf, "/mpackXXXXXX");
+- mktemp(fnamebuf);
++ mkstemp(fnamebuf);
+ outfname = strsave(fnamebuf);
+ }
+
diff --git a/net-mail/mpack/mpack-1.5-r1.ebuild b/net-mail/mpack/mpack-1.5-r1.ebuild
index 513f51685149..59dfa7ad2153 100644
--- a/net-mail/mpack/mpack-1.5-r1.ebuild
+++ b/net-mail/mpack/mpack-1.5-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mpack/mpack-1.5-r1.ebuild,v 1.9 2004/07/15 01:51:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mpack/mpack-1.5-r1.ebuild,v 1.10 2005/04/12 23:18:10 ticho Exp $
+
+inherit eutils
S=${WORKDIR}/${PN}
DESCRIPTION="Command-line MIME encoding and decoding utilities"
@@ -17,7 +19,8 @@ DEPEND="virtual/libc"
src_unpack() {
unpack ${P}-src.tar.Z
cd ${S}
- patch -l -p1 <${FILESDIR}/${P}-r1.patch
+ patch -l -p1 <${FILESDIR}/${P}-r1.patch || die "patch failed"
+ epatch ${FILESDIR}/${P}-malloc-fix.patch || die "epatch failed"
}
src_compile() {
@@ -27,4 +30,5 @@ src_compile() {
src_install () {
dodir /usr
make DESTDIR=${D}/usr install || die
+ dodoc README.* SCOPTIONS
}