summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-02-16 00:35:11 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-02-16 00:35:11 +0000
commita615aa4853d7b925ec105f42501b0f719e62ed30 (patch)
tree57170f5aaeaf7af267e4b04110ec75a546ee5fb4 /net-mail/lurker
parentFixup bashism #258300 by Felipe Lessa. (diff)
downloadgentoo-2-a615aa4853d7b925ec105f42501b0f719e62ed30.tar.gz
gentoo-2-a615aa4853d7b925ec105f42501b0f719e62ed30.tar.bz2
gentoo-2-a615aa4853d7b925ec105f42501b0f719e62ed30.zip
Add gcc-4.3 patch per bug 255910. Thanks to Gene Seto <geneseto@hotmail.com> for the patch.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/lurker')
-rw-r--r--net-mail/lurker/ChangeLog9
-rw-r--r--net-mail/lurker/files/lurker-2.1-gcc43.patch123
-rw-r--r--net-mail/lurker/lurker-2.1.ebuild6
3 files changed, 134 insertions, 4 deletions
diff --git a/net-mail/lurker/ChangeLog b/net-mail/lurker/ChangeLog
index 69870606bc12..45bb898efb63 100644
--- a/net-mail/lurker/ChangeLog
+++ b/net-mail/lurker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/lurker
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/lurker/ChangeLog,v 1.8 2008/08/16 17:31:58 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lurker/ChangeLog,v 1.9 2009/02/16 00:35:10 loki_val Exp $
+
+ 16 Feb 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/lurker-2.1-gcc43.patch, lurker-2.1.ebuild:
+ Add gcc-4.3 patch per bug 255910. Thanks to Gene Seto
+ <geneseto@hotmail.com> for the patch.
16 Aug 2008; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove strerror from metadata.xml (#89719)
diff --git a/net-mail/lurker/files/lurker-2.1-gcc43.patch b/net-mail/lurker/files/lurker-2.1-gcc43.patch
new file mode 100644
index 000000000000..1d728862b144
--- /dev/null
+++ b/net-mail/lurker/files/lurker-2.1-gcc43.patch
@@ -0,0 +1,123 @@
+diff -rupN lurker-2.1b/common/Thread.cpp lurker-2.1/common/Thread.cpp
+--- lurker-2.1b/common/Thread.cpp 2009-01-24 18:43:46.000000000 -0400
++++ lurker-2.1/common/Thread.cpp 2009-01-24 18:44:57.000000000 -0400
+@@ -25,7 +25,7 @@
+ #define _FILE_OFFSET_BITS 64
+
+ #include <cstdio>
+-#include <string>
++#include <cstring>
+
+ #include "md5.h"
+ #include "Keys.h"
+diff -rupN lurker-2.1b/index/Index.cpp lurker-2.1/index/Index.cpp
+--- lurker-2.1b/index/Index.cpp 2009-01-24 18:43:46.000000000 -0400
++++ lurker-2.1/index/Index.cpp 2009-01-24 18:45:48.000000000 -0400
+@@ -47,6 +47,7 @@
+ #include <string>
+ #include <vector>
+ #include <iostream>
++#include <cstdlib>
+
+ #include <unistd.h>
+ #include <iconv.h>
+diff -rupN lurker-2.1b/index/main.cpp lurker-2.1/index/main.cpp
+--- lurker-2.1b/index/main.cpp 2009-01-24 18:43:46.000000000 -0400
++++ lurker-2.1/index/main.cpp 2009-01-24 18:46:17.000000000 -0400
+@@ -38,6 +38,7 @@
+ #include <cstdio>
+ #include <ctime>
+ #include <cstdlib>
++#include <cstring>
+
+ #include <sys/stat.h>
+ #include <sys/types.h>
+diff -rupN lurker-2.1b/libesort/File.cpp lurker-2.1/libesort/File.cpp
+--- lurker-2.1b/libesort/File.cpp 2009-01-24 18:43:46.000000000 -0400
++++ lurker-2.1/libesort/File.cpp 2009-01-24 18:44:08.000000000 -0400
+@@ -34,6 +34,7 @@
+
+ #include <cassert>
+ #include <iostream>
++#include <cstring>
+
+ namespace ESort
+ {
+diff -rupN lurker-2.1b/libesort/Transaction.cpp lurker-2.1/libesort/Transaction.cpp
+--- lurker-2.1b/libesort/Transaction.cpp 2009-01-24 18:43:46.000000000 -0400
++++ lurker-2.1/libesort/Transaction.cpp 2009-01-24 18:44:21.000000000 -0400
+@@ -30,6 +30,7 @@
+
+ #include <iostream>
+ #include <cassert>
++#include <cstring>
+
+ /* #define DEBUG */
+
+diff -rupN lurker-2.1b/prune/attach.cpp lurker-2.1/prune/attach.cpp
+--- lurker-2.1b/prune/attach.cpp 2009-01-24 18:43:46.000000000 -0400
++++ lurker-2.1/prune/attach.cpp 2009-01-24 18:47:50.000000000 -0400
+@@ -28,6 +28,7 @@
+ #include <Keys.h>
+
+ #include <iostream>
++#include <cstdlib>
+
+ using namespace std;
+
+diff -rupN lurker-2.1b/prune/prune.cpp lurker-2.1/prune/prune.cpp
+--- lurker-2.1b/prune/prune.cpp 2009-01-24 18:43:46.000000000 -0400
++++ lurker-2.1/prune/prune.cpp 2009-01-24 18:47:32.000000000 -0400
+@@ -36,6 +36,7 @@
+ #include <utime.h>
+
+ #include <iostream>
++#include <cstdlib>
+
+ #include <cstring>
+ #include <cerrno>
+diff -rupN lurker-2.1b/render/attach.cpp lurker-2.1/render/attach.cpp
+--- lurker-2.1b/render/attach.cpp 2009-01-24 18:43:46.000000000 -0400
++++ lurker-2.1/render/attach.cpp 2009-01-24 18:48:34.000000000 -0400
+@@ -36,6 +36,7 @@
+ #include "Summary.h"
+
+ #include <iostream>
++#include <cstdlib>
+
+ using std::cout;
+
+diff -rupN lurker-2.1b/render/jump.cpp lurker-2.1/render/jump.cpp
+--- lurker-2.1b/render/jump.cpp 2009-01-24 18:43:46.000000000 -0400
++++ lurker-2.1/render/jump.cpp 2009-01-24 18:49:46.000000000 -0400
+@@ -28,6 +28,7 @@
+
+ #include <ctime>
+ #include <cstring>
++#include <cstdlib>
+
+ int main()
+ {
+diff -rupN lurker-2.1b/render/keyword.cpp lurker-2.1/render/keyword.cpp
+--- lurker-2.1b/render/keyword.cpp 2009-01-24 18:43:46.000000000 -0400
++++ lurker-2.1/render/keyword.cpp 2009-01-24 18:50:16.000000000 -0400
+@@ -31,6 +31,8 @@
+ #include <vector>
+
+ #include <ctime>
++#include <cstdlib>
++#include <cstring>
+
+ using std::set;
+
+diff -rupN lurker-2.1b/render/parse.cpp lurker-2.1/render/parse.cpp
+--- lurker-2.1b/render/parse.cpp 2009-01-24 18:43:46.000000000 -0400
++++ lurker-2.1/render/parse.cpp 2009-01-24 18:49:31.000000000 -0400
+@@ -25,6 +25,7 @@
+ #define _FILE_OFFSET_BITS 64
+
+ #include <iostream>
++#include <cstdlib>
+
+ #include "parse.h"
+
diff --git a/net-mail/lurker/lurker-2.1.ebuild b/net-mail/lurker/lurker-2.1.ebuild
index 02bb92cc0ca6..8c658c2ffa1c 100644
--- a/net-mail/lurker/lurker-2.1.ebuild
+++ b/net-mail/lurker/lurker-2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/lurker/lurker-2.1.ebuild,v 1.4 2008/02/05 10:51:18 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lurker/lurker-2.1.ebuild,v 1.5 2009/02/16 00:35:10 loki_val Exp $
inherit eutils webapp depend.apache
@@ -25,6 +25,8 @@ pkg_setup() {
src_unpack() {
unpack lurker-${PV}.tar.gz && cd "${S}"
unpack mimelib-3.1.1.tar.gz
+ cd ${S}
+ epatch "${FILESDIR}/${P}-gcc43.patch"
}
src_compile() {