summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-03-05 07:19:37 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-03-05 07:19:37 +0000
commitff3a3015ce2255c65be8e1cae3b37ee633f33f95 (patch)
tree25019d79de1a022a5573b497c3a3759b06b41859 /net-mail/libdbx/libdbx-1.0.3.ebuild
parentAzureus is a Java based bittorrent client. Initial ebuild provided by me and... (diff)
downloadgentoo-2-ff3a3015ce2255c65be8e1cae3b37ee633f33f95.tar.gz
gentoo-2-ff3a3015ce2255c65be8e1cae3b37ee633f33f95.tar.bz2
gentoo-2-ff3a3015ce2255c65be8e1cae3b37ee633f33f95.zip
Initial import
Diffstat (limited to 'net-mail/libdbx/libdbx-1.0.3.ebuild')
-rw-r--r--net-mail/libdbx/libdbx-1.0.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-mail/libdbx/libdbx-1.0.3.ebuild b/net-mail/libdbx/libdbx-1.0.3.ebuild
new file mode 100644
index 000000000000..c38a3598d7a2
--- /dev/null
+++ b/net-mail/libdbx/libdbx-1.0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libdbx/libdbx-1.0.3.ebuild,v 1.1 2004/03/05 07:19:37 phosphan Exp $
+
+DESCRIPTION="Tools and library for reading Outlook Express mailboxes (.dbx format)"
+HOMEPAGE="http://sourceforge.net/projects/ol2mbox"
+MY_PN="libdbx"
+MYFILE="${MY_PN}_${PV}.tgz"
+SRC_URI="mirror://sourceforge/ol2mbox/${MYFILE}"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+
+S="${WORKDIR}/${MY_PN}_${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e 's/-g/$(CFLAGS)/' Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe readoe readdbx
+ dodoc README* AUTHORS FILE-FORMAT
+ insinto /usr/include
+ doins libdbx.h libdbx++.h
+ insinto /usr/lib
+ doins libdbx.o
+}